Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Problem with warsaw installation for bank

Help for Current Versions of MX
Post Reply
User avatar
filipe
Forum Novice
Forum  Novice
Posts: 2
Joined: Thu Jul 04, 2019 12:08 pm

Problem with warsaw installation for bank

#1

Post by filipe » Thu Jul 04, 2019 12:19 pm

Help, I am the newest user of mx linux I am really enjoying the distro, but I have this problem here:

Calculando atualização... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Configurando warsaw (1.13.1-2) ...
Synchronizing state of warsaw.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable warsaw
Failed to start warsaw.service: Unknown unit: warsaw.service
See system logs and 'systemctl status warsaw.service' for details.
dpkg: erro ao processar o pacote warsaw (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
warsaw
E: Sub-process /usr/bin/dpkg returned an error code (1)


Thank you very much in advance.

Brazil - Rio de Janeiro

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 5120
Joined: Wed Jul 12, 2006 4:05 pm

Re: Problem with warsaw installation for bank

#2

Post by timkb4cq » Thu Jul 04, 2019 1:03 pm

Warsaw runs as a service. The installer package contains service scripts for both sysvinit and systemd.
MX-18 uses sysvinit by default.
In the Warsaw .deb file, the preinst, postinst, prerm, & postrm install scripts are not written correctly. They fail if parts of systemd are installed but systemd is not running.
The easiest way to get warsaw installed would by to reboot using the systemd option and then running

Code: Select all

sudo dpkg --configure warsaw
Warsaw should run whether MX is booted into sysvinit or systemd but it can only be installed or removed while systemd is running unless those scripts at var/lib/dpkg/info/warsaw.* are edited to remove the if stanzas which contain the systemctl command.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
filipe
Forum Novice
Forum  Novice
Posts: 2
Joined: Thu Jul 04, 2019 12:08 pm

Re: Problem with warsaw installation for bank

#3

Post by filipe » Thu Jul 04, 2019 11:27 pm

thank you very much :exclamation: :exclamation:

Post Reply

Return to “MX Help”