Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[solved] Live usb legacy bios and UEFI boot

Help for Current Versions of MX
Post Reply
mgp
Forum Novice
Forum  Novice
Posts: 12
Joined: Sun Jun 30, 2019 9:20 pm

[solved] Live usb legacy bios and UEFI boot

#1

Post by mgp » Wed Jul 03, 2019 10:02 am

I used the MX live usb tool to create a live install of my current system. I set up persistence and boot options which work fine and are retained when I boot it in legacy. When i boot it from UEFI not everything is retained. I'm just curious why i get a different setup with UEFI and is there a way to make legacy and UEFI boot to the same setup ?

System:
Host: crypto-mx Kernel: 5.1.0-14.2-liquorix-amd64 x86_64 bits: 64
compiler: gcc v: 6.3.0 Desktop: Xfce 4.12.3
Distro: MX-18.3_x64 Continuum Feb 9 2019
base: Debian GNU/Linux 9 (stretch)
Machine:
Type: Desktop System: LENOVO product: 10181 v: Lenovo K450e
serial: <filter>
Mobo: LENOVO model: N/A v: 31900058 STD serial: <filter> BIOS: LENOVO
v: I1KT44AUS date: 11/14/2014
CPU:
Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP
arch: Haswell rev: 3 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25540
Speed: 2684 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 924 2: 929
3: 990 4: 911
Graphics:
Device-1: NVIDIA GK208 [GeForce GT 730] vendor: Bitland Information
driver: nouveau v: kernel bus ID: 01:00.0
Display: x11 server: X.Org 1.19.2 driver: nouveau
unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz
OpenGL: renderer: NV106 v: 4.3 Mesa 18.2.6 direct render: Yes
Last edited by mgp on Tue Jul 09, 2019 9:34 am, edited 1 time in total.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8892
Joined: Wed Jul 12, 2006 2:10 am

Re: Live usb legacy bios and UEFI boot

#2

Post by Eadwine Rose » Wed Jul 03, 2019 10:05 am

Please paste the output of Quick System Info in MX Tools, that gives us all the info.

Thanks :)
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

mgp
Forum Novice
Forum  Novice
Posts: 12
Joined: Sun Jun 30, 2019 9:20 pm

Re: Live usb legacy bios and UEFI boot

#3

Post by mgp » Wed Jul 03, 2019 10:22 am

Thanks for the quick reply. here my quick info

Code: Select all

System:    Host: crypto-mx Kernel: 5.1.0-14.2-liquorix-amd64 x86_64 bits: 64 compiler: gcc 
           v: 6.3.0 Desktop: Xfce 4.12.3 Distro: MX-18.3_x64 Continuum Feb 9  2019 
           base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Desktop System: LENOVO product: 10181 v: Lenovo K450e serial: <filter> 
           Mobo: LENOVO model: N/A v: 31900058 STD serial: <filter> BIOS: LENOVO v: I1KT44AUS 
           date: 11/14/2014 
CPU:       Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP arch: Haswell rev: 3 
           L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25540 
           Speed: 2135 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 825 2: 827 3: 802 4: 798 
Graphics:  Device-1: NVIDIA GK208 [GeForce GT 730] vendor: Bitland Information driver: nouveau 
           v: kernel bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.2 driver: nouveau unloaded: fbdev,modesetting,vesa 
           resolution: 1600x900~60Hz 
           OpenGL: renderer: NV106 v: 4.3 Mesa 18.2.6 direct render: Yes 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Bitland Information 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.1.0-14.2-liquorix-amd64 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo 
           driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo 
           driver: rtl8821ae v: kernel port: c000 bus ID: 04:00.0 
           IF: wlan0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.60 TiB used: 7.44 GiB (0.5%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000DX001-1CM162 size: 931.51 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD6400AAKS-75A7B0 size: 596.17 GiB 
           ID-3: /dev/sdc type: USB vendor: Patriot model: Patriot Memory size: 115.50 GiB 
Partition: ID-1: / size: 6.13 GiB used: 117.8 MiB (1.9%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A gpu: nouveau temp: 52 C 
           Fan Speeds (RPM): N/A 
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb http://mirrors.rit.edu/mxlinux/mx-packages/antix/stretch stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb http://mirrors.rit.edu/mxlinux/mx-packages/mx/repo/ stretch main non-free
           Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
           1: deb [arch=amd64] https://repo.skype.com/deb stable main
           No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:      Processes: 211 Uptime: 16m Memory: 7.72 GiB used: 798.2 MiB (10.1%) Init: SysVinit 
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.33 
I created the stick on a legacy bios system. I disabled UEFI and used legacy because at first Linux was a little finicky about UEFI. I tried the UEFI boot just out of curiosity. Thinking about it now is it possible i get the different setup because my systems are set to legacy boot and not UEFI ? Changes I made to the system after booting in legacy mode like noswap boot option or desktop changes are retained in legacy boot. If i reboot and use UEFI those changes aren't retained. I don't get the menu choices at the bottom of the boot screen in UEFI. I'm happy with the live usb encryption works everything is goo but i am assuming if i plug it into a UEFI only PC i wont get my custom setup that i have when i boot legacy. I would like to have the same setup where ever i boot if possible. Thanks

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 12137
Joined: Sun Dec 16, 2007 1:17 pm

Re: Live usb legacy bios and UEFI boot

#4

Post by dolphin_oracle » Wed Jul 03, 2019 10:28 am

the UEFI uses a different boot system than the legacy boot. but the same options should hae been saved. is there not a "Custom" entry in the menu?
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

mgp
Forum Novice
Forum  Novice
Posts: 12
Joined: Sun Jun 30, 2019 9:20 pm

Re: Live usb legacy bios and UEFI boot

#5

Post by mgp » Tue Jul 09, 2019 9:33 am

Yes there is a custom menu option.Thanks. I edited the UEFI boot options to match the legacy boot options and it appears to be working. I am booting into the same system with either boot option. Going to mark it solved. Thanks

Post Reply

Return to “MX Help”