Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

Help for Current Versions of MX
User avatar
mike lovin
Forum Novice
Forum  Novice
Posts: 54
Joined: Fri Dec 21, 2018 3:46 am

18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#1

Post by mike lovin » Fri Jun 07, 2019 11:50 am

Trying to bring back to life an old HP desktop that was an Windows XP machine, but I'm having issues with the 18.3 live usb 32 bit, the live usb boots and runs great, even installs, but Firefox and the Firewall do not work when clicked, is there a fix for this? I tested the live usb on my 9 year old Dell laptop and the Firefox and Firewall work on it, so I know the live usb is working ok. I'm including the HP desktop specs below.

Code: Select all

System:    Host: mx Kernel: 4.19.0-5-686-pae i686 bits: 32 compiler: gcc v: 6.3.0 
           Desktop: Xfce 4.12.3 Distro: MX-18.3_386 Continuum May 26  2019 
           base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Desktop System: HP Pavilion 061 product: DW217A-ABA A535W 
           v: 0nB1211RE101KELUT10 serial: <filter> 
           Mobo: ASUSTek model: Kelut v: 2.02 serial: <filter> BIOS: Phoenix v: 3.03 
           date: 02/09/2004 
CPU:       Topology: Single Core model: AMD Athlon XP 3200+ bits: 32 type: UP arch: K7 Palomino+ 
           L2 cache: 512 KiB 
           flags: pae sse bogomips: 4400 
           Speed: 2200 MHz min/max: N/A Core speed (MHz): 1: 2200 
Graphics:  Device-1: NVIDIA NV44A [GeForce 6200] vendor: eVga.com. driver: nouveau v: kernel 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.2 driver: nouveau unloaded: fbdev,modesetting,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: NV4A v: 2.1 Mesa 18.2.6 direct render: Yes 
Audio:     Device-1: VIA VT8233/A/8235/8237 AC97 Audio vendor: ASUSTeK driver: snd_via82xx 
           v: kernel bus ID: 00:11.5 
           Sound Server: ALSA v: k4.19.0-5-686-pae 
Network:   Device-1: VIA VT6102/VT6103 [Rhine-II] vendor: ASUSTeK driver: via-rhine v: N/A 
           port: e000 bus ID: 00:12.0 
           IF: eth0 state: unknown speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 74.53 GiB used: 4.66 GiB (6.2%) 
           ID-1: /dev/sda vendor: Western Digital model: WD800BB-00JHC0 size: 74.53 GiB 
Partition: ID-1: / size: 24.48 GiB used: 4.57 GiB (18.7%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 46.53 GiB used: 73.8 MiB (0.2%) fs: ext4 dev: /dev/dm-0 
           ID-3: swap-1 size: 2.00 GiB used: 13.4 MiB (0.7%) fs: swap dev: /dev/dm-1 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb http://iso.mxrepo.com/antix/stretch stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb http://mirrors.rit.edu/mxlinux/mx-packages/mx/repo/ stretch main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:      Processes: 174 Uptime: 6m Memory: 557.2 MiB used: 250.2 MiB (44.9%) Init: SysVinit 
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.33 
Last edited by mike lovin on Fri Jun 07, 2019 12:24 pm, edited 1 time in total.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8681
Joined: Wed Jul 12, 2006 2:10 am

Re: 18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#2

Post by Eadwine Rose » Fri Jun 07, 2019 11:52 am

Can you please put the output into code tags? Like so: [code] content here [/code]


Thanks :)
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
mike lovin
Forum Novice
Forum  Novice
Posts: 54
Joined: Fri Dec 21, 2018 3:46 am

Re: 18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#3

Post by mike lovin » Fri Jun 07, 2019 11:55 am

Eadwine Rose wrote:
Fri Jun 07, 2019 11:52 am
Can you please put the output into code tags? Like so: [code] content here [/code]


Thanks :)
Like this?

Code: Select all

System:    Host: mx Kernel: 4.19.0-5-686-pae i686 bits: 32 compiler: gcc v: 6.3.0 
           Desktop: Xfce 4.12.3 Distro: MX-18.3_386 Continuum May 26  2019 
           base: Debian GNU/Linux 9 (stretch) 
Machine:   Type: Desktop System: HP Pavilion 061 product: DW217A-ABA A535W 
           v: 0nB1211RE101KELUT10 serial: <filter> 
           Mobo: ASUSTek model: Kelut v: 2.02 serial: <filter> BIOS: Phoenix v: 3.03 
           date: 02/09/2004 
CPU:       Topology: Single Core model: AMD Athlon XP 3200+ bits: 32 type: UP arch: K7 Palomino+ 
           L2 cache: 512 KiB 
           flags: pae sse bogomips: 4400 
           Speed: 2200 MHz min/max: N/A Core speed (MHz): 1: 2200 
Graphics:  Device-1: NVIDIA NV44A [GeForce 6200] vendor: eVga.com. driver: nouveau v: kernel 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.19.2 driver: nouveau unloaded: fbdev,modesetting,vesa 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: NV4A v: 2.1 Mesa 18.2.6 direct render: Yes 
Audio:     Device-1: VIA VT8233/A/8235/8237 AC97 Audio vendor: ASUSTeK driver: snd_via82xx 
           v: kernel bus ID: 00:11.5 
           Sound Server: ALSA v: k4.19.0-5-686-pae 
Network:   Device-1: VIA VT6102/VT6103 [Rhine-II] vendor: ASUSTeK driver: via-rhine v: N/A 
           port: e000 bus ID: 00:12.0 
           IF: eth0 state: unknown speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 74.53 GiB used: 4.66 GiB (6.2%) 
           ID-1: /dev/sda vendor: Western Digital model: WD800BB-00JHC0 size: 74.53 GiB 
Partition: ID-1: / size: 24.48 GiB used: 4.57 GiB (18.7%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 46.53 GiB used: 73.8 MiB (0.2%) fs: ext4 dev: /dev/dm-0 
           ID-3: swap-1 size: 2.00 GiB used: 13.4 MiB (0.7%) fs: swap dev: /dev/dm-1 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Repos:     Active apt repos in: /etc/apt/sources.list.d/antix.list 
           1: deb http://iso.mxrepo.com/antix/stretch stretch main
           Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
           1: deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/debian.list 
           1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
           2: deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt repos in: /etc/apt/sources.list.d/mx.list 
           1: deb http://mirrors.rit.edu/mxlinux/mx-packages/mx/repo/ stretch main non-free
           No active apt repos in: /etc/apt/sources.list.d/various.list 
Info:      Processes: 174 Uptime: 6m Memory: 557.2 MiB used: 250.2 MiB (44.9%) Init: SysVinit 
           runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.33 

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8681
Joined: Wed Jul 12, 2006 2:10 am

Re: 18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#4

Post by Eadwine Rose » Fri Jun 07, 2019 12:02 pm

Yes, in your original post ;) :)

But thanks!
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 11902
Joined: Sun Dec 16, 2007 1:17 pm

Re: 18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#5

Post by dolphin_oracle » Fri Jun 07, 2019 12:03 pm

I believe firefox requires sse2 instruction set, which your process doesn't apparently support.

I think we have a non-sse2 palemoon in the repo that you can try.

Not sure about the firewall. I assume you mean the gui doesn't open? You might resort to using the cli with "ufw".
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18.3
lenovo s21e - antiX-19 beta 2 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
mike lovin
Forum Novice
Forum  Novice
Posts: 54
Joined: Fri Dec 21, 2018 3:46 am

Re: 18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#6

Post by mike lovin » Fri Jun 07, 2019 12:09 pm

Eadwine Rose wrote:
Fri Jun 07, 2019 12:02 pm
Yes, in your original post ;) :)

But thanks!
Sorry, I guess that's why I'm shown as a novice :grin: Thanks for your help!

User avatar
mike lovin
Forum Novice
Forum  Novice
Posts: 54
Joined: Fri Dec 21, 2018 3:46 am

Re: 18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#7

Post by mike lovin » Fri Jun 07, 2019 12:15 pm

dolphin_oracle wrote:
Fri Jun 07, 2019 12:03 pm
I believe firefox requires sse2 instruction set, which your process doesn't apparently support.

I think we have a non-sse2 palemoon in the repo that you can try.

Not sure about the firewall. I assume you mean the gui doesn't open? You might resort to using the cli with "ufw".
I also tried chromium browser, it failed to open too, I assume it requires sse2 also.

I will try the non-sse2 palemoon from the repo.

You are correct, the gui failed to open.

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8681
Joined: Wed Jul 12, 2006 2:10 am

Re: 18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#8

Post by Eadwine Rose » Fri Jun 07, 2019 12:17 pm

You're welcome. You can edit that post by using the little pencil icon.
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
mike lovin
Forum Novice
Forum  Novice
Posts: 54
Joined: Fri Dec 21, 2018 3:46 am

Re: 18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#9

Post by mike lovin » Fri Jun 07, 2019 12:28 pm

Eadwine Rose wrote:
Fri Jun 07, 2019 12:17 pm
You're welcome. You can edit that post by using the little pencil icon.
I corrected my mistake, I'll try to remember that next time. Thank you and Dolphin Oracle for your help! :)

Btw I love MX, I use it everyday on my laptop! :)

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8681
Joined: Wed Jul 12, 2006 2:10 am

Re: 18.3 Live USB 32 bit [Firefox and Firewall don't work on this HP machine]

#10

Post by Eadwine Rose » Fri Jun 07, 2019 12:32 pm

That's ok, it all takes some getting used to ;)

Welcome!
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

Post Reply

Return to “MX Help”