Welcome!
Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Updator is broken [Solved]

Help for Current Versions of MX
User avatar
Mauser
Forum Guide
Forum Guide
Posts: 1068
Joined: Mon Jun 27, 2016 7:32 pm

Re: Updator is broken

#11

Post by Mauser » Wed May 22, 2019 12:09 pm

kmathern wrote:
Wed May 22, 2019 12:07 pm
Mauser wrote:
Wed May 22, 2019 12:04 pm
I don't see any such setting. I never change the default setting of full upgrade in "Preferences."
In the preferences dialog it's full upgrade (recommended) & basic upgrade.

Full upgrade is the default.
Yes, I have it set to: Full upgrade.
I am command line illiterate. :confused:

User avatar
Mauser
Forum Guide
Forum Guide
Posts: 1068
Joined: Mon Jun 27, 2016 7:32 pm

Re: Updator is broken

#12

Post by Mauser » Wed May 22, 2019 12:11 pm

kmathern wrote:
Wed May 22, 2019 12:05 pm
I'm not seeing it here. Also I'm unclear on what the problem is, is it that the notification doesn't go away after installing upgrades, or is the Upgrade button on the View&Upgrade window unresponsive. @Jerry, what does `apt-get dist-upgrade -s' show?
The notification doesn't go away no matter how many times I update it.
I am command line illiterate. :confused:

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 11491
Joined: Sun Dec 16, 2007 1:17 pm

Re: Updator is broken

#13

Post by dolphin_oracle » Wed May 22, 2019 12:15 pm

Mauser wrote:
Wed May 22, 2019 10:46 am
I received updates for MX Linux this morning. I updated but it still showed on the panel icon that I had updates. I did the update again. Still showing updates. I rebooted the computer and it still shows updates available. I updated again and it still shows updates available. Does anyone know the fix for this?
can you post the output?
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-18
lenovo s21e - MX-18, antiX-17.3.1 (live-USB)
FYI: mx "test" repo is not the same thing as debian testing repo.

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9590
Joined: Wed Jul 12, 2006 2:26 pm

Re: Updator is broken

#14

Post by kmathern » Wed May 22, 2019 12:17 pm

Could you run the updater's history option and post it's output? That way I can see what updates you received today.

User avatar
Mauser
Forum Guide
Forum Guide
Posts: 1068
Joined: Mon Jun 27, 2016 7:32 pm

Re: Updator is broken

#15

Post by Mauser » Wed May 22, 2019 12:18 pm

dolphin_oracle wrote:
Wed May 22, 2019 12:15 pm
Mauser wrote:
Wed May 22, 2019 10:46 am
I received updates for MX Linux this morning. I updated but it still showed on the panel icon that I had updates. I did the update again. Still showing updates. I rebooted the computer and it still shows updates available. I updated again and it still shows updates available. Does anyone know the fix for this?
can you post the output?
You mean this?

Code: Select all

  full upgrade
  Reading package lists...
  Building dependency tree...
  Reading state information...
  Calculating upgrade...
  The following packages were automatically installed and are no longer required:
     breeze-cursor-theme (4:5.8.5-2)
     breeze-icon-theme (4:5.28.0-1)
     gir1.2-gtk-2.0 (2.24.31-2)
     gir1.2-rsvg-2.0 (2.40.16-1+b1)
     gnome-colors-common (5.5.1-2)
     icoutils (0.31.2-1.1)
     kde-telepathy-data (15.08.3-1.1)
     kdeplasma-addons-data (4:5.8.5-2)
     libaccounts-glib0 (1.21-1+b1)
     libaccounts-qt5-1 (1.13+20150813-1)
     libasound2:i386 (1.1.3-5)
     libasound2-plugins:i386 (1.1.1-1)
     libasyncns0:i386 (0.8-6)
     libavcodec57:i386 (7:3.3.4-1mx17+2)
     libavresample3:i386 (7:3.3.4-1mx17+2)
     libavutil55:i386 (7:3.3.4-1mx17+2)
     libbsd0:i386 (0.8.3-1)
     libcairo2:i386 (1.14.8-1)
     libcap2:i386 (1:2.25-1)
     libcrystalhd3:i386 (1:0.0~git20110715.fdd2f19-12)
     libdb5.3:i386 (5.3.28-12+deb9u1)
     libdbus-1-3:i386 (1.10.26-0+deb9u1)
     libdecoration0 (2:0.8.14-0mx17+1)
     libdrm-dev (2.4.95-1~mx17+1)
     libdrm2:i386 (2.4.95-1~mx17+1)
     libegl1-mesa-dev (18.2.6-1~mx17+1)
     libepoxy-dev (1.3.1-2)
     libexif12:i386 (0.6.21-2+b2)
     libexpat1:i386 (2.2.0-2+deb9u1)
     libffi6:i386 (3.2.1-6)
     libflac8:i386 (1.3.2-1)
     libfontconfig1:i386 (1:2.13.0-5~mx17+1)
     libfreetype6:i386 (2.8.1-2~mx17+1)
     libgcrypt20:i386 (1.7.6-2+deb9u3)
     libgd3:i386 (2.2.4-2+deb9u4)
     libgl1-mesa-dev (18.2.6-1~mx17+1)
     libgles1 (1.1.0-1~mx17+1)
     libglib2.0-0:i386 (2.56.1-2~mx17+1)
     libglu1-mesa-dev (9.0.0-2.1)
     libglvnd-core-dev (1.1.0-1~mx17+1)
     libglvnd-dev (1.1.0-1~mx17+1)
     libgmp10:i386 (2:6.1.2+dfsg-1)
     libgnutls30:i386 (3.5.8-5+deb9u4)
     libgomp1:i386 (6.3.0-18+deb9u1)
     libgpg-error0:i386 (1.26-2)
     libgphoto2-6:i386 (2.5.12-1)
     libgphoto2-port12:i386 (2.5.12-1)
     libgsm1:i386 (1.0.13-4+b2)
     libgstreamer-plugins-base1.0-0:i386 (1.10.4-1+deb9u1)
     libgstreamer1.0-0:i386 (1.10.4-1)
     libhogweed4:i386 (3.3-1+b2)
     libice6:i386 (2:1.0.9-2)
     libicu57:i386 (57.1-6+deb9u2)
     libidn11:i386 (1.33-1)
     libjack-jackd2-0:i386 (1.9.10+20150825git1ed50c92~dfsg-5)
     libjbig0:i386 (2.1-3.1+b2)
     libjpeg62-turbo:i386 (1:1.5.1-2)
     libkaccounts1 (16.08.3-1)
     libkdecorations2-5v5 (4:5.8.4-1)
     libkdecorations2private5v5 (4:5.8.4-1)
     libkf5activities5 (5.28.0-1)
     libkf5calendarevents5 (5.28.0-1)
     libkf5coreaddons-bin-dev (5.28.0-2)
     libkf5coreaddons-dev (5.28.0-2)
     libkf5globalaccelprivate5 (5.28.0-1)
     libkf5idletime5 (5.28.0-1)
     libkf5js5 (5.28.0-1)
     libkf5kcmutils-data (5.28.0-2)
     libkf5khtml-data (5.28.0-2)
     libkf5notifyconfig-data (5.28.0-1)
     libkf5people-data (5.28.0-1)
     libkf5peoplebackend5 (5.28.0-1)
     libkf5style5 (5.28.0-1)
     libkf5waylandclient5 (4:5.28.0-1)
     libkf5waylandserver5 (4:5.28.0-1)
     liblcms2-2:i386 (2.8-4+deb9u1)
     libldap-2.4-2:i386 (2.4.44+dfsg-5+deb9u2)
     libltdl7:i386 (2.4.6-2)
     liblz4-1:i386 (0.0~r131-2+b1)
     libmarco-private1 (1.16.1-1)
     libmission-control-plugins0 (1:5.16.3-2.1)
     libmp3lame0:i386 (3.99.5+repack1-9+b2)
     libmpg123-0:i386 (1.23.8-1+b1)
     libncurses5:i386 (6.0+20161126-1+deb9u2)
     libnettle6:i386 (3.3-1+b2)
     libnuma1:i386 (2.0.11-2.1)
     libogg0:i386 (1.3.2-1)
     libopenal1:i386 (1:1.17.2-4+b2)
     libopengl0 (1.1.0-1~mx17+1)
     libopenjp2-7:i386 (2.1.2-1.1+deb9u3)
     libopus0:i386 (1.2~alpha2-1)
     liborc-0.4-0:i386 (1:0.4.26-2)
     libp11-kit0:i386 (0.23.3-2)
     libpixman-1-0:i386 (0.34.0-1)
     libpng16-16:i386 (1.6.28-1+deb9u1)
     libpthread-stubs0-dev (0.3-4)
     libpulse0:i386 (10.0-1+deb9u1)
     libqt4-svg (4:4.8.7+dfsg-11)
     libqt5multimedia5 (5.7.1~20161021-2)
     libqt5multimediaquick-p5 (5.7.1~20161021-2)
     libqt5x11extras5-dev (5.7.1~20161021-2)
     libquazip1 (0.7.2-1)
     libsamplerate0:i386 (0.1.8-8+b2)
     libsasl2-2:i386 (2.1.27~101-g0780600+dfsg-3)
     libsasl2-modules-db:i386 (2.1.27~101-g0780600+dfsg-3)
     libshine3:i386 (3.1.0-5)
     libsignon-extension1 (8.59-1+b2)
     libsignon-glib1 (1.12-2)
     libsignon-plugins-common1 (8.59-1+b2)
     libsignon-qt5-1 (8.59-1+b2)
     libsm6:i386 (2:1.2.2-1+b3)
     libsnappy1v5:i386 (1.1.3-3)
     libsndfile1:i386 (1.0.27-3)
     libsndio6.1:i386 (1.1.0-3)
     libsoxr0:i386 (0.1.2-2)
     libspeex1:i386 (1.2~rc1.2-1+b2)
     libspeexdsp1:i386 (1.2~rc1.2-1+b2)
     libstdc++6:i386 (6.3.0-18+deb9u1)
     libswresample2:i386 (7:3.3.4-1mx17+2)
     libsystemd0:i386 (232-25+deb9u11)
     libtasn1-6:i386 (4.10-1.1+deb9u1)
     libtelepathy-logger-qt5 (15.04.0-2)
     libtelepathy-qt4-2 (0.9.6.1-6.1)
     libtelepathy-qt5-0 (0.9.6.1-6.1)
     libtheora0:i386 (1.1.1+dfsg.1-14+b1)
     libtiff5:i386 (4.0.8-2+deb9u4)
     libtwolame0:i386 (0.3.13-2)
     libudev1:i386 (232-25+deb9u11)
     libusb-1.0-0:i386 (2:1.0.21-1)
     libuser1 (1:0.62~dfsg-0.1)
     libva-drm1 (1.7.3-2)
     libva-drm2:i386 (2.3.0-2~mx17+1)
     libva-wayland1 (1.7.3-2)
     libva-x11-1 (1.7.3-2)
     libva-x11-2:i386 (2.3.0-2~mx17+1)
     libva1 (1.7.3-2)
     libva2:i386 (2.3.0-2~mx17+1)
     libvdpau1:i386 (1.1.1-6)
     libvorbis0a:i386 (1.3.5-4+deb9u2)
     libvorbisenc2:i386 (1.3.5-4+deb9u2)
     libvpx4:i386 (1.6.1-3+deb9u1)
     libwavpack1:i386 (5.0.0-2+deb9u2)
     libwayland-bin (1.16.0-1~mx17+1)
     libwayland-dev (1.16.0-1~mx17+1)
     libwebp6:i386 (0.6.1-2~mx17+1)
     libwebpmux3:i386 (0.6.1-2~mx17+1)
     libwine (1.8.7-2)
     libwrap0:i386 (7.6.q-26)
     libx11-6:i386 (2:1.6.4-3+deb9u1)
     libx11-dev (2:1.6.4-3+deb9u1)
     libx11-xcb-dev (2:1.6.4-3+deb9u1)
     libx11-xcb1:i386 (2:1.6.4-3+deb9u1)
     libx264-148:i386 (2:0.148.2748+git97eaef2-1)
     libx265-146:i386 (2.6-3~mx17+1)
     libxau-dev (1:1.0.8-1)
     libxau6:i386 (1:1.0.8-1)
     libxcb-composite0 (1.12-3)
     libxcb-cursor0 (0.1.1-3)
     libxcb-damage0 (1.12-3)
     libxcb-dri2-0-dev (1.12-3)
     libxcb-dri3-dev (1.12-3)
     libxcb-glx0-dev (1.12-3)
     libxcb-present-dev (1.12-3)
     libxcb-randr0-dev (1.12-3)
     libxcb-render0:i386 (1.12-3)
     libxcb-render0-dev (1.12-3)
     libxcb-shape0-dev (1.12-3)
     libxcb-shm0:i386 (1.12-3)
     libxcb-sync-dev (1.12-3)
     libxcb-xfixes0-dev (1.12-3)
     libxcb1:i386 (1.12-3)
     libxcb1-dev (1.12-3)
     libxdamage-dev (1:1.1.4-2+b3)
     libxdmcp-dev (1:1.1.2-3)
     libxdmcp6:i386 (1:1.1.2-3)
     libxext-dev (2:1.3.3-1+b2)
     libxext6:i386 (2:1.3.3-1+b2)
     libxfixes-dev (1:5.0.3-1)
     libxfixes3:i386 (1:5.0.3-1)
     libxi6:i386 (2:1.7.9-1)
     libxml2:i386 (2.9.4+dfsg1-2.2+deb9u2)
     libxpm4:i386 (1:3.5.12-1)
     libxrender1:i386 (1:0.9.10-1)
     libxshmfence-dev (1.2-1+b2)
     libxtst6:i386 (2:1.2.3-1)
     libxvidcore4:i386 (2:1.3.4-1+b2)
     libxxf86vm-dev (1:1.1.4-1+b2)
     libzvbi0:i386 (0.2.35-13)
     mesa-common-dev (18.2.6-1~mx17+1)
     ocl-icd-libopencl1:i386 (2.2.11-1)
     python-crypto (2.6.1-7)
     python-dnspython (1.15.0-1+deb9u1)
     python-ldb (2:1.1.27-1+deb9u1)
     python-libuser (1:0.62~dfsg-0.1)
     python-smbc (1.0.15.6-1)
     python-tdb (1.3.11-2)
     python-wxgtk3.0 (3.0.2.0+dfsg-4)
     python-wxversion (3.0.2.0+dfsg-4)
     qml-module-qtmultimedia (5.7.1~20161021-2)
     qml-module-qtquick-controls-styles-breeze (4:5.8.5-2)
     qt5-qmake (5.7.1+dfsg-3+deb9u1)
     qtbase5-dev (5.7.1+dfsg-3+deb9u1)
     qtbase5-dev-tools (5.7.1+dfsg-3+deb9u1)
     signon-plugin-oauth2 (0.22-1)
     signon-plugin-password (8.59-1+b2)
     signon-ui-service (0.17+15.10.20150810-2)
     signon-ui-x11 (0.17+15.10.20150810-2+b1)
     signond (8.59-1+b2)
     telepathy-accounts-signon (1.0-1)
     wine-gecko2.47 (2.47-1mx17+1)
     wine-gecko2.47:i386 (2.47-1mx17+1)
     wine-mono4.7.1 (1.0-1mx17+1)
     wine-staging (2.21-1mx17+1)
     wine-staging-amd64 (2.21-1mx17+1)
     wine-staging-i386:i386 (2.21-1mx17+1)
     x11proto-core-dev (7.0.31-1)
     x11proto-damage-dev (1:1.2.1-2)
     x11proto-dri2-dev (2.8-2)
     x11proto-fixes-dev (1:5.0-2)
     x11proto-gl-dev (1.4.17-1)
     x11proto-input-dev (2.3.2-1)
     x11proto-kb-dev (1.0.7-1)
     x11proto-xext-dev (7.3.0-1)
     x11proto-xf86vidmode-dev (2.3.1-2)
     xorg-sgml-doctools (1:1.11-1)
     xtrans-dev (1.3.5-1)
  Use 'apt autoremove' to remove them.
  The following packages will be upgraded:
     firefox (66.0.5~mozillabinaries-1mx17+1 => 67.0~mozillabinaries-1mx17+1)
     mx-packageinstaller-pkglist (19.05.02 => 19.05.03)
     partition-info (1.8 => 1.10)
  3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  Need to get 12.4 kB/50.7 MB of archives.
  After this operation, 818 kB of additional disk space will be used.
I am command line illiterate. :confused:

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9590
Joined: Wed Jul 12, 2006 2:26 pm

Re: Updator is broken

#16

Post by kmathern » Wed May 22, 2019 12:26 pm

Mauser wrote:
Wed May 22, 2019 12:18 pm
You mean this?

Code: Select all

  full upgrade
  Reading package lists...
  Building dependency tree...
  Reading state information...
  Calculating upgrade...
  The following packages were automatically installed and are no longer required:
     breeze-cursor-theme (4:5.8.5-2)
     breeze-icon-theme (4:5.28.0-1)
     gir1.2-gtk-2.0 (2.24.31-2)
     gir1.2-rsvg-2.0 (2.40.16-1+b1)
     gnome-colors-common (5.5.1-2)
     icoutils (0.31.2-1.1)
     kde-telepathy-data (15.08.3-1.1)
     kdeplasma-addons-data (4:5.8.5-2)
     libaccounts-glib0 (1.21-1+b1)
     libaccounts-qt5-1 (1.13+20150813-1)
     libasound2:i386 (1.1.3-5)
     libasound2-plugins:i386 (1.1.1-1)
     libasyncns0:i386 (0.8-6)
     libavcodec57:i386 (7:3.3.4-1mx17+2)
     libavresample3:i386 (7:3.3.4-1mx17+2)
     libavutil55:i386 (7:3.3.4-1mx17+2)
     libbsd0:i386 (0.8.3-1)
     libcairo2:i386 (1.14.8-1)
     libcap2:i386 (1:2.25-1)
     libcrystalhd3:i386 (1:0.0~git20110715.fdd2f19-12)
     libdb5.3:i386 (5.3.28-12+deb9u1)
     libdbus-1-3:i386 (1.10.26-0+deb9u1)
     libdecoration0 (2:0.8.14-0mx17+1)
     libdrm-dev (2.4.95-1~mx17+1)
     libdrm2:i386 (2.4.95-1~mx17+1)
     libegl1-mesa-dev (18.2.6-1~mx17+1)
     libepoxy-dev (1.3.1-2)
     libexif12:i386 (0.6.21-2+b2)
     libexpat1:i386 (2.2.0-2+deb9u1)
     libffi6:i386 (3.2.1-6)
     libflac8:i386 (1.3.2-1)
     libfontconfig1:i386 (1:2.13.0-5~mx17+1)
     libfreetype6:i386 (2.8.1-2~mx17+1)
     libgcrypt20:i386 (1.7.6-2+deb9u3)
     libgd3:i386 (2.2.4-2+deb9u4)
     libgl1-mesa-dev (18.2.6-1~mx17+1)
     libgles1 (1.1.0-1~mx17+1)
     libglib2.0-0:i386 (2.56.1-2~mx17+1)
     libglu1-mesa-dev (9.0.0-2.1)
     libglvnd-core-dev (1.1.0-1~mx17+1)
     libglvnd-dev (1.1.0-1~mx17+1)
     libgmp10:i386 (2:6.1.2+dfsg-1)
     libgnutls30:i386 (3.5.8-5+deb9u4)
     libgomp1:i386 (6.3.0-18+deb9u1)
     libgpg-error0:i386 (1.26-2)
     libgphoto2-6:i386 (2.5.12-1)
     libgphoto2-port12:i386 (2.5.12-1)
     libgsm1:i386 (1.0.13-4+b2)
     libgstreamer-plugins-base1.0-0:i386 (1.10.4-1+deb9u1)
     libgstreamer1.0-0:i386 (1.10.4-1)
     libhogweed4:i386 (3.3-1+b2)
     libice6:i386 (2:1.0.9-2)
     libicu57:i386 (57.1-6+deb9u2)
     libidn11:i386 (1.33-1)
     libjack-jackd2-0:i386 (1.9.10+20150825git1ed50c92~dfsg-5)
     libjbig0:i386 (2.1-3.1+b2)
     libjpeg62-turbo:i386 (1:1.5.1-2)
     libkaccounts1 (16.08.3-1)
     libkdecorations2-5v5 (4:5.8.4-1)
     libkdecorations2private5v5 (4:5.8.4-1)
     libkf5activities5 (5.28.0-1)
     libkf5calendarevents5 (5.28.0-1)
     libkf5coreaddons-bin-dev (5.28.0-2)
     libkf5coreaddons-dev (5.28.0-2)
     libkf5globalaccelprivate5 (5.28.0-1)
     libkf5idletime5 (5.28.0-1)
     libkf5js5 (5.28.0-1)
     libkf5kcmutils-data (5.28.0-2)
     libkf5khtml-data (5.28.0-2)
     libkf5notifyconfig-data (5.28.0-1)
     libkf5people-data (5.28.0-1)
     libkf5peoplebackend5 (5.28.0-1)
     libkf5style5 (5.28.0-1)
     libkf5waylandclient5 (4:5.28.0-1)
     libkf5waylandserver5 (4:5.28.0-1)
     liblcms2-2:i386 (2.8-4+deb9u1)
     libldap-2.4-2:i386 (2.4.44+dfsg-5+deb9u2)
     libltdl7:i386 (2.4.6-2)
     liblz4-1:i386 (0.0~r131-2+b1)
     libmarco-private1 (1.16.1-1)
     libmission-control-plugins0 (1:5.16.3-2.1)
     libmp3lame0:i386 (3.99.5+repack1-9+b2)
     libmpg123-0:i386 (1.23.8-1+b1)
     libncurses5:i386 (6.0+20161126-1+deb9u2)
     libnettle6:i386 (3.3-1+b2)
     libnuma1:i386 (2.0.11-2.1)
     libogg0:i386 (1.3.2-1)
     libopenal1:i386 (1:1.17.2-4+b2)
     libopengl0 (1.1.0-1~mx17+1)
     libopenjp2-7:i386 (2.1.2-1.1+deb9u3)
     libopus0:i386 (1.2~alpha2-1)
     liborc-0.4-0:i386 (1:0.4.26-2)
     libp11-kit0:i386 (0.23.3-2)
     libpixman-1-0:i386 (0.34.0-1)
     libpng16-16:i386 (1.6.28-1+deb9u1)
     libpthread-stubs0-dev (0.3-4)
     libpulse0:i386 (10.0-1+deb9u1)
     libqt4-svg (4:4.8.7+dfsg-11)
     libqt5multimedia5 (5.7.1~20161021-2)
     libqt5multimediaquick-p5 (5.7.1~20161021-2)
     libqt5x11extras5-dev (5.7.1~20161021-2)
     libquazip1 (0.7.2-1)
     libsamplerate0:i386 (0.1.8-8+b2)
     libsasl2-2:i386 (2.1.27~101-g0780600+dfsg-3)
     libsasl2-modules-db:i386 (2.1.27~101-g0780600+dfsg-3)
     libshine3:i386 (3.1.0-5)
     libsignon-extension1 (8.59-1+b2)
     libsignon-glib1 (1.12-2)
     libsignon-plugins-common1 (8.59-1+b2)
     libsignon-qt5-1 (8.59-1+b2)
     libsm6:i386 (2:1.2.2-1+b3)
     libsnappy1v5:i386 (1.1.3-3)
     libsndfile1:i386 (1.0.27-3)
     libsndio6.1:i386 (1.1.0-3)
     libsoxr0:i386 (0.1.2-2)
     libspeex1:i386 (1.2~rc1.2-1+b2)
     libspeexdsp1:i386 (1.2~rc1.2-1+b2)
     libstdc++6:i386 (6.3.0-18+deb9u1)
     libswresample2:i386 (7:3.3.4-1mx17+2)
     libsystemd0:i386 (232-25+deb9u11)
     libtasn1-6:i386 (4.10-1.1+deb9u1)
     libtelepathy-logger-qt5 (15.04.0-2)
     libtelepathy-qt4-2 (0.9.6.1-6.1)
     libtelepathy-qt5-0 (0.9.6.1-6.1)
     libtheora0:i386 (1.1.1+dfsg.1-14+b1)
     libtiff5:i386 (4.0.8-2+deb9u4)
     libtwolame0:i386 (0.3.13-2)
     libudev1:i386 (232-25+deb9u11)
     libusb-1.0-0:i386 (2:1.0.21-1)
     libuser1 (1:0.62~dfsg-0.1)
     libva-drm1 (1.7.3-2)
     libva-drm2:i386 (2.3.0-2~mx17+1)
     libva-wayland1 (1.7.3-2)
     libva-x11-1 (1.7.3-2)
     libva-x11-2:i386 (2.3.0-2~mx17+1)
     libva1 (1.7.3-2)
     libva2:i386 (2.3.0-2~mx17+1)
     libvdpau1:i386 (1.1.1-6)
     libvorbis0a:i386 (1.3.5-4+deb9u2)
     libvorbisenc2:i386 (1.3.5-4+deb9u2)
     libvpx4:i386 (1.6.1-3+deb9u1)
     libwavpack1:i386 (5.0.0-2+deb9u2)
     libwayland-bin (1.16.0-1~mx17+1)
     libwayland-dev (1.16.0-1~mx17+1)
     libwebp6:i386 (0.6.1-2~mx17+1)
     libwebpmux3:i386 (0.6.1-2~mx17+1)
     libwine (1.8.7-2)
     libwrap0:i386 (7.6.q-26)
     libx11-6:i386 (2:1.6.4-3+deb9u1)
     libx11-dev (2:1.6.4-3+deb9u1)
     libx11-xcb-dev (2:1.6.4-3+deb9u1)
     libx11-xcb1:i386 (2:1.6.4-3+deb9u1)
     libx264-148:i386 (2:0.148.2748+git97eaef2-1)
     libx265-146:i386 (2.6-3~mx17+1)
     libxau-dev (1:1.0.8-1)
     libxau6:i386 (1:1.0.8-1)
     libxcb-composite0 (1.12-3)
     libxcb-cursor0 (0.1.1-3)
     libxcb-damage0 (1.12-3)
     libxcb-dri2-0-dev (1.12-3)
     libxcb-dri3-dev (1.12-3)
     libxcb-glx0-dev (1.12-3)
     libxcb-present-dev (1.12-3)
     libxcb-randr0-dev (1.12-3)
     libxcb-render0:i386 (1.12-3)
     libxcb-render0-dev (1.12-3)
     libxcb-shape0-dev (1.12-3)
     libxcb-shm0:i386 (1.12-3)
     libxcb-sync-dev (1.12-3)
     libxcb-xfixes0-dev (1.12-3)
     libxcb1:i386 (1.12-3)
     libxcb1-dev (1.12-3)
     libxdamage-dev (1:1.1.4-2+b3)
     libxdmcp-dev (1:1.1.2-3)
     libxdmcp6:i386 (1:1.1.2-3)
     libxext-dev (2:1.3.3-1+b2)
     libxext6:i386 (2:1.3.3-1+b2)
     libxfixes-dev (1:5.0.3-1)
     libxfixes3:i386 (1:5.0.3-1)
     libxi6:i386 (2:1.7.9-1)
     libxml2:i386 (2.9.4+dfsg1-2.2+deb9u2)
     libxpm4:i386 (1:3.5.12-1)
     libxrender1:i386 (1:0.9.10-1)
     libxshmfence-dev (1.2-1+b2)
     libxtst6:i386 (2:1.2.3-1)
     libxvidcore4:i386 (2:1.3.4-1+b2)
     libxxf86vm-dev (1:1.1.4-1+b2)
     libzvbi0:i386 (0.2.35-13)
     mesa-common-dev (18.2.6-1~mx17+1)
     ocl-icd-libopencl1:i386 (2.2.11-1)
     python-crypto (2.6.1-7)
     python-dnspython (1.15.0-1+deb9u1)
     python-ldb (2:1.1.27-1+deb9u1)
     python-libuser (1:0.62~dfsg-0.1)
     python-smbc (1.0.15.6-1)
     python-tdb (1.3.11-2)
     python-wxgtk3.0 (3.0.2.0+dfsg-4)
     python-wxversion (3.0.2.0+dfsg-4)
     qml-module-qtmultimedia (5.7.1~20161021-2)
     qml-module-qtquick-controls-styles-breeze (4:5.8.5-2)
     qt5-qmake (5.7.1+dfsg-3+deb9u1)
     qtbase5-dev (5.7.1+dfsg-3+deb9u1)
     qtbase5-dev-tools (5.7.1+dfsg-3+deb9u1)
     signon-plugin-oauth2 (0.22-1)
     signon-plugin-password (8.59-1+b2)
     signon-ui-service (0.17+15.10.20150810-2)
     signon-ui-x11 (0.17+15.10.20150810-2+b1)
     signond (8.59-1+b2)
     telepathy-accounts-signon (1.0-1)
     wine-gecko2.47 (2.47-1mx17+1)
     wine-gecko2.47:i386 (2.47-1mx17+1)
     wine-mono4.7.1 (1.0-1mx17+1)
     wine-staging (2.21-1mx17+1)
     wine-staging-amd64 (2.21-1mx17+1)
     wine-staging-i386:i386 (2.21-1mx17+1)
     x11proto-core-dev (7.0.31-1)
     x11proto-damage-dev (1:1.2.1-2)
     x11proto-dri2-dev (2.8-2)
     x11proto-fixes-dev (1:5.0-2)
     x11proto-gl-dev (1.4.17-1)
     x11proto-input-dev (2.3.2-1)
     x11proto-kb-dev (1.0.7-1)
     x11proto-xext-dev (7.3.0-1)
     x11proto-xf86vidmode-dev (2.3.1-2)
     xorg-sgml-doctools (1:1.11-1)
     xtrans-dev (1.3.5-1)
  Use 'apt autoremove' to remove them.
  The following packages will be upgraded:
     firefox (66.0.5~mozillabinaries-1mx17+1 => 67.0~mozillabinaries-1mx17+1)
     mx-packageinstaller-pkglist (19.05.02 => 19.05.03)
     partition-info (1.8 => 1.10)
  3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  Need to get 12.4 kB/50.7 MB of archives.
  After this operation, 818 kB of additional disk space will be used.
It's not exactly what I asked for but it'll work, firefox mx-packageinstaller-pkglist & partition-info were your upgrades.

User avatar
Mauser
Forum Guide
Forum Guide
Posts: 1068
Joined: Mon Jun 27, 2016 7:32 pm

Re: Updator is broken

#17

Post by Mauser » Wed May 22, 2019 12:32 pm

kmathern wrote:
Wed May 22, 2019 12:26 pm
Mauser wrote:
Wed May 22, 2019 12:18 pm
You mean this?

Code: Select all

  full upgrade
  Reading package lists...
  Building dependency tree...
  Reading state information...
  Calculating upgrade...
  The following packages were automatically installed and are no longer required:
     breeze-cursor-theme (4:5.8.5-2)
     breeze-icon-theme (4:5.28.0-1)
     gir1.2-gtk-2.0 (2.24.31-2)
     gir1.2-rsvg-2.0 (2.40.16-1+b1)
     gnome-colors-common (5.5.1-2)
     icoutils (0.31.2-1.1)
     kde-telepathy-data (15.08.3-1.1)
     kdeplasma-addons-data (4:5.8.5-2)
     libaccounts-glib0 (1.21-1+b1)
     libaccounts-qt5-1 (1.13+20150813-1)
     libasound2:i386 (1.1.3-5)
     libasound2-plugins:i386 (1.1.1-1)
     libasyncns0:i386 (0.8-6)
     libavcodec57:i386 (7:3.3.4-1mx17+2)
     libavresample3:i386 (7:3.3.4-1mx17+2)
     libavutil55:i386 (7:3.3.4-1mx17+2)
     libbsd0:i386 (0.8.3-1)
     libcairo2:i386 (1.14.8-1)
     libcap2:i386 (1:2.25-1)
     libcrystalhd3:i386 (1:0.0~git20110715.fdd2f19-12)
     libdb5.3:i386 (5.3.28-12+deb9u1)
     libdbus-1-3:i386 (1.10.26-0+deb9u1)
     libdecoration0 (2:0.8.14-0mx17+1)
     libdrm-dev (2.4.95-1~mx17+1)
     libdrm2:i386 (2.4.95-1~mx17+1)
     libegl1-mesa-dev (18.2.6-1~mx17+1)
     libepoxy-dev (1.3.1-2)
     libexif12:i386 (0.6.21-2+b2)
     libexpat1:i386 (2.2.0-2+deb9u1)
     libffi6:i386 (3.2.1-6)
     libflac8:i386 (1.3.2-1)
     libfontconfig1:i386 (1:2.13.0-5~mx17+1)
     libfreetype6:i386 (2.8.1-2~mx17+1)
     libgcrypt20:i386 (1.7.6-2+deb9u3)
     libgd3:i386 (2.2.4-2+deb9u4)
     libgl1-mesa-dev (18.2.6-1~mx17+1)
     libgles1 (1.1.0-1~mx17+1)
     libglib2.0-0:i386 (2.56.1-2~mx17+1)
     libglu1-mesa-dev (9.0.0-2.1)
     libglvnd-core-dev (1.1.0-1~mx17+1)
     libglvnd-dev (1.1.0-1~mx17+1)
     libgmp10:i386 (2:6.1.2+dfsg-1)
     libgnutls30:i386 (3.5.8-5+deb9u4)
     libgomp1:i386 (6.3.0-18+deb9u1)
     libgpg-error0:i386 (1.26-2)
     libgphoto2-6:i386 (2.5.12-1)
     libgphoto2-port12:i386 (2.5.12-1)
     libgsm1:i386 (1.0.13-4+b2)
     libgstreamer-plugins-base1.0-0:i386 (1.10.4-1+deb9u1)
     libgstreamer1.0-0:i386 (1.10.4-1)
     libhogweed4:i386 (3.3-1+b2)
     libice6:i386 (2:1.0.9-2)
     libicu57:i386 (57.1-6+deb9u2)
     libidn11:i386 (1.33-1)
     libjack-jackd2-0:i386 (1.9.10+20150825git1ed50c92~dfsg-5)
     libjbig0:i386 (2.1-3.1+b2)
     libjpeg62-turbo:i386 (1:1.5.1-2)
     libkaccounts1 (16.08.3-1)
     libkdecorations2-5v5 (4:5.8.4-1)
     libkdecorations2private5v5 (4:5.8.4-1)
     libkf5activities5 (5.28.0-1)
     libkf5calendarevents5 (5.28.0-1)
     libkf5coreaddons-bin-dev (5.28.0-2)
     libkf5coreaddons-dev (5.28.0-2)
     libkf5globalaccelprivate5 (5.28.0-1)
     libkf5idletime5 (5.28.0-1)
     libkf5js5 (5.28.0-1)
     libkf5kcmutils-data (5.28.0-2)
     libkf5khtml-data (5.28.0-2)
     libkf5notifyconfig-data (5.28.0-1)
     libkf5people-data (5.28.0-1)
     libkf5peoplebackend5 (5.28.0-1)
     libkf5style5 (5.28.0-1)
     libkf5waylandclient5 (4:5.28.0-1)
     libkf5waylandserver5 (4:5.28.0-1)
     liblcms2-2:i386 (2.8-4+deb9u1)
     libldap-2.4-2:i386 (2.4.44+dfsg-5+deb9u2)
     libltdl7:i386 (2.4.6-2)
     liblz4-1:i386 (0.0~r131-2+b1)
     libmarco-private1 (1.16.1-1)
     libmission-control-plugins0 (1:5.16.3-2.1)
     libmp3lame0:i386 (3.99.5+repack1-9+b2)
     libmpg123-0:i386 (1.23.8-1+b1)
     libncurses5:i386 (6.0+20161126-1+deb9u2)
     libnettle6:i386 (3.3-1+b2)
     libnuma1:i386 (2.0.11-2.1)
     libogg0:i386 (1.3.2-1)
     libopenal1:i386 (1:1.17.2-4+b2)
     libopengl0 (1.1.0-1~mx17+1)
     libopenjp2-7:i386 (2.1.2-1.1+deb9u3)
     libopus0:i386 (1.2~alpha2-1)
     liborc-0.4-0:i386 (1:0.4.26-2)
     libp11-kit0:i386 (0.23.3-2)
     libpixman-1-0:i386 (0.34.0-1)
     libpng16-16:i386 (1.6.28-1+deb9u1)
     libpthread-stubs0-dev (0.3-4)
     libpulse0:i386 (10.0-1+deb9u1)
     libqt4-svg (4:4.8.7+dfsg-11)
     libqt5multimedia5 (5.7.1~20161021-2)
     libqt5multimediaquick-p5 (5.7.1~20161021-2)
     libqt5x11extras5-dev (5.7.1~20161021-2)
     libquazip1 (0.7.2-1)
     libsamplerate0:i386 (0.1.8-8+b2)
     libsasl2-2:i386 (2.1.27~101-g0780600+dfsg-3)
     libsasl2-modules-db:i386 (2.1.27~101-g0780600+dfsg-3)
     libshine3:i386 (3.1.0-5)
     libsignon-extension1 (8.59-1+b2)
     libsignon-glib1 (1.12-2)
     libsignon-plugins-common1 (8.59-1+b2)
     libsignon-qt5-1 (8.59-1+b2)
     libsm6:i386 (2:1.2.2-1+b3)
     libsnappy1v5:i386 (1.1.3-3)
     libsndfile1:i386 (1.0.27-3)
     libsndio6.1:i386 (1.1.0-3)
     libsoxr0:i386 (0.1.2-2)
     libspeex1:i386 (1.2~rc1.2-1+b2)
     libspeexdsp1:i386 (1.2~rc1.2-1+b2)
     libstdc++6:i386 (6.3.0-18+deb9u1)
     libswresample2:i386 (7:3.3.4-1mx17+2)
     libsystemd0:i386 (232-25+deb9u11)
     libtasn1-6:i386 (4.10-1.1+deb9u1)
     libtelepathy-logger-qt5 (15.04.0-2)
     libtelepathy-qt4-2 (0.9.6.1-6.1)
     libtelepathy-qt5-0 (0.9.6.1-6.1)
     libtheora0:i386 (1.1.1+dfsg.1-14+b1)
     libtiff5:i386 (4.0.8-2+deb9u4)
     libtwolame0:i386 (0.3.13-2)
     libudev1:i386 (232-25+deb9u11)
     libusb-1.0-0:i386 (2:1.0.21-1)
     libuser1 (1:0.62~dfsg-0.1)
     libva-drm1 (1.7.3-2)
     libva-drm2:i386 (2.3.0-2~mx17+1)
     libva-wayland1 (1.7.3-2)
     libva-x11-1 (1.7.3-2)
     libva-x11-2:i386 (2.3.0-2~mx17+1)
     libva1 (1.7.3-2)
     libva2:i386 (2.3.0-2~mx17+1)
     libvdpau1:i386 (1.1.1-6)
     libvorbis0a:i386 (1.3.5-4+deb9u2)
     libvorbisenc2:i386 (1.3.5-4+deb9u2)
     libvpx4:i386 (1.6.1-3+deb9u1)
     libwavpack1:i386 (5.0.0-2+deb9u2)
     libwayland-bin (1.16.0-1~mx17+1)
     libwayland-dev (1.16.0-1~mx17+1)
     libwebp6:i386 (0.6.1-2~mx17+1)
     libwebpmux3:i386 (0.6.1-2~mx17+1)
     libwine (1.8.7-2)
     libwrap0:i386 (7.6.q-26)
     libx11-6:i386 (2:1.6.4-3+deb9u1)
     libx11-dev (2:1.6.4-3+deb9u1)
     libx11-xcb-dev (2:1.6.4-3+deb9u1)
     libx11-xcb1:i386 (2:1.6.4-3+deb9u1)
     libx264-148:i386 (2:0.148.2748+git97eaef2-1)
     libx265-146:i386 (2.6-3~mx17+1)
     libxau-dev (1:1.0.8-1)
     libxau6:i386 (1:1.0.8-1)
     libxcb-composite0 (1.12-3)
     libxcb-cursor0 (0.1.1-3)
     libxcb-damage0 (1.12-3)
     libxcb-dri2-0-dev (1.12-3)
     libxcb-dri3-dev (1.12-3)
     libxcb-glx0-dev (1.12-3)
     libxcb-present-dev (1.12-3)
     libxcb-randr0-dev (1.12-3)
     libxcb-render0:i386 (1.12-3)
     libxcb-render0-dev (1.12-3)
     libxcb-shape0-dev (1.12-3)
     libxcb-shm0:i386 (1.12-3)
     libxcb-sync-dev (1.12-3)
     libxcb-xfixes0-dev (1.12-3)
     libxcb1:i386 (1.12-3)
     libxcb1-dev (1.12-3)
     libxdamage-dev (1:1.1.4-2+b3)
     libxdmcp-dev (1:1.1.2-3)
     libxdmcp6:i386 (1:1.1.2-3)
     libxext-dev (2:1.3.3-1+b2)
     libxext6:i386 (2:1.3.3-1+b2)
     libxfixes-dev (1:5.0.3-1)
     libxfixes3:i386 (1:5.0.3-1)
     libxi6:i386 (2:1.7.9-1)
     libxml2:i386 (2.9.4+dfsg1-2.2+deb9u2)
     libxpm4:i386 (1:3.5.12-1)
     libxrender1:i386 (1:0.9.10-1)
     libxshmfence-dev (1.2-1+b2)
     libxtst6:i386 (2:1.2.3-1)
     libxvidcore4:i386 (2:1.3.4-1+b2)
     libxxf86vm-dev (1:1.1.4-1+b2)
     libzvbi0:i386 (0.2.35-13)
     mesa-common-dev (18.2.6-1~mx17+1)
     ocl-icd-libopencl1:i386 (2.2.11-1)
     python-crypto (2.6.1-7)
     python-dnspython (1.15.0-1+deb9u1)
     python-ldb (2:1.1.27-1+deb9u1)
     python-libuser (1:0.62~dfsg-0.1)
     python-smbc (1.0.15.6-1)
     python-tdb (1.3.11-2)
     python-wxgtk3.0 (3.0.2.0+dfsg-4)
     python-wxversion (3.0.2.0+dfsg-4)
     qml-module-qtmultimedia (5.7.1~20161021-2)
     qml-module-qtquick-controls-styles-breeze (4:5.8.5-2)
     qt5-qmake (5.7.1+dfsg-3+deb9u1)
     qtbase5-dev (5.7.1+dfsg-3+deb9u1)
     qtbase5-dev-tools (5.7.1+dfsg-3+deb9u1)
     signon-plugin-oauth2 (0.22-1)
     signon-plugin-password (8.59-1+b2)
     signon-ui-service (0.17+15.10.20150810-2)
     signon-ui-x11 (0.17+15.10.20150810-2+b1)
     signond (8.59-1+b2)
     telepathy-accounts-signon (1.0-1)
     wine-gecko2.47 (2.47-1mx17+1)
     wine-gecko2.47:i386 (2.47-1mx17+1)
     wine-mono4.7.1 (1.0-1mx17+1)
     wine-staging (2.21-1mx17+1)
     wine-staging-amd64 (2.21-1mx17+1)
     wine-staging-i386:i386 (2.21-1mx17+1)
     x11proto-core-dev (7.0.31-1)
     x11proto-damage-dev (1:1.2.1-2)
     x11proto-dri2-dev (2.8-2)
     x11proto-fixes-dev (1:5.0-2)
     x11proto-gl-dev (1.4.17-1)
     x11proto-input-dev (2.3.2-1)
     x11proto-kb-dev (1.0.7-1)
     x11proto-xext-dev (7.3.0-1)
     x11proto-xf86vidmode-dev (2.3.1-2)
     xorg-sgml-doctools (1:1.11-1)
     xtrans-dev (1.3.5-1)
  Use 'apt autoremove' to remove them.
  The following packages will be upgraded:
     firefox (66.0.5~mozillabinaries-1mx17+1 => 67.0~mozillabinaries-1mx17+1)
     mx-packageinstaller-pkglist (19.05.02 => 19.05.03)
     partition-info (1.8 => 1.10)
  3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  Need to get 12.4 kB/50.7 MB of archives.
  After this operation, 818 kB of additional disk space will be used.
It's not exactly what I asked for but it'll work, firefox mx-packageinstaller-pkglist & partition-info were your upgrades.
But it still shows that they need to be upgraded even though I ran the upgrade.
I am command line illiterate. :confused:

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9590
Joined: Wed Jul 12, 2006 2:26 pm

Re: Updator is broken

#18

Post by kmathern » Wed May 22, 2019 12:40 pm

Mauser wrote:
Wed May 22, 2019 12:32 pm
But it still shows that they need to be upgraded even though I ran the upgrade.
So what does the output in the terminal look like if you proceed with the upgrade(s) the 2nd or 3rd (or whatever) time?

User avatar
Mauser
Forum Guide
Forum Guide
Posts: 1068
Joined: Mon Jun 27, 2016 7:32 pm

Re: Updator is broken

#19

Post by Mauser » Wed May 22, 2019 12:48 pm

kmathern wrote:
Wed May 22, 2019 12:40 pm
Mauser wrote:
Wed May 22, 2019 12:32 pm
But it still shows that they need to be upgraded even though I ran the upgrade.
So what does the output in the terminal look like if you proceed with the upgrade(s) the 2nd or 3rd (or whatever) time?
When I removed the check for "automatically close terminal window when full/basic upgrade complete" So I could give you that information, it fixed it. I put the check back for it. All is O.K. now. Thank you and all who tried to help.
I am command line illiterate. :confused:

User avatar
figueroa
Forum Regular
Forum Regular
Posts: 396
Joined: Fri Dec 21, 2018 12:20 am

Re: Updator is broken

#20

Post by figueroa » Wed May 22, 2019 12:49 pm

Cannot duplicate here on 64 bit install in VirtualBox. Cannot duplicate on my 32 bit install on 10 year old AMD box. These don't use the same repositories. No leads here.
Andy Figueroa
Using Unix from 1984; GNU/Linux from 1993

Post Reply

Return to “MX Help”