Welcome!
Important information
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.1 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

ERROR - GPG in Synaptic

Help for Current Versions of MX
Post Reply
User avatar
crazysquirrel
Forum Novice
Forum  Novice
Posts: 53
Joined: Thu Mar 14, 2019 5:59 pm

ERROR - GPG in Synaptic

#1

Post by crazysquirrel » Fri Mar 15, 2019 9:53 pm

GPG error: http://iso.mxrepo.com/antix/stretch stretch InRelease: The following signatures were invalid: EXPKEYSIG DB36CDF3452F0C20 antiX (antix repo) <antix@daveserver.info>The repository 'http://iso.mxrepo.com/antix/stretch stretch InRelease' is not signed.
Mx 17.1, dual boot with XP Media Center Edition 2005, core i5, 4gb ram, 2TB hybrid Seagate + other storage drives.

I NEED MULTISYSTEM just like the one I can get for *buntu derivatives. NOT THE ISO ONE.

User avatar
fehlix
Forum Veteran
Forum Veteran
Posts: 3111
Joined: Wed Apr 11, 2018 5:09 pm

Re: ERROR - GPG in Synaptic

#2

Post by fehlix » Fri Mar 15, 2019 9:56 pm

crazysquirrel wrote:
Fri Mar 15, 2019 9:53 pm
GPG error: http://iso.mxrepo.com/antix/stretch stretch InRelease: The following signatures were invalid: EXPKEYSIG DB36CDF3452F0C20 antiX (antix repo) <antix@daveserver.info>The repository 'http://iso.mxrepo.com/antix/stretch stretch InRelease' is not signed.
Yes, we know.
Close synaptic . Open terminal and do this:

Code: Select all

sudo apt update
sudo apt install antix-archive-keyring
sudo apt update
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 18296
Joined: Fri Dec 15, 2006 8:07 pm

Re: ERROR - GPG in Synaptic

#3

Post by Stevo » Fri Mar 15, 2019 10:12 pm

Isn't that already installed by default? Then you just need to upgrade the version in the MX repo.

Code: Select all

sudo apt upgrade
Then it can be upgraded again to the version in the antiX repo after another apt update.

User avatar
crazysquirrel
Forum Novice
Forum  Novice
Posts: 53
Joined: Thu Mar 14, 2019 5:59 pm

Re: ERROR - GPG in Synaptic

#4

Post by crazysquirrel » Fri Mar 15, 2019 10:24 pm

successful now it says I have more packages to upgrade.
And it upgraded firefox Grrr....
Mx 17.1, dual boot with XP Media Center Edition 2005, core i5, 4gb ram, 2TB hybrid Seagate + other storage drives.

I NEED MULTISYSTEM just like the one I can get for *buntu derivatives. NOT THE ISO ONE.

User avatar
crazysquirrel
Forum Novice
Forum  Novice
Posts: 53
Joined: Thu Mar 14, 2019 5:59 pm

Re: ERROR - GPG in Synaptic

#5

Post by crazysquirrel » Fri Mar 15, 2019 10:32 pm

got *SOME* hair left lol
enough for today I think
Thanks everyone for the help
Mx 17.1, dual boot with XP Media Center Edition 2005, core i5, 4gb ram, 2TB hybrid Seagate + other storage drives.

I NEED MULTISYSTEM just like the one I can get for *buntu derivatives. NOT THE ISO ONE.

Post Reply

Return to “MX Help”