Welcome!
Important information
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-18 Final release info here
-- Migration Information to MX-18 here
-- antiX-17.3 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] gave up waiting for root file system device

Help for Current Versions of MX
Post Reply
User avatar
rgnr
Forum Novice
Forum  Novice
Posts: 3
Joined: Sat Jan 12, 2019 1:54 am

[SOLVED] gave up waiting for root file system device

#1

Post by rgnr » Sat Jan 12, 2019 3:17 am

Yo fawkz! New troll here XD! And here's the deal:
After successful installation I got https://ibb.co/z2y3KkS
Obviously the computer fails to find the root partition, but it's there. And the uuid is correct. However if i boot with the installation usb inserted I don't receive this error, but receive others about missing stuff. Guess the computer somehow expects an installation usb to be the root partition.
Also the installation usb fails to boot on uefi system, at least mine. Tried dd, rufus, unetbootin, etcher, result is either "Could not find antix/liuxfs" or "Could not find /efi/loopback". Only booting from iso worked.
Last edited by rgnr on Sat Jan 12, 2019 4:43 pm, edited 1 time in total.

User avatar
BitJam
Forum Guide
Forum Guide
Posts: 2705
Joined: Sat Aug 22, 2009 11:36 pm

Re: gave up waiting for root file system device

#2

Post by BitJam » Sat Jan 12, 2019 3:45 am

rgnr wrote:
Sat Jan 12, 2019 3:17 am
Also the installation usb fails to boot on uefi system, at least mine. Tried dd, rufus, unetbootin, etcher, result is either "Could not find antix/liuxfs" or "Could not find /efi/loopback". Only booting from iso worked.
This can happen if you are using a defective usb device such as the SanDisk Ultra Fit. This will also cause the error you encountered on the installed system. For the live system, the work-around is to unplug and replug the usb-stick while we are looking for the linuxfs file. It's also possible to get these errors if you have very unusual hardware that we (and Debian) have not encountered before. Did you try booting the live system in "failsafe" mode?
Will I cry when it's all over?
When I die will I see Heaven?

User avatar
rgnr
Forum Novice
Forum  Novice
Posts: 3
Joined: Sat Jan 12, 2019 1:54 am

Re: gave up waiting for root file system device

#3

Post by rgnr » Sat Jan 12, 2019 5:52 am

Hah! Found it! The solution was pretty simple. I've compared the grub entries of mx and another distro which boots and found the source of evil. Here it is:
BOOT_IMAGE=(loop)/antiX/vmlinuz root=UUID= in linux /boot/vmlinuz-4.19.0-1-amd64 root=UUID=8e874424-0386-4f3a-8094-53290017c3f1 ro
Guess the line was copied because the installer was called from an iso file and not live usb.
Now it boots normal. Guess the topic can be closed. :)

User avatar
BitJam
Forum Guide
Forum Guide
Posts: 2705
Joined: Sat Aug 22, 2009 11:36 pm

Re: gave up waiting for root file system device

#4

Post by BitJam » Sat Jan 12, 2019 6:07 am

Good work. We wil fix this. Thank you.
Will I cry when it's all over?
When I die will I see Heaven?

turtlebay777
Forum Regular
Forum Regular
Posts: 296
Joined: Sat Apr 14, 2018 2:40 pm

Re: gave up waiting for root file system device

#5

Post by turtlebay777 » Sat Jan 12, 2019 8:10 am

rgnr wrote:
Sat Jan 12, 2019 5:52 am
Guess the topic can be closed. :)
@rgnr

Congrats. It is normal here for the OP to close the thread themselves by editing the original #1 post by adding [SOLVED]to the subject line.

Post Reply

Return to “MX Help”