Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

no sound in play on linux

Help for Current Versions of MX
Message
Author
retired
Forum Novice
Forum  Novice
Posts: 10
Joined: Sun Oct 14, 2018 7:01 pm

no sound in play on linux

#1 Post by retired » Tue Oct 16, 2018 11:22 am

Hi - I just installed playonlinux/wine and the install seemed to go ok -I loaded a program -Harping software.exe and it works visually on my thinkpad t-60 - I see it working just like it does in windows but I have no sound - my sound is working on youtube etc. Harping software runs music in midi format. Do I need to download something for midi audio to work - if so - what. Thanks.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: no sound in play on linux

#2 Post by fehlix » Tue Oct 16, 2018 1:27 pm

In principal it should work ... with some tweaking.
Have a look here at wineHQ wiki: MIDI should work in Wine as long as it works on your system in general, with some caveats.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

retired
Forum Novice
Forum  Novice
Posts: 10
Joined: Sun Oct 14, 2018 7:01 pm

Re: no sound in play on linux

#3 Post by retired » Tue Oct 16, 2018 7:15 pm

I read the site re unix and midi - don't have a clue what they are talking about - i'm a basic computer user. I now have the midi files working , sound wise in vlc, after downloading fluid synth, but still no audio in the Harping software.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: no sound in play on linux

#4 Post by fehlix » Tue Oct 16, 2018 7:29 pm

retired wrote:
Tue Oct 16, 2018 7:15 pm
I read the site re unix and midi - don't have a clue what they are talking about - i'm a basic computer user. I now have the midi files working , sound wise in vlc, after downloading fluid synth, but still no audio in the Harping software.
I'm can play midi's in linux too. But never tried in wine. :blindfold:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

retired
Forum Novice
Forum  Novice
Posts: 10
Joined: Sun Oct 14, 2018 7:01 pm

Re: no sound in play on linux

#5 Post by retired » Fri Oct 19, 2018 9:06 am

any ideas on a cure ?

retired
Forum Novice
Forum  Novice
Posts: 10
Joined: Sun Oct 14, 2018 7:01 pm

Re: no sound in play on linux

#6 Post by retired » Thu Oct 25, 2018 9:59 am

still no luck

retired
Forum Novice
Forum  Novice
Posts: 10
Joined: Sun Oct 14, 2018 7:01 pm

Re: no sound in play on linux

#7 Post by retired » Sun Oct 28, 2018 11:35 pm

pleh

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2068
Joined: Wed Apr 11, 2018 5:09 pm

Re: no sound in play on linux

#8 Post by fehlix » Mon Oct 29, 2018 6:51 am

Might be this trick by using a timidity-wrapper mentioned here Midi sound with Wine/PlayOnLinux
will pass the midi sound from playoninux to the speaker.
Certainly worth to try it out. :needcoffee:
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

retired
Forum Novice
Forum  Novice
Posts: 10
Joined: Sun Oct 14, 2018 7:01 pm

Re: no sound in play on linux

#9 Post by retired » Thu Nov 01, 2018 9:14 am

looked at that - I'm afraid that's way beyond my ability to follow.

User avatar
penguin
Forum Regular
Forum Regular
Posts: 276
Joined: Wed Jan 04, 2017 3:15 pm

Re: no sound in play on linux

#10 Post by penguin » Sat Nov 03, 2018 1:49 pm

Hmmm. Now I see this post. I had this problem on Mx Linux 32 and Sparky Linux 32 bit lately. Nothing related on web.

I think that the best way is to reinstall Pulse or Alsa .Remove and reinstall. Use Synaptic.
Something like this

Code: Select all

 https://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/
Also look to find alsa-base deb package . Suppose that this package remove some other conflict packages.
Reboot to see if the the changes are saved. Do not forget to autostart PulseAudio Sound System > Settings>Session Startup
Last edited by penguin on Sun Nov 04, 2018 11:53 am, edited 1 time in total.

Post Reply

Return to “MX Help”