Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Problem with 32 bit program

Help for Current Versions of MX
Post Reply
Message
Author
User avatar
WoodLark
Forum Novice
Forum  Novice
Posts: 17
Joined: Fri Oct 27, 2017 11:51 am

Problem with 32 bit program

#1 Post by WoodLark » Sat Oct 06, 2018 12:34 pm

I have been running MX17.1, 32 bit for some time, but I decided to upgrade to 64 bit.

I use a program called "turbomailer" (the executable is called "tmailer" to send bulk mail to members of a club where I am the Secretary. The program works great on the 32 bit system, but when I try to run it on a 64 bit MX17.1, (from a terminal), I get the message "not found" even though the program exists, and I am correctly specifying its location.

According to the readme file with the program. I need to install ia32-libs to run on a 64 bit linux. However, that package is no longer available in MX, and its functions are superseded by "multiarch" which is supposedly automatically activated in MX.

What do I need to do to get tmailer to run?

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 16962
Joined: Fri Dec 15, 2006 8:07 pm

Re: Problem with 32 bit program

#2 Post by Stevo » Sat Oct 06, 2018 3:55 pm

Do you know the tmailer executable is located? If you have it, run

Code: Select all

objdump -x <executable-file-name>
and the "Dynamic" section will list what i386 .so library files it needs. Then it's a matter of tracking down what packages contain those files and installing the :i386 versions.

ia32libs was deprecated with Jessie and replaced by multiarch.

User avatar
WoodLark
Forum Novice
Forum  Novice
Posts: 17
Joined: Fri Oct 27, 2017 11:51 am

Re: Problem with 32 bit program

#3 Post by WoodLark » Sat Oct 06, 2018 5:30 pm

Thanks stevo!

That worked. I had to install the 32 bit version of libssl.0.9.8. (It had to be that obsolete version; it won't work with any newer version.)

Post Reply

Return to “MX Help”