Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Printer error - solved

Help for Current Versions of MX
Post Reply
Message
Author
User avatar
Coastie
Forum Novice
Forum  Novice
Posts: 45
Joined: Fri Jul 18, 2014 4:02 pm

Printer error - solved

#1 Post by Coastie » Mon Aug 06, 2018 6:40 pm

I was trying to print using my Cannon MG2500. It stopped demanding more black ink. I replaced the cartridge. I now get an error message, "There is a missing print filter ..." I have rebooted and checked for updates. Any suggestions?
Last edited by Coastie on Wed Aug 08, 2018 1:39 am, edited 1 time in total.
MX 17
ASUS M32
CPU: Quad core AMD A10-6700
HDD: 2 TB
RAM: 12 GB
Graphics: Integrated Radeon HD Graphics

Left Mac OS X for Linux in January 2014

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 17046
Joined: Fri Dec 15, 2006 8:07 pm

Re: Printer error

#2 Post by Stevo » Tue Aug 07, 2018 2:36 pm

Coastie wrote:
Mon Aug 06, 2018 6:40 pm
I was trying to print using my Cannon MG2500. It stopped demanding more black ink. I replaced the cartridge. I now get an error message, "There is a missing print filter ..." I have rebooted and checked for updates. Any suggestions?
Where is this error message appearing?
Any leads if you to a web search for that error on the Canon MG2500?

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2531
Joined: Thu May 01, 2014 10:12 am

Re: Printer error

#3 Post by mmikeinsantarosa » Tue Aug 07, 2018 3:20 pm

Coastie wrote:
Mon Aug 06, 2018 6:40 pm
I was trying to print using my Cannon MG2500. It stopped demanding more black ink. I replaced the cartridge. I now get an error message, "There is a missing print filter ..." I have rebooted and checked for updates. Any suggestions?
You may have a print job stuck in your spooler.
Kill any current jobs and try again.

I think you can check this from the whisker menu "Print Settings"

- mike
Last edited by mmikeinsantarosa on Wed Aug 08, 2018 9:12 am, edited 2 times in total.
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
Coastie
Forum Novice
Forum  Novice
Posts: 45
Joined: Fri Jul 18, 2014 4:02 pm

Re: Printer error

#4 Post by Coastie » Wed Aug 08, 2018 1:38 am

Tried a lot of things that may have had no effect but last was in printer setting checked accepting jobs. Have no idea how it got unchecked. :smile:
MX 17
ASUS M32
CPU: Quad core AMD A10-6700
HDD: 2 TB
RAM: 12 GB
Graphics: Integrated Radeon HD Graphics

Left Mac OS X for Linux in January 2014

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2531
Joined: Thu May 01, 2014 10:12 am

Re: Printer error

#5 Post by mmikeinsantarosa » Wed Aug 08, 2018 9:12 am

Coastie wrote:
Wed Aug 08, 2018 1:38 am
Tried a lot of things that may have had no effect but last was in printer setting checked accepting jobs. Have no idea how it got unchecked. :smile:
Great!
LT: MX17.1 Quad Core model: Intel Core i7-6820HQ Kernel: 4.16.0-12.1-liquorix-amd64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

Post Reply

Return to “MX Help”