Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

No Newsreader works after latest update

Help for Current Versions of MX
Post Reply
Message
Author
arkjohn5
Forum Novice
Forum  Novice
Posts: 12
Joined: Thu Feb 09, 2017 5:02 pm

No Newsreader works after latest update

#1 Post by arkjohn5 » Fri Aug 03, 2018 3:49 pm

I had previously run mx 17.1 and am now back to running Mx 17.1 once again. after updating the OS ..none of my newsreaders work / will connect to a previously good server.
Up until this update all worked ok. I also tried Ubuntu 18.04...xubuntu 18.04 and Peppermint 9..None connected with the news server....and yes.. my internet connection is
fine..no problems there

I have tried Pan and Xpn and Knode. None work at all. I know that the server address is good because on my laptop (windows) Pan's connection work nrmally and is very quick
and i can download any all posts i choose with no issues at all.

Any help would be hugely appreciated.

I am not new to linux but not an expert either.. so a little patience/hand holding would be great

Thanks to any all that respond to this plea :-)

arkohn5
Dell XPS13 9360 mx16 64bit

User avatar
chrispop99
Forum Guide
Forum Guide
Posts: 2320
Joined: Tue Jan 27, 2009 3:07 pm

Re: No Newsreader works after latest update

#2 Post by chrispop99 » Fri Aug 03, 2018 4:18 pm

I can't solve your problem for you, but I just installed Pan on a test box, entered the server details, and it all worked.

If anyone more knowledgeable wants me to test, I will be happy to do so.

Chris
Test machines:
32-bit non-PAE - Thinkpad T41, 1.6GHz Pentium M, 1GB RAM.
32-bit PAE - DELL Latitude D610, 1.73GHz Pentium M, 2GB RAM.
64-bit - Lenovo T61, 2GHz Core 2 Duo, 2GB RAM
64-bit - Gigabyte Z77P-D3, Intel i3-3220, GeForce 8400 GS, 4GB PC3-12800.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9076
Joined: Sun Dec 16, 2007 1:17 pm

Re: No Newsreader works after latest update

#3 Post by dolphin_oracle » Fri Aug 03, 2018 4:20 pm

I would make sure some hosts based ad blocker isn't blocking your chosen server.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

arkjohn5
Forum Novice
Forum  Novice
Posts: 12
Joined: Thu Feb 09, 2017 5:02 pm

Re: No Newsreader works after latest update

#4 Post by arkjohn5 » Tue Aug 07, 2018 6:30 pm

still not able to get pan to work.

I downloaded a new dvd of mx17.1 on my neighbors computer.. Burned the dvd and installed it to my main system as well a my Dell XPS13.. NO good
The program launches fine on both but then just simply locks up and does nothing even after i input the correct server info again after deleting the
pan2 folder (as someone elsewhere had said to try)

Nothing works on either system or ANY flavor of linux (ubuntu mint antergos or manjaro).
Only thing i can think of is that somehow someone put a block on my ATT router to disable newsgroups.
The router works fine otherwise and i checked all the setting and had them reset to as it came to me from ATT.

The really odd thing. In a V.B. if i install ANY flavor of Linux ....it works normally. That is what is driving me nuts over this..!!!

Totally frustrated and considering going back to windows if i cannot get this worked out. :frown:

and yes my motherboard is updated to ALL the newest updates.including Intel microcode and BIOS

arkjohn5
Dell XPS13 9360 mx16 64bit

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9076
Joined: Sun Dec 16, 2007 1:17 pm

Re: No Newsreader works after latest update

#5 Post by dolphin_oracle » Tue Aug 07, 2018 6:33 pm

maybe check your /etc/hosts file

what is the server that is supposed to work?

the other thing to check is to see if the ports in use have changed and that perhaps the firewall is blocking them.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

arkjohn5
Forum Novice
Forum  Novice
Posts: 12
Joined: Thu Feb 09, 2017 5:02 pm

Re: No Newsreader works after latest update

#6 Post by arkjohn5 » Wed Aug 08, 2018 8:42 am

Host file :

127.0.0.1 localhost
127.0.1.1 john-peppermint9

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Hosts-deny file:

# /etc/hosts.deny: list of hosts that are _not_ allowed to access the system.
# See the manual pages hosts_access(5) and hosts_options(5).
#
# Example: ALL: some.host.name, .some.domain
# ALL EXCEPT in.fingerd: other.host.name, .other.domain
#
# If you're going to protect the portmapper use the name "rpcbind" for the
# daemon name. See rpcbind(8) and rpc.mountd(8) for further information.
#
# The PARANOID wildcard matches any host whose name does not match its
# address.
#
# You may wish to enable this to ensure any programs that don't
# validate looked up hostnames still leave understandable logs. In past
# versions of Debian this has been the default.
# ALL: PARANOID


Hosts Allow file:

# /etc/hosts.allow: list of hosts that are allowed to access the system.
# See the manual pages hosts_access(5) and hosts_options(5).
#
# Example: ALL: LOCAL @some_netgroup
# ALL: .foobar.edu EXCEPT terminalserver.foobar.edu
#
# If you're going to protect the portmapper use the name "rpcbind" for the
# daemon name. See rpcbind(8) and rpc.mountd(8) for further information.
#

this is the newshosting provider IP address:

ews.iad.highwinds-media.com./69.16.179.22

and the ports are 119 and SSL 586

All seems to be entered correctly and i see nothing as being blocked on the hosts file

Thanks for the heads up but still unable to use any newsreader

arkjohn5
Dell XPS13 9360 mx16 64bit

Post Reply

Return to “MX Help”