Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Resolution in virtual console

Help for Current Versions of MX
Message
Author
mbooyzen
Forum Novice
Forum  Novice
Posts: 38
Joined: Thu May 10, 2018 12:34 am

Re: Resolution in virtual console

#21 Post by mbooyzen » Sun Jun 03, 2018 2:24 pm

Just an update, I did a reinstall with the conwidth setting at live boot, everything was fine. Used for about a day rebooting quite a lot and everything stayed fine.
Then I installed the nvidia proprietary driver and my virtual console went back to 80x50 characters :bawling:, did all of the above steps and got nowhere.
Removal of the driver didn't have the effect i was hoping for(very little time spent here) so a quick reinstall did the trick again.
So for future reference the nvidia driver does work for my card (an older 6800GT) but the console size is stuck. For me that's enough to revert back to the foss driver.

Thanks for everyone's time and effort with this.
Some old 2nd generation i5, 8GB ram, Nvidia 6800gs.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 1156
Joined: Wed Apr 11, 2018 5:09 pm

Re: Resolution in virtual console

#22 Post by fehlix » Sun Jun 03, 2018 2:38 pm

mbooyzen wrote:
Sun Jun 03, 2018 2:24 pm
... did all of the above steps and got nowhere. ..
So you are saying, you have changed the fontsize with:

Code: Select all

sudo dpkg-reconfigure console-setup
within a normal xfce-terminal. But still the fontsize has not changed and did not influence the number of colums with the VTconsole. Is that right?

mbooyzen
Forum Novice
Forum  Novice
Posts: 38
Joined: Thu May 10, 2018 12:34 am

Re: Resolution in virtual console

#23 Post by mbooyzen » Sun Jun 03, 2018 3:15 pm

Fehlix, that is correct. It's as if the driver overrules every change i made. The font size when running dpkg-reconfigure console-setup is second from smallest to start with(the one highlighted, 8x16), with the nvidia driver installed. Without the nvidia driver, dpkg-reconfigure console-setup the highlighted size is much larger(12x24) but the virtual console has 160 columns. My screen gives me the input resolution via menu and that confirms changes in /etc/default/grub.
Makes zero sense I know....

I have other (though older) nvidia cards in a box somewhere, so I'll do some tests when i have the time. For now I'll test the nouveau driver


Edit: Another thing I've noticed is during startup, after grub selection while starting services the following happens
Without Nvidia driver: text is large (80 columns) then changes to small(200 columns) and finally changes to my selection with conwidth (160 columns)
Nvidia driver installed: the whole time just stays 80 columns
Some old 2nd generation i5, 8GB ram, Nvidia 6800gs.

mbooyzen
Forum Novice
Forum  Novice
Posts: 38
Joined: Thu May 10, 2018 12:34 am

Re: Resolution in virtual console

#24 Post by mbooyzen » Wed Aug 08, 2018 7:05 pm

Just as an update. I again spent some time on this, this time using 4.17 liquorix kernel with the same effect.
The console-font-sellect program is different after updates as it only gives options for font size. It also now gives the current amount of columns which remains 80 under Nvidia driver, no option to change. The font sizes changes the ratio(pressing 's'), anything from 80x25 to 80x50(columns x lines). Under nouveau driver everything works as expected.
When using "inxi" without args I get in the output
"TTY 80" on Nvidia, whereas on nouveau this is not mentioned. Seems that it's overridden somehow. Will install Nvidia driver again and check any settings I can find for the driver itself.
Sorry this isn't true I've used the -G flag and it is there with nouveau driver
Some old 2nd generation i5, 8GB ram, Nvidia 6800gs.

Post Reply

Return to “MX Help”