Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Lost access to user account

Help for Current Versions of MX
Post Reply
Message
Author
djmclaws

Lost access to user account

#1 Post by djmclaws » Wed May 16, 2018 10:55 am

Description of what happened:

I used root Thunar to copy a couple of my own preferred wallpapers to the etc/share/backgrounds directory. After a couple of wallpaper changes, I then then tried to use root Thunar to remove a picture I decided not to use, when Thunar seemed to hang up. I then logged out and tried to log back in to my account, Now at the login screen the correct username comes up, but after entering the password, it just cycles back to the login screen.

Try #1: Was able to login as root, so I did and reset the user password. Tried again, no change. Still can't login to user account.

Try #2: After reading someone else's post about a corrupted fstab file, I copied fstab.backup over onto the fstab. No change.

Try#3: Logged in as root again, and this time tried to switch to the user account by:

Code: Select all

root@danny:~# su -l danny
mount: Operation not permitted
danny@danny:~$
Notice that the mount was not permitted, but it did change the user to "danny".

These files are given:
I did select encrypt the home directory during the initial install.

Code: Select all

root@danny:~# su -l danny
mount: Operation not permitted
danny@danny:~$ ls
Access-Your-Private-Data.desktop  README.txt
danny@danny:~$
opening up the README.txt file:

Code: Select all

THIS DIRECTORY HAS BEEN UNMOUNTED TO PROTECT YOUR DATA.

From the graphical desktop, click on:
 "Access Your Private Data"

or

From the command line, run:
 ecryptfs-mount-private

Using less to find any instructions:

Code: Select all

[Desktop Entry]
_Name=Access Your Private Data
_GenericName=Access Your Private Data
Exec=/usr/bin/ecryptfs-mount-private
Terminal=true
Type=Application
Categories=System;Security;
X-Ubuntu-Gettext-Domain=ecryptfs-utils

Code: Select all

danny@danny:~$ sudo /usr/bin/ecryptfs-mount-private
[sudo] password for danny: 
Enter your login passphrase:
Inserted auth tok with sig [c2f0dfc45bd87f1b] into the user session keyring
fopen: No such file or directory
Am I heading down a rabbit hole of trying to backdoor into my encrypted user home directory, or am I missing an easier step. I just want to boot up to my user account as normal. Not sure what glitch or my human error caused this to happen.

Thanks in advance for any insight.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10044
Joined: Sun Dec 16, 2007 1:17 pm

Re: Lost access to user account

#2 Post by dolphin_oracle » Wed May 16, 2018 11:29 am

some thoughts

your home folder is encrypted with your original password as the pass phase, I think. your home folder is actually an encrypted file inside your actual home folder.

you may have inadvertently changed the permissions of the home folder (probably the version inside the encrypted container file) to such that your user can no longer access it. There are files created in the home folder during a login by X which if they can't be created, will kick back out to the login manager.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

djmclaws

Re: Lost access to user account

#3 Post by djmclaws » Wed May 16, 2018 11:47 am

Interesting. I probably must have screwed those permissives when root Thunar hung up, and I just backed out of it, perhaps not very gracefully.

Anyway, not a big disaster. I've only been using MX for about a week now, and my important files are backed up. I'll just do a re-install tonight (sans encryption this time).

Just created a new user and deleted the old one instead.

Post Reply

Return to “MX Help”