Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

35 second delay after GRUB [SOLVED]

Help for Current Versions of MX
Message
Author
User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10127
Joined: Sun Dec 16, 2007 1:17 pm

Re: 35 second delay after GRUB [SOLVED]

#21 Post by dolphin_oracle » Thu May 10, 2018 7:49 am

ok,

in /etc/default/grub, add this as a boot parameter in the same line as the "quiet" is located.

Code: Select all

RESUME=/dev/mapper/cryptswap1
and then

Code: Select all

sudo update-grub
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

djmclaws

Re: 35 second delay after GRUB [SOLVED]

#22 Post by djmclaws » Thu May 10, 2018 9:37 am

dolphin_oracle wrote:ok,

in /etc/default/grub, add this as a boot parameter in the same line as the "quiet" is located.

Code: Select all

RESUME=/dev/mapper/cryptswap1
Like this?

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="zswap.zpool=zsmalloc quiet" RESUME=/dev/mapper/cryptswap1
 
Should I leave the "RESUME=none" line in the initramfs.conf file after this change to the grub file?


and then

Code: Select all

sudo update-grub

User avatar
Richard
Posts: 2264
Joined: Fri Dec 12, 2008 10:31 am

Re: 35 second delay after GRUB [SOLVED]

#23 Post by Richard » Thu May 10, 2018 9:43 am

@D_O,
Does the RESUME part need to be within the quotes, or not?
GRUB_CMDLINE_LINUX_DEFAULT="zswap.zpool=zsmalloc quiet RESUME=/dev/mapper/cryptswap1"
MX18b1: Lenovo T430: Intel Ivy Bridge i5-3320M, 8GB RAM, 4.9.0-8-amd64, 119 GB SSD
MX18b1: Eee&AA1 NBs: Dual Core Atom N270, 1GB RAM, 4.19.0-1-686, 150 GB HDD
DoubleCmd/Thunar, LibO613, Dropbox, Vivaldi/Firefox, CherryTree, Vbox. LinuxCounter #208633

djmclaws

Re: 35 second delay after GRUB [SOLVED]

#24 Post by djmclaws » Thu May 10, 2018 9:57 am

Richard wrote:@D_O,
Does the RESUME part need to be within the quotes, or not?
GRUB_CMDLINE_LINUX_DEFAULT="zswap.zpool=zsmalloc quiet RESUME=/dev/mapper/cryptswap1"
I'll bet you are probably right. I haven't tried it yet.
i was going to wait until I find out if I should remove the "RESUME=none" line or not.

djmclaws

Re: 35 second delay after GRUB [SOLVED]

#25 Post by djmclaws » Thu May 10, 2018 10:30 am

djmclaws wrote:
dolphin_oracle wrote:ok,

in /etc/default/grub, add this as a boot parameter in the same line as the "quiet" is located.

Code: Select all

RESUME=/dev/mapper/cryptswap1
Like this?

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="zswap.zpool=zsmalloc quiet" RESUME=/dev/mapper/cryptswap1
 
Should I leave the "RESUME=none" line in the initramfs.conf file after this change to the grub file?


and then

Code: Select all

sudo update-grub
I just tested it out, and even with the addition to the grub file, I still need to have the "RESUME=none" line in the initramfs.conf file. to avoid the bootup delay.

So what does adding "RESUME=/dev/mapper/cryptswap1" to the grub file supposed to do?

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 10127
Joined: Sun Dec 16, 2007 1:17 pm

Re: 35 second delay after GRUB [SOLVED]

#26 Post by dolphin_oracle » Thu May 10, 2018 10:43 am

djmclaws wrote:
djmclaws wrote:
dolphin_oracle wrote:ok,

in /etc/default/grub, add this as a boot parameter in the same line as the "quiet" is located.

Code: Select all

RESUME=/dev/mapper/cryptswap1
Like this?

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="zswap.zpool=zsmalloc quiet" RESUME=/dev/mapper/cryptswap1
 
Should I leave the "RESUME=none" line in the initramfs.conf file after this change to the grub file?


and then

Code: Select all

sudo update-grub
I just tested it out, and even with the addition to the grub file, I still need to have the "RESUME=none" line in the initramfs.conf file. to avoid the bootup delay.

So what does adding "RESUME=/dev/mapper/cryptswap1" to the grub file supposed to do?
it was an attempt to get grub to actually look to your encrypted swap as the resume device instead of the actual UUID of the swap partition. The only thing this should affect is "hibernate".
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

djmclaws

Re: 35 second delay after GRUB [SOLVED]

#27 Post by djmclaws » Thu May 10, 2018 11:01 am

OK, Thanks.

Again, thank you to all for your help!!

Post Reply

Return to “MX Help”