Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Calibre won't install - (solved)

Help for Current Versions of MX
Post Reply
Message
Author
User avatar
paul1149
Forum Regular
Forum Regular
Posts: 166
Joined: Fri Dec 29, 2017 12:39 pm

Calibre won't install - (solved)

#1 Post by paul1149 » Tue Feb 13, 2018 2:27 pm

Hello,
I've tried installing Calibre via the MX Package Manager and Synaptics. Neither works, and the latter reports the following errors:

! Could not mark all packages for installation or upgrade.
The following packages have unresolvable dependencies...

Code: Select all

calibre:
 Depends: python-lxml but it is not going to be installed
 Depends: python-mechanize but it is not going to be installed
 Depends: python-beautifulsoup but it is not going to be installed
 Depends: python-cssutils but it is not going to be installed
 Depends: python-cssselect but it is not going to be installed
 Depends: python-cherrypy3 but it is not going to be installed
 Depends: python-dateutil but it is not going to be installed
 Depends: python-feedparser but it is not going to be installed
 Depends: python-html5-parser  but it is not installable
 Depends: python-markdown but it is not going to be installed
 Depends: python-msgpack but it is not going to be installed
 Depends: python-pyqt5 but it is not going to be installed
 Depends: python-pyqt5.qtwebkit but it is not going to be installed
 Depends: python-pyqt5.qtsvg but it is not going to be installed
 Depends: python-pyparsing but it is not going to be installed
 Depends: python-regex but it is not going to be installed
 Depends: python-routes but it is not going to be installed
 Depends: python-netifaces but it is not going to be installed
 Depends: python-apsw but it is not going to be installed
 Depends: libjs-mathjax but it is not going to be installed
 Depends: libjs-coffeescript but it is not going to be installed
 Depends: calibre-bin but it is not going to be installed
Has anyone come across this, and what should I do about it?

Thanks.
Last edited by paul1149 on Tue Feb 13, 2018 3:55 pm, edited 1 time in total.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4309
Joined: Wed Jul 12, 2006 4:05 pm

Re: Calibre won't install

#2 Post by timkb4cq » Tue Feb 13, 2018 2:49 pm

Thanks for the detailed report. It seems when the new Calibre was uploaded yesterday, one of its dependencies was not.
Hang on a few minutes, I'll get it up.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4309
Joined: Wed Jul 12, 2006 4:05 pm

Re: Calibre won't install

#3 Post by timkb4cq » Tue Feb 13, 2018 3:09 pm

Calibre 3.17 is now installable. Use MXPI, or if you would rather use Synaptic, click on Reload before selecting calibre.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

User avatar
paul1149
Forum Regular
Forum Regular
Posts: 166
Joined: Fri Dec 29, 2017 12:39 pm

Re: Calibre won't install

#4 Post by paul1149 » Tue Feb 13, 2018 3:54 pm

Perfect, via MXPI. Thanks much for your help!

Post Reply

Return to “MX Help”