Welcome!

Please read this important information about Spectre and Meltdown vulnerabilities.
Please read this important information about MX sources lists.
News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17 Final release info here
  • MX-16.1 release info here
  • antiX-17 release info here
    New users
    • Please read this first, and don't forget to add system and hardware information to posts!
    • Read Forum Rules

kernel options

Help for Current Versions of MX
Message
Author
User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 14420
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: kernel options

#51 Postby Stevo » Mon Feb 12, 2018 3:41 pm

I haven't even had Tim put them in testing yet! We don't have hardly any users using a 4.15 kernel yet. But since the new patches only take effect when the code detects a 4.15 kernel, I would consider them reasonably safe to go into antiX main. In that case, we should also have them in MX main.

I think I remembered to add libelf-dev to the Depends for the 4.14 kernel headers before I handed off the source to Mike to build. That seems to be an outstanding bug still in Debian, though maybe they expect the individual dkms packages to depend on it instead. Anyway, mx-system also depends on libelf-dev, so we currently have belt and suspenders.

dr-kart
Forum Novice
Forum  Novice
Posts: 96
Joined: Sun Oct 22, 2017 8:12 pm

Re: kernel options

#52 Postby dr-kart » Mon Feb 12, 2018 5:10 pm

...running anti's 4.15 kernel. With current nvidia video driver. So far so good.

Code: Select all

dkms status
broadcom-sta, 6.30.223.271, 4.14.0-0.bpo.3-amd64, x86_64: installed
broadcom-sta, 6.30.223.271, 4.14.0-3-amd64, x86_64: installed
broadcom-sta, 6.30.223.271, 4.14.14-antix.1-amd64-smp, x86_64: installed
broadcom-sta, 6.30.223.271, 4.9.0-5-amd64, x86_64: installed
ndiswrapper, 1.61, 4.14.0-0.bpo.3-amd64, x86_64: installed
ndiswrapper, 1.61, 4.14.0-3-amd64, x86_64: installed
ndiswrapper, 1.61, 4.14.14-antix.1-amd64-smp, x86_64: installed
ndiswrapper, 1.61, 4.9.0-5-amd64, x86_64: installed
nvidia, 390.25, 4.14.14-antix.1-amd64-smp, x86_64: installed
nvidia, 390.25, 4.15.0-antix.1-amd64-smp, x86_64: installed

perhaps I need some cleaning up here?

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5366
Joined: Sat Jul 15, 2006 10:40 am

Re: kernel options

#53 Postby anticapitalista » Mon Feb 12, 2018 5:21 pm

dr-kart wrote:...running anti's 4.15 kernel. With current nvidia video driver. So far so good.

Code: Select all

dkms status
broadcom-sta, 6.30.223.271, 4.14.0-0.bpo.3-amd64, x86_64: installed
broadcom-sta, 6.30.223.271, 4.14.0-3-amd64, x86_64: installed
broadcom-sta, 6.30.223.271, 4.14.14-antix.1-amd64-smp, x86_64: installed
broadcom-sta, 6.30.223.271, 4.9.0-5-amd64, x86_64: installed
ndiswrapper, 1.61, 4.14.0-0.bpo.3-amd64, x86_64: installed
ndiswrapper, 1.61, 4.14.0-3-amd64, x86_64: installed
ndiswrapper, 1.61, 4.14.14-antix.1-amd64-smp, x86_64: installed
ndiswrapper, 1.61, 4.9.0-5-amd64, x86_64: installed
nvidia, 390.25, 4.14.14-antix.1-amd64-smp, x86_64: installed
nvidia, 390.25, 4.15.0-antix.1-amd64-smp, x86_64: installed

perhaps I need some cleaning up here?


From now on, antiX kernel upgrades will only be 4.9 and 4.15 series. I am going to drop 4.14 in favour of 4.15
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

dr-kart
Forum Novice
Forum  Novice
Posts: 96
Joined: Sun Oct 22, 2017 8:12 pm

Re: kernel options

#54 Postby dr-kart » Mon Feb 12, 2018 5:26 pm

anticapitalista wrote:...I am going to drop 4.14 in favour of 4.15
:thumbup:

caprea
Forum Novice
Forum  Novice
Posts: 63
Joined: Sat Aug 23, 2014 7:01 am

Re: kernel options

#55 Postby caprea » Mon Feb 12, 2018 5:45 pm

dr-kart,is this on mx-17 ?

dr-kart
Forum Novice
Forum  Novice
Posts: 96
Joined: Sun Oct 22, 2017 8:12 pm

Re: kernel options

#56 Postby dr-kart » Mon Feb 12, 2018 5:50 pm

Yes it is

caprea
Forum Novice
Forum  Novice
Posts: 63
Joined: Sat Aug 23, 2014 7:01 am

Re: kernel options

#57 Postby caprea » Mon Feb 12, 2018 6:06 pm

I'm asking because I have a antix-system, where I also have the nvidia-driver 390.25 manually installed,
but I cant get the 4.15-antix-kernel to build against it.
Something is missing, but I don't know what
If it works on mx I have to look again at this.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 14420
Age: 59
Joined: Fri Dec 15, 2006 8:07 pm

Re: kernel options

#58 Postby Stevo » Mon Feb 12, 2018 7:27 pm

We currently have the 384.111 Nvidia-driver in MX testing, too. I expect that it would work well if moved to main.

Nvidia-driver 390.25 has been stuck in Debian Experimental for a couple weeks now.

User avatar
entropyfoe
Forum Regular
Forum Regular
Posts: 733
Joined: Thu Apr 19, 2007 11:42 am

Re: kernel options

#59 Postby entropyfoe » Mon Feb 12, 2018 11:44 pm

caprea,

same here. That didn't work.
I installed 4.15.0-antix.1amd 64-smp,, the headers, then the image with synaptic.

I ran the trusty dpkg-reconfigure nvidia-kernel-dkms

looked fine for the 4.9.77-antix kernel I am now running, but when trying the 4.15 this was the sad message:

Code: Select all

Building initial module for 4.15.0-antix.1-amd64-smp
Error! Bad return status for module build on kernel: 4.15.0-antix.1-amd64-smp (x86_64)
Consult /var/lib/dkms/nvidia-current/375.82/build/make.log for more information.


there is lots of kernel gibberish in that log

Code: Select all

DKMS make.log for nvidia-current-375.82 for kernel 4.15.0-antix.1-amd64-smp (x86_64)
Mon Feb 12 21:25:27 CST 2018
make  KBUILD_VERBOSE=1 -C /lib/modules/4.15.0-antix.1-amd64-smp/build M=/var/lib/dkms/nvidia-current/375.82/build ARCH=x86_64 NV_KERNEL_SOURCES=/lib/modules/4.15.0-antix.1-amd64-smp/build NV_KERNEL_OUTPUT=/lib/modules/4.15.0-antix.1-amd64-smp/build NV_KERNEL_MODULES="nvidia nvidia-uvm nvidia-modeset nvidia-drm" INSTALL_MOD_DIR=kernel/drivers/video Q= modules
make[1]: Entering directory '/usr/src/linux-headers-4.15.0-antix.1-amd64-smp'
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (      \
echo >&2;                     \
echo >&2 "  ERROR: Kernel configuration is invalid.";      \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";   \
echo >&2 ;                     \
/bin/false)........lots cut out ....

ending with ......
   ./tools/objtool/objtool orc generate --no-fp  "/var/lib/dkms/nvidia-current/375.82/build/nvidia/.tmp_nv-procfs.o";
Makefile:1521: recipe for target '_module_/var/lib/dkms/nvidia-current/375.82/build' failed
make[1]: *** [_module_/var/lib/dkms/nvidia-current/375.82/build] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-antix.1-amd64-smp'
Makefile:81: recipe for target 'modules' failed
make: *** [modules] Error 2


So, how to get this nice 4.15 kernel, as I have written before, it has CPU temperature monitoring finally working, or so I read.
Asus Prime 370X-Pro
AMD Ryzen 1600X (6 cores @ 3.6 GHz)
16 Gig DDR4 3200 (G Skill)
Nvidia -MSI GeForce GT 710 fanless
Samsung 960 NVMe SSD nvme0n1 P1,P2, and P3=MX-17, P4=antiX-17
1TB SSD sda1= Data, 2TB WD =backups
on-board ethernet & sound

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5366
Joined: Sat Jul 15, 2006 10:40 am

Re: kernel options

#60 Postby anticapitalista » Tue Feb 13, 2018 7:26 am

entropyfoe - you are not comparing the same.

You are compiling nvidia 375.82

caprea says that this does NOT work with the 4.15 antiX kernel.
Instead you need to use nvidia 384.111
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com


Return to “MX Help”

Who is online

Users browsing this forum: No registered users and 6 guests