Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

kernel options

Help for Current Versions of MX
Message
Author
User avatar
stsoh
Forum Regular
Forum Regular
Posts: 301
Joined: Sun Aug 20, 2017 10:11 am

Re: kernel options

#31 Post by stsoh » Tue Jan 30, 2018 4:28 am

liquorix update, it is not kernel 4.15 but 4.14.15.
installed it, no error.

Code: Select all

System:    Host: mx1 Kernel: 4.14.0-15.2-liquorix-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
           Distro: MX-17_x64 Horizon December 15, 2017

Code: Select all

$ dkms status
broadcom-sta, 6.30.223.271, 4.14.0-15.2-liquorix-amd64, x86_64: installed
broadcom-sta, 6.30.223.271, 4.14.15, x86_64: installed
ndiswrapper, 1.61, 4.14.0-15.2-liquorix-amd64, x86_64: installed
ndiswrapper, 1.61, 4.14.15, x86_64: installed
virtualbox-guest, 5.2.6, 4.14.0-15.2-liquorix-amd64, x86_64: installed
virtualbox-guest, 5.2.6, 4.14.15, x86_64: installed
MX-17.1_x64 Horizon, G41M-P33 Combo(MS-7592), Pentium E5400 (min/max: 1203/2700 MHz), 8Gb RAM (800 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5575
Joined: Sat Jul 15, 2006 10:40 am

Re: kernel options

#32 Post by anticapitalista » Tue Jan 30, 2018 7:55 am

4.14.14 antiX dkms builds work. It's too early for 4.15 - see this kernel as a test bed.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5575
Joined: Sat Jul 15, 2006 10:40 am

Re: kernel options

#33 Post by anticapitalista » Tue Jan 30, 2018 8:12 am

Stevo wrote:OK, things that are supposed to build with the 4.15 kernel:

Virtual Box 5.26 from the MX 17 test repo.
Nvidia-driver 384.11
ndiswrapper 1.60-6 as soon as we port it over from testing

unknown: broadcom-sta-dkms 6.30.223.271-7 in our repo, there's no newer version upstream.

We are supposed to be using a newer bbswitch-dkms from buster to build with 4.12+ kernels, but it still seems to be working fine.
The 4.15 kernel now includes vbox modules

http://www.omgubuntu.co.uk/2018/01/virt ... nux-kernel
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
kmathern
Forum Veteran
Forum Veteran
Posts: 9255
Joined: Wed Jul 12, 2006 2:26 pm

Re: kernel options

#34 Post by kmathern » Tue Jan 30, 2018 8:56 am

anticapitalista wrote: The 4.15 kernel now includes vbox modules

http://www.omgubuntu.co.uk/2018/01/virt ... nux-kernel
That looks like 4.16 (four dot sixteen) to me.

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5575
Joined: Sat Jul 15, 2006 10:40 am

Re: kernel options

#35 Post by anticapitalista » Tue Jan 30, 2018 9:47 am

kmathern wrote:
anticapitalista wrote: The 4.15 kernel now includes vbox modules

http://www.omgubuntu.co.uk/2018/01/virt ... nux-kernel
That looks like 4.16 (four dot sixteen) to me.
Duh! So it is.
I'm sure i read it somewhere that it will be ready in 4.15
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15394
Joined: Fri Dec 15, 2006 8:07 pm

Re: kernel options

#36 Post by Stevo » Tue Jan 30, 2018 3:51 pm

Shared folders are not supposed to work until an even later release, which is a critical feature for me. :frown:

caprea
Forum Novice
Forum  Novice
Posts: 89
Joined: Sat Aug 23, 2014 7:01 am

Re: kernel options

#37 Post by caprea » Sat Feb 10, 2018 8:50 am

On antix17, if you install libelf-dev.
The 4.15.0-antix.1-amd64-smp builds fine against the 384.111 nvidia-driver from backports, installed with ddm-mx
The Virtual Box 5.26 from the MX 17 test repo also builds perfectly.

The ndiswrapper 1.61-0mx17+2 and the broadcom-sta-dkms 6.30.223.271-7 don't.

Code: Select all

$ dkms status
broadcom-sta, 6.30.223.271, 4.10.5-antix.3-amd64-smp, x86_64: installed
broadcom-sta, 6.30.223.271, 4.14.14-antix.1-amd64-smp, x86_64: installed
ndiswrapper, 1.61, 4.10.5-antix.3-amd64-smp, x86_64: installed
ndiswrapper, 1.61, 4.14.14-antix.1-amd64-smp, x86_64: installed
nvidia-current, 384.111, 4.14.14-antix.1-amd64-smp, x86_64: installed
nvidia-current, 384.111, 4.15.0-antix.1-amd64-smp, x86_64: installed
virtualbox-guest, 5.2.6, 4.14.14-antix.1-amd64-smp, x86_64: installed
virtualbox-guest, 5.2.6, 4.15.0-antix.1-amd64-smp, x86_64: installed (original_module exists)
helga@antix1:~

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15394
Joined: Fri Dec 15, 2006 8:07 pm

Re: kernel options

#38 Post by Stevo » Sat Feb 10, 2018 6:30 pm

Shoot, the patched ndiswrapper 1.60-6 from upstream Debian advertises that it builds with the 4.15 kernel. Let me see if I can port the patches over to 1.6.1. I think we have it in the test repo, but you have to force the downgrade manually.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15394
Joined: Fri Dec 15, 2006 8:07 pm

Re: kernel options

#39 Post by Stevo » Sat Feb 10, 2018 6:54 pm

Well, that was simple enough to cherry-pick the patch from Debian. Can you give these a try?

https://drive.google.com/open?id=1-91cq ... B3bFyqM4XE

User avatar
stsoh
Forum Regular
Forum Regular
Posts: 301
Joined: Sun Aug 20, 2017 10:11 am

Re: kernel options

#40 Post by stsoh » Sun Feb 11, 2018 5:40 am

liquorix release 4.14.18.2 kernel on 10/feb.

Code: Select all

$ uname -a
Linux mx1 4.14.0-18.2-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix 4.14-25 (2018-02-11) x86_64 GNU/Linux
user@mx1:~/Desktop
$ dkms status
broadcom-sta, 6.30.223.271, 4.13.0-1-amd64, x86_64: installed
broadcom-sta, 6.30.223.271, 4.14.0-18.2-liquorix-amd64, x86_64: installed
ndiswrapper, 1.61, 4.13.0-1-amd64, x86_64: installed
ndiswrapper, 1.61, 4.14.0-18.2-liquorix-amd64, x86_64: installed
virtualbox-guest, 5.2.6, 4.13.0-1-amd64, x86_64: installed
virtualbox-guest, 5.2.6, 4.14.0-18.2-liquorix-amd64, x86_64: installed (original_module exists)
MX-17.1_x64 Horizon, G41M-P33 Combo(MS-7592), Pentium E5400 (min/max: 1203/2700 MHz), 8Gb RAM (800 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.

Post Reply

Return to “MX Help”