Page 1 of 2

Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 8:53 am
by tekkaman
Hi there,

I'm having a problem with the new MX 17. My problem is that randomly when watching videos online the browser will just close itself randomly. It doesn't have a pattern. Sometimes I can watch a whole movie and sometimes it just closes in midway. It just randomly happens when watching videos. I've tried Palemoon, Firefox, Cyberfox but I keep having the same issue. Here are my system specs:

Acer V5 11.1
CPU: Celeron 1.5GHz dualcore
Ram: 8GB DDR3 1333Mhz
HDD: 500 GB 7200rpm

Re: Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 9:13 am
by Jerry3904
We need better system information, since it is clearly not a browser problem. Please post the output of this command as regular user:

Code: Select all

inxi -F

Re: Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 5:19 pm
by tekkaman
Here´s the info:

Code: Select all

System:    Host: mx1 Kernel: 4.13.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
           Distro: MX-17_x64 Horizon December 15, 2017
Machine:   Device: laptop System: Acer product: V5-131 v: V1.09 serial: N/A
           Mobo: Acer model: Mimic v: Type2 - Board Version serial: N/A
           UEFI [Legacy]: Acer v: V1.09 date: 10/30/2012
Battery    BAT1: charge: 44.1 Wh 87.0% condition: 50.7/55.5 Wh (91%)
           hidpp__0: charge: N/A condition: NA/NA Wh
           hidpp__1: charge: N/A condition: NA/NA Wh
CPU:       Dual core Intel Celeron 1007U (-MCP-) cache: 2048 KB
           clock speeds: max: 1500 MHz 1: 1496 MHz 2: 1496 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           Display Server: x11 (X.Org 1.19.2 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.02hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile version: 3.3 Mesa 13.0.6
Audio:     Card Intel 7 Series/C216 Family High Def. Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-1-amd64
Network:   Card-1: Qualcomm Atheros AR9462 Wireless Network Adapter driver: ath9k
           IF: wlan0 state: up mac: 2c:d0:5a:aa:5f:2e
           Card-2: Broadcom Limited NetLink BCM57785 Gigabit Ethernet PCIe driver: tg3
           IF: eth0 state: down mac: 20:89:84:73:f9:3c
Drives:    HDD Total Size: 500.1GB (4.3% used)
           ID-1: /dev/sda model: HGST_HTS725050A7 size: 500.1GB
Partition: ID-1: / size: 456G used: 19G (5%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 45.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 174 Uptime: 3 min Memory: 582.2/7827.3MB Client: Shell (bash) inxi: 2.3.53


I wanted to add that I didn´t have this problem with MX 16.1. So apart from the video troubles MX 17 seems just as stable as with MX 16.1. The only difference is that I have the frequency monitor in the taskbar and it shows the CPU going at 1.5Ghz all the time instead of going up and down like MX 16.1.

Re: Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 5:42 pm
by Jerry3904
The graphics driver might be the culprit, since people have reported that using "modesetting" sometimes causes problems. But someone else will have to tell you how to proceed, I don't have intel.

Re: Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 6:18 pm
by Stevo
The CPU frequency being "stuck" is a consequence of the Debian kernels now using the pstate power management scheme by default for Intel CPUs, instead of cpufreq. It's supposed to bring the processor to a complete halt when it's idle, instead of just slowing it down, but the speed will still look high.

From the Arch wiki:

Code: Select all

 The pstate power scaling driver is used automatically for modern Intel CPUs instead of the other drivers below. This driver takes priority over other drivers and is built-in as opposed to being a module. This driver is currently automatically used for Sandy Bridge and newer CPUs. If you encounter a problem while using this driver, add intel_pstate=disable to your kernel line. You can use the same user space utilities with this driver, but cannot control it.

Even P State behavior mentioned above can be influenced with /sys/devices/system/cpu/intel_pstate, e.g. Intel Turbo Boost can be deactivated with # echo 1 > /sys/devices/system/cpu/intel_pstate/no_turbo for keeping CPU-Temperatures low.

Additional control for modern Intel CPUs is available with the Linux Thermal Daemon (available as thermald), which proactively controls thermal using P-states, T-states, and the Intel power clamp driver. thermald can also be used for older Intel CPUs. If the latest drivers are not available, then the daemon will revert to x86 model specific registers and the Linux ‘cpufreq subsystem’ to control system cooling.


We should also know what video sites are causing the browser to crash, and if any messages show up if you start the browser from the terminal and then crash it.

Re: Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 6:27 pm
by Mauser
I see you still have the old kernel. I suggest going into the MX Package Installer and select the MX 4.14 kernel and install which is the one on the bottom of the list. This might correct your issue. It will fix the Spectra/Meltdown venerability.

Re: Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 6:55 pm
by tekkaman
So changing the kernel will fix the video issue or the frequency issue ?

The browser closing itself can happen in any video site as common as Youtube. I want to add that I can watch offline videos fine with Kodi and SMplayer.

Re: Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 8:02 pm
by Mauser
tekkaman wrote:So changing the kernel will fix the video issue or the frequency issue ?

The browser closing itself can happen in any video site as common as Youtube. I want to add that I can watch offline videos fine with Kodi and SMplayer.

It might.

Re: Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 8:41 pm
by Stevo
Mauser wrote:
tekkaman wrote:So changing the kernel will fix the video issue or the frequency issue ?

The browser closing itself can happen in any video site as common as Youtube. I want to add that I can watch offline videos fine with Kodi and SMplayer.

It might.


Re frequency: No, the 4.14 kernel is a backported Debian kernel and will still use the pstate power manager by default. You can switch back to the cpufreq manager by adding that command from the Arch wiki to the kernel boot line after "quiet" in the GRUB menu to test it out, or permanently in Grub-customizer.

The Liquorix kernels currently use cpufreq by default instead of pstate, like the older kernels.

It may be some odd bug in that particular 4.13 kernel that causes your crashes, so trying some other kernel might fix it...you could try the stock 4.9 Debian and the Liqourix kernel in addition.

Re: Online videos Problem in MX 17

Posted: Fri Jan 12, 2018 10:14 pm
by Mauser
Stevo wrote:
Mauser wrote:
tekkaman wrote:So changing the kernel will fix the video issue or the frequency issue ?

The browser closing itself can happen in any video site as common as Youtube. I want to add that I can watch offline videos fine with Kodi and SMplayer.

It might.


Re frequency: No, the 4.14 kernel is a backported Debian kernel and will still use the pstate power manager by default. You can switch back to the cpufreq manager by adding that command from the Arch wiki to the kernel boot line after "quiet" in the GRUB menu to test it out, or permanently in Grub-customizer.

The Liquorix kernels currently use cpufreq by default instead of pstate, like the older kernels.

It may be some odd bug in that particular 4.13 kernel that causes your crashes, so trying some other kernel might fix it...you could try the stock 4.9 Debian and the Liqourix kernel in addition.

I am talking about the MX-17 4.14.0-12.1-liquorix-amd64 x86_64 kernel.