Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MX Updater applet not autostarting.

Help for Current Versions of MX
Post Reply
Message
Author
User avatar
Atlanelan
Forum Novice
Forum  Novice
Posts: 30
Joined: Mon Dec 18, 2017 9:52 pm

MX Updater applet not autostarting.

#1 Post by Atlanelan » Tue Dec 26, 2017 8:41 pm

MX Updater applet not showing in the panel automatically.I've to open manually everytime from menu.Autostart enabled.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21630
Joined: Wed Jul 19, 2006 6:13 am

Re: MX Updater applet not autostarting.

#2 Post by Jerry3904 » Tue Dec 26, 2017 8:56 pm

I've been seeing that lately on MX-16 but not -17. Which one are you on?
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
asqwerth
Forum Guide
Forum Guide
Posts: 2802
Joined: Sun May 27, 2007 5:37 am

Re: MX Updater applet not autostarting.

#3 Post by asqwerth » Wed Dec 27, 2017 3:59 am

I find it gets hidden a lot if Compiz is enabled. The fusion icon in the notification area often "steals" the place of the MX Updater icon.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
richb
Administrator
Posts: 16609
Joined: Wed Jul 12, 2006 2:17 pm

Re: MX Updater applet not autostarting.

#4 Post by richb » Wed Dec 27, 2017 7:25 am

In my case with Compiz it just disappears on occasion but not "hidden" by any other icon. Restarting it brings it back.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
Atlanelan
Forum Novice
Forum  Novice
Posts: 30
Joined: Mon Dec 18, 2017 9:52 pm

Re: MX Updater applet not autostarting.

#5 Post by Atlanelan » Wed Dec 27, 2017 9:19 am

Jerry3904 wrote:I've been seeing that lately on MX-16 but not -17. Which one are you on?
It is MX17.Suddenly the applet stops to autostart.

User avatar
Atlanelan
Forum Novice
Forum  Novice
Posts: 30
Joined: Mon Dec 18, 2017 9:52 pm

Re: MX Updater applet not autostarting.

#6 Post by Atlanelan » Wed Dec 27, 2017 9:20 am

asqwerth wrote:I find it gets hidden a lot if Compiz is enabled. The fusion icon in the notification area often "steals" the place of the MX Updater icon.
Compiz is not enabled in my MX17.

User avatar
Atlanelan
Forum Novice
Forum  Novice
Posts: 30
Joined: Mon Dec 18, 2017 9:52 pm

Re: MX Updater applet not autostarting.

#7 Post by Atlanelan » Wed Dec 27, 2017 9:23 am

richb wrote:In my case with Compiz it just disappears on occasion but not "hidden" by any other icon. Restarting it brings it back.
Starting manually brings the icon back to the panel but after reboot it hides.

User avatar
richb
Administrator
Posts: 16609
Joined: Wed Jul 12, 2006 2:17 pm

Re: MX Updater applet not autostarting.

#8 Post by richb » Wed Dec 27, 2017 9:25 am

Atlanelan wrote:
richb wrote:In my case with Compiz it just disappears on occasion but not "hidden" by any other icon. Restarting it brings it back.
Starting manually brings the icon back to the panel but after reboot it hides.
Mine comes back on a reboot. At times it does not after suspend or a panel reset. Bottom line is, it is unpredictable.
Forum Rules
Guide - How to Ask for Help

Rich
SSD Production: MX 17.1
AMD A8 7600 FM2+ CPU R7 Graphics, 16 GIG Mem. Three Samsung EVO SSD's 250 GB, 350 GB HD

User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2253
Joined: Thu May 01, 2014 10:12 am

Re: MX Updater applet not autostarting.

#9 Post by mmikeinsantarosa » Wed Dec 27, 2017 1:54 pm

Same here (MX-17 64bit), no notifier in the notification area. Running an update/reload on synaptic doesn't reveal any new packages so maybe the hide until updates are available is stuck.
LT: Intel Core i7-6820HQ Kernel: 4.12.0-8.3-liquorix-amd64 x86_64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

ChrisUK
Forum Novice
Forum  Novice
Posts: 87
Joined: Tue Dec 12, 2017 1:04 pm

Re: MX Updater applet not autostarting.

#10 Post by ChrisUK » Wed Dec 27, 2017 2:07 pm

In case it helps: MX Updater behaves as expected here, and I'm running MX-17 64 for 16 hours a day since Beta 1 - wireframe when no updates - green-filled when updates. Doesn't hide or quit after suspend/resume cycles either.

Only probable difference on my install to everyone else, is I use the 4.9 LTS Kernel (I've no need for later on 6 year old hardware.)
Chris

MX 17 - Manjaro - LMDE

Post Reply

Return to “MX Help”