Welcome!
Important information
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-18.1 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.3.1 release info here

New users[/u
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Cannot change keyboeard map

Help for Current Versions of MX
Post Reply
User avatar
frapelli
Forum Novice
Forum  Novice
Posts: 5
Joined: Sat Mar 14, 2009 2:10 pm

Cannot change keyboeard map

#1

Post by frapelli » Tue Dec 26, 2017 9:54 am

Installed MX 17 on an old IBM thinkpad.

Menu>settings>Keyboard>Map Model: generic; keyboard map:whatever (Italian winkey, It-Ibm, ecc). I have removed US keyboard.

Keyboard switcher on panel shows only US flag (which has been removed). Nothing happens when left-clicking, only information and exit with right-clicking.
What am I supposed to do to get italian keyboard).

Thanks

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 23737
Joined: Wed Jul 19, 2006 6:13 am

Re: Cannot change keyboeard map

#2

Post by Jerry3904 » Tue Dec 26, 2017 10:15 am

First, the general approach is through the Users Manual, Section 3.7.2. If you followed that procedure (did you uncheck "Use system defaults"?) and see Italian in the keyboard layout in Settings > keyboard, you are good to go. That flag icon doesn't handle non-English very well, so unless you have multiple keyboards you can just quit it and either 1) uncheck it in session and Startup > Applications autostart, or just uninstall it.
You do not have the required permissions to view the files attached to this post.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
frapelli
Forum Novice
Forum  Novice
Posts: 5
Joined: Sat Mar 14, 2009 2:10 pm

Re: Cannot change keyboeard map

#3

Post by frapelli » Tue Dec 26, 2017 10:44 am

Thanks Jerri3940.

Yes, I did follow procedure.
Menu>settings>Keyboard>Map Model: generic; keyboard map:whatever (Italian winkey, It-Ibm, ecc)
means:
Istantanea.png
but still US keyboard.

I tried all IT keyboards available.

Thanks
You do not have the required permissions to view the files attached to this post.

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 23737
Joined: Wed Jul 19, 2006 6:13 am

Re: Cannot change keyboeard map

#4

Post by Jerry3904 » Tue Dec 26, 2017 1:27 pm

You might need to log out and back in.

On a deeper level: could you check how the locale is set up:

Code: Select all

$locale
. If that reads LANG=en_US.UTF-8 then you will need to reset that; check Users Manual Section 3.7.2
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, SSD 120 GB, Data 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB
Personal: XPS 13, 4.18.0-19.3-liquorix, 4 GB

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 7053
Joined: Wed Jul 12, 2006 2:10 am

Re: Cannot change keyboeard map

#5

Post by Eadwine Rose » Tue Dec 26, 2017 1:35 pm

I always do this after an install:

As su enter:

Code: Select all

dpkg-reconfigure locales
I disable all non en_ and nl_ locales, and then choose en_us utf 8 as default


Might need to change that utf8 one for full effect?
MX-18_x64 20-12-2018 * 4.19.0-1-amd64 ext4 Xfce 4.12.3 * AMD Asus M4A785TD-V EVO AM3 * ASUS GF GT640-1GD5-L NVIDIA 390.87 * AMD Proc. Athl II X4 635, sAM3 * HDA ATI SB VT1708S An * 2x4Gb DDR3 1600 Kingston * Samsung S24D330 & P2250 * HP Envy5030

User avatar
frapelli
Forum Novice
Forum  Novice
Posts: 5
Joined: Sat Mar 14, 2009 2:10 pm

Re: Cannot change keyboeard map

#6

Post by frapelli » Tue Dec 26, 2017 2:50 pm

Thanks to all.

$ locale
LANG=it_IT.UTF-8
LANGUAGE=
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL


With dpkg-reconfigure i tried it_IT@euro ISO-8859-15 and it_CH.UTF. Uninsalled all other locales and rebooted each time.

US layout keeps ruling my keybord. :mad:

Post Reply

Return to “MX Help”