Welcome!
Important information
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-18.1 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.3.1 release info here

New users[/u
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

MailSpring

Help for Current Versions of MX
Frigo
Forum Novice
Forum  Novice
Posts: 15
Joined: Sun Dec 09, 2018 7:45 pm

MailSpring

#1

Post by Frigo » Sun Feb 10, 2019 5:20 pm

I know using Snaps requires Systemd. So, I've booted using this option. Snapd installed and so did Mindspring, but now it will not even show a startup screen. It appears that no snap services are running. Are there any suggestion for getting MindSpring running on my system?

System:
Host: mx Kernel: 4.19.0-1-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0
Desktop: Xfce 4.12.3 Distro: MX-18_x64 Continuum Dec 20 2018
base: Debian GNU/Linux 9 (stretch)
Machine:

xali
Forum Regular
Forum Regular
Posts: 166
Joined: Wed Dec 28, 2016 6:14 am

Re: MailSpring

#2

Post by xali » Sun Feb 10, 2019 6:07 pm

mailspring or mindspring? your title says mailspring but later you say mindspring...

anyway mailspring offers a deb package. you can install it that way, but you are going to need some dependences that you can find in synaptic. I just tried with a live usb with mx 18. mailspring seems nice by the first impression

Frigo
Forum Novice
Forum  Novice
Posts: 15
Joined: Sun Dec 09, 2018 7:45 pm

Re: MailSpring

#3

Post by Frigo » Mon Feb 11, 2019 9:33 pm

Sorry, it is Mailspring. WAY back when, there was an ISP called Mindspring...

Frigo
Forum Novice
Forum  Novice
Posts: 15
Joined: Sun Dec 09, 2018 7:45 pm

Re: MailSpring

#4

Post by Frigo » Mon Feb 11, 2019 10:06 pm

Well, come to find out, I can't install using the deb package as I have unresolved dependency issues. Specifically, the .deb install gives the following error: "Cannot install 'libsecret-1-dev'".

When installing the missing dependency via Synaptic, I also run into the same broken package error.

I even tried installing with aptitude, but it also failed.

Any idea how to "unbreak" libsecret-1-dev?

User avatar
Buck Fankers
Forum Regular
Forum Regular
Posts: 232
Joined: Sat Mar 10, 2018 9:06 pm

Re: MailSpring

#5

Post by Buck Fankers » Mon Feb 11, 2019 10:46 pm

Hmm, so in order to use this desktop app, you need to register with them, create an account.
And it is build with electron. These are two no-no's for me. Claws mail for me ;-)

xali
Forum Regular
Forum Regular
Posts: 166
Joined: Wed Dec 28, 2016 6:14 am

Re: MailSpring

#6

Post by xali » Tue Feb 12, 2019 5:48 am

Frigo wrote:Any idea how to "unbreak" libsecret-1-dev?
probably you didn't notice the other requirement you need which is gir1.2-gnomekeyring-1.0
Buck Fankers wrote:Hmm, so in order to use this desktop app, you need to register with them, create an account.
And it is build with electron. These are two no-no's for me
i agree with this...

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 17967
Joined: Fri Dec 15, 2006 8:07 pm

Re: MailSpring

#7

Post by Stevo » Tue Feb 12, 2019 4:59 pm

Libsecret-1-dev installs fine on standard MX 18.1, as well as the 64-bit mailspring deb, so you have some broken packages somehow.

What do you show for

Code: Select all

apt policy libsecret-1-dev
and

Code: Select all

aptitude why-not libsecret-1-dev
(install aptitude first if necessary)

Frigo
Forum Novice
Forum  Novice
Posts: 15
Joined: Sun Dec 09, 2018 7:45 pm

Re: MailSpring

#8

Post by Frigo » Wed Feb 13, 2019 9:56 am

------
$ apt policy libsecret-1-dev
libsecret-1-dev:
Installed: (none)
Candidate: 0.18.5-3.1
Version table:
0.18.5-3.1 500
500 http://ftp.us.debian.org/debian stretch/main amd64 Packages

$ aptitude why-not libsecret-1-dev
Not currently installed
The candidate version 0.18.5-3.1 has priority optional
No dependencies require to remove libsecret-1-dev

-------

Installing libsecret-1-dev yields:

The following packages have unmet dependencies:
libsecret-1-dev : Depends: libglib2.0-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 4108
Joined: Sun May 27, 2007 5:37 am

Re: MailSpring

#9

Post by asqwerth » Wed Feb 13, 2019 1:31 pm

What's the output of

Code: Select all

inxi -r
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
dreamer
Forum Regular
Forum Regular
Posts: 295
Joined: Sun Oct 15, 2017 11:34 am

Re: MailSpring

#10

Post by dreamer » Wed Feb 13, 2019 1:57 pm

Mailspring version 1.5.5 64 bit deb package installed correctly here. I'm using it with Gmail. It uses about 500 MiB (5 processes). SeaMonkey (just the mail client) uses 200 MiB. So there is a price to pay for Electron. That being said, Mailspring is pretty good.

Post Reply

Return to “MX Help”