Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

None of my browsers can play embedded videos any more

Help for Current Versions of MX
User avatar
Captain Brillo
Forum Regular
Forum Regular
Posts: 198
Joined: Mon Jan 07, 2019 12:29 am

None of my browsers can play embedded videos any more

#1

Post by Captain Brillo » Fri Jan 11, 2019 10:28 am

I'm running Vivaldi, Slimjet and Firefox.
All of a sudden today, Vivaldi can't run videos, so I assumed, at first, that it was a repeat of the reason I stopped using Opera.
But then I tried Slimjet and Firefox, and neither of them is working.
YouTube works, but not videos like those on smithsonian.com or theweathernetwork.com
Flash is installed from the repo.

Any suggestions? More info needed?
GAFA-free zone

User avatar
chrispop99
Forum Guide
Forum Guide
Posts: 2824
Joined: Tue Jan 27, 2009 3:07 pm

Re: None of my browsers can play embedded videos any more

#2

Post by chrispop99 » Fri Jan 11, 2019 10:39 am

I have the latest updated Flash, and video on the two websites you mention work here in Firefox.

Right-click the MX-Updater, and select History. Check your Flash plugin is the latest version:

Code: Select all

adobe-flashplugin                       amd64  1:20181205.1-1mx17+1              1:20190108.1-1mx17+1
Chris
Test machines:
32-bit non-PAE - Thinkpad T41, 1.6GHz Pentium M, 1GB RAM.
32-bit PAE - DELL Latitude D610, 1.73GHz Pentium M, 2GB RAM.
64-bit - Lenovo T61, 2GHz Core 2 Duo, 2GB RAM
64-bit - Gigabyte Z77P-D3, Intel i3-3220, GeForce 8400 GS, 4GB PC3-12800.

User avatar
Captain Brillo
Forum Regular
Forum Regular
Posts: 198
Joined: Mon Jan 07, 2019 12:29 am

Re: None of my browsers can play embedded videos any more

#3

Post by Captain Brillo » Fri Jan 11, 2019 11:22 am

Yep.
Latest versions of everything.
GAFA-free zone

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8352
Joined: Wed Jul 12, 2006 2:10 am

Re: None of my browsers can play embedded videos any more

#4

Post by Eadwine Rose » Fri Jan 11, 2019 11:44 am

Have you rebooted since the install?
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
PondLife
Forum Novice
Forum  Novice
Posts: 91
Joined: Wed May 09, 2018 12:24 pm

Re: None of my browsers can play embedded videos any more

#5

Post by PondLife » Fri Jan 11, 2019 11:51 am

Don't think it is flash. Can play video on both sites (Html5) in Firefox and I don't have adobe-flash installed.

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1535
Joined: Sat Jun 30, 2018 6:33 pm

Re: None of my browsers can play embedded videos any more

#6

Post by manyroads » Fri Jan 11, 2019 11:54 am

Maybe your removal of Opera 'borked' something.

First, I'd try reinstalling your 'broken' browsers.
Second, you can try installing pepperflash to see if that might fix things.
"Don't believe everything you think."
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
Dell Latitude E5470
Intel i5-6300U~ 24GB RAM ~ SSD: 1TB
Coding since 1974

User avatar
Eadwine Rose
Forum Veteran
Forum Veteran
Posts: 8352
Joined: Wed Jul 12, 2006 2:10 am

Re: None of my browsers can play embedded videos any more

#7

Post by Eadwine Rose » Fri Jan 11, 2019 1:21 pm

Alternatively, check the history and post here what got removed if you removed stuff.
MX-18.3_x64 May 26 2019 * 4.19.0-5-amd64 ext4 Xfce 4.12.3 * 8-core AMD Ryzen 7 2700
Asus TUF B450-Plus Gaming UEFI * Asus GTX 1050 Ti Nvidia 390.116 * 2x16Gb DDR4 2666 Kingston HyperX Predator
Samsung 860EVO * Samsung S24D330 & P2250 * HP Envy5030

User avatar
Captain Brillo
Forum Regular
Forum Regular
Posts: 198
Joined: Mon Jan 07, 2019 12:29 am

Re: None of my browsers can play embedded videos any more

#8

Post by Captain Brillo » Fri Jan 11, 2019 1:55 pm

Uninstalled 3 browsers and flash. Rebooted.
installed 3 browsers and flash. Rebooted.
Vivaldi still borked, getting same error:

Code: Select all

This video is either unavailable or not supported in this browser
Error Code: MEDIA_ERR_SRC_NOT_SUPPORTED
Tried fixes from Vivaldi forum, no luck so far.
GAFA-free zone

User avatar
manyroads
Forum Guide
Forum Guide
Posts: 1535
Joined: Sat Jun 30, 2018 6:33 pm

Re: None of my browsers can play embedded videos any more

#9

Post by manyroads » Fri Jan 11, 2019 2:11 pm

@Captain Brillo, you might try contacting @handy via PM. He is very deep into/ savvy about Vivaldi. Perhaps he can offer you a clue/ solution?!!
"Don't believe everything you think."
Pax vobiscum,
Mark Rabideau - http://many-roads.com - Reg. Linux User #449130
MX-18.3 kernel: 5.1.11-antix.1-amd64-smp
Dell Latitude E5470
Intel i5-6300U~ 24GB RAM ~ SSD: 1TB
Coding since 1974

philotux
Forum Regular
Forum Regular
Posts: 428
Joined: Sun Apr 22, 2018 12:57 pm

Re: None of my browsers can play embedded videos any more

#10

Post by philotux » Fri Jan 11, 2019 2:12 pm

Could it be related to this:
https://www.slimjet.com/en/libffmpeg.php
Slimjet doesn't include h.264, AAC and mp3 decoders on Linux and Mac platform due to patent issues. Without h.264 and AAC decoders, HTML5 videos encoded with MP4 format will not be playable. Without mp3 decoder, mp3 streaming music will not be playable. There are some external ffmpeg libraries contributed by the community which includes the proprietary decoders. You can download and install them on your own. Make sure you quit Slimjet first before installing the external ffmpeg library.

Please note that the major version of the ffmpeg library should match with the Blink engine version of Slimjet. Otherwise, Slimjet might not be able to run at all. Always backup the original copy of libffmpeg.so before overwriting it with the external copy. The instructions here are intended for the latest version (21.0.8.0)of Slimjet. If you are using an older version of Slimjet, you might need find an older version of ffmpeg library to be compatible.
You can download libffmpeg.so from the ubuntu chromium-codecs-ffmpeg-extra package. The file name to pick should have such a pattern: chromium-codecs-ffmpeg-extra_$ChromiumVersion-0ubuntu0.$UbuntuVersion_$SystemBits.deb. $ChromiumVersion is the Chromium engine version used by Slimjet. You can check that in Help center->About Slimjet. $UbuntuVersion is the version of your linux. $SystemBits is amd64 for 64-bit Slimjet and i386 for 32-bit Slimjet. If you can't find an exact match for the version numbers, get the best match and try your luck. Extract the file libffmpeg.so out of the deb archive using the dpkg command.

>dpkg -x downloaded_file.deb .

The libffmpeg.so file is located under the subfolder "usr/lib/chromium-browser" after dpkg extraction. You can use some GUI archive manager to extract the file as well such as the built-in archive manager shipped with Ubuntu. After that, use the following commands to copy libffmpeg.so to the Slimjet installation folder ("/opt/slimjet" on Ubuntu),

>sudo cp libffmpeg.so /opt/slimjet/
I have seen similar issue with Opera and Vivaldi as well elsewhere.
Last edited by philotux on Fri Jan 11, 2019 2:15 pm, edited 1 time in total.

Post Reply

Return to “MX Help”