Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Disable: Granted permissions without asking for password

Help for Current Versions of MX
Post Reply
Message
Author
User avatar
leegold
Forum Novice
Forum  Novice
Posts: 4
Joined: Fri Dec 07, 2018 12:03 pm

Disable: Granted permissions without asking for password

#1 Post by leegold » Fri Dec 07, 2018 12:18 pm

I want to turn-off "Granted permissions without asking for password". I want it to turn-off this feature.

I can't seem to find the edit or script that will disable this.

Using: MX-17.1_x64 Horizon

Thanks

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2451
Joined: Wed Apr 11, 2018 5:09 pm

Re: Disable: Granted permissions without asking for password

#2 Post by fehlix » Fri Dec 07, 2018 12:29 pm

leegold wrote:
Fri Dec 07, 2018 12:18 pm
I want to turn-off "Granted permissions without asking for password". I want it to turn-off this feature.

I can't seem to find the edit or script that will disable this.

Using: MX-17.1_x64 Horizon

Thanks
You might switch to sudo mode by running this:

Code: Select all

gksu-properties
Which will change those password-popups to enter you personal passwords instead.
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
leegold
Forum Novice
Forum  Novice
Posts: 4
Joined: Fri Dec 07, 2018 12:03 pm

Re: Disable: Granted permissions without asking for password

#3 Post by leegold » Mon Dec 10, 2018 2:55 pm

"gksu-properties" helped. Thanks.

One other thing I notice. With MX I do a sudo command let's say, "$ sudo apt-get update" then I close the terminal window. I reopen the terminal again and the commands works again without prompting for password.

What I expect is something different. I expected if I reopen the the terminal I will be prompted for the password again no matter what. If I did not reopen and had the same terminal process open I will have a few minutes of sudo non-prompting for a few minutes while I do stuff - a grace time from the last sudo. Also if I leave that original terminal open for over 5 minutes (or whatever the time is set to) without any use time expires and I need reenter password.

Closing the terminal definitely causes a prompt again for sudo. It's the standard action I remember from Ubuntu and most other distros. This is not happening in MX. How do I config this please?

Could these configs be asked during install? Maybe I missed it? There are a few people who normally use this PC in rapid succession who don't need to have root access.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2451
Joined: Wed Apr 11, 2018 5:09 pm

Re: Disable: Granted permissions without asking for password

#4 Post by fehlix » Mon Dec 10, 2018 3:22 pm

leegold wrote:
Mon Dec 10, 2018 2:55 pm
How do I config this please?
- sudoers timestamp_timeout can be set with visudo.
- sudo -k resets the timestamp manual
- can be set on closing terminal, e.g. by change the command for invoking the terminal and add "sudo -k"
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

User avatar
leegold
Forum Novice
Forum  Novice
Posts: 4
Joined: Fri Dec 07, 2018 12:03 pm

Re: Disable: Granted permissions without asking for password

#5 Post by leegold » Tue Dec 11, 2018 11:56 am

> - can be set on closing terminal, e.g. by change the command for invoking the terminal and add "sudo -k"

Sorry I guess I need this spoon fed. What's the steps? Sorry, Thanks.

User avatar
fehlix
Forum Guide
Forum Guide
Posts: 2451
Joined: Wed Apr 11, 2018 5:09 pm

Re: Disable: Granted permissions without asking for password

#6 Post by fehlix » Tue Dec 11, 2018 12:14 pm

leegold wrote:
Tue Dec 11, 2018 11:56 am
> - can be set on closing terminal, e.g. by change the command for invoking the terminal and add "sudo -k"

Sorry I guess I need this spoon fed. What's the steps? Sorry, Thanks.
Might be easier to reset timeout just before invoking the terminal. What's the way you start the terminal normaly, easiest to adjust those terminal calls. Alternatively have a wrapper whithin somehting like 'sudo -k; xfce4-terminal ...'.
Guess you see the idea ... ;)
Gigabyte Z77M-D3H, Intel Xeon E3-1240 V2 (Quad core), 32GB RAM,
GeForce GTX 770, Samsung SSD 850 EVO 500GB, Seagate Barracuda 4TB

Post Reply

Return to “MX Help”