Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[Solved] Setting up PPTP VPN to access both the private network and the internet

Help for Current Versions of MX
Message
Author
User avatar
proskehy
Forum Novice
Forum  Novice
Posts: 8
Joined: Mon Nov 26, 2018 10:17 am

[Solved] Setting up PPTP VPN to access both the private network and the internet

#1 Post by proskehy » Fri Dec 07, 2018 10:47 am

I've been struggling to set up my VPN so that I can access both the private network it is meant to provide access to and the internet.

I know that in Windows, it can be achieved by going into the VPN adapter settings, unchecking IPv6 and, in the advanced IPv4 config, unchecking 'Use default gateway on remote network'. (see the attached picture).

However, I haven't been able to replicate these settings in my VPN config on MX Linux. I tried clicking through the whole VPN config UI on my MX, but none of the settings similar to these Windows settings (there is one in the Advanced tab of IPv4) didn't help.

Any idea how to get this to work?

Thank you.
You do not have the required permissions to view the files attached to this post.
Last edited by proskehy on Sat Dec 08, 2018 6:55 am, edited 1 time in total.

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 2132
Joined: Tue Feb 06, 2007 11:47 pm

Re: Setting up PPTP VPN to access both the private network and the internet

#2 Post by smilliken » Fri Dec 07, 2018 11:39 am

What VPN product are you using? I use NordVPN at work and Ivacy at home. Each sets up a little bit different, and really aren't that bad to set up. Most commercial VPN's have downloadable server settings that you locate on your computer during the set up of the VPN within Netowrkmanager.
There is no "Ctrl+Z" in life!
Panasonic Toughpad FZ-G1 - MX-17
Acer 7551G MX-17 | Dell 1525, MX17 & Win 10
HP DV4-1118 Mx17 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
proskehy
Forum Novice
Forum  Novice
Posts: 8
Joined: Mon Nov 26, 2018 10:17 am

Re: Setting up PPTP VPN to access both the private network and the internet

#3 Post by proskehy » Fri Dec 07, 2018 11:42 am

Yeah, most commercially offered VPNs are a piece of cake to set up. This is, however, just a corporate VPN for my workplace.

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 2132
Joined: Tue Feb 06, 2007 11:47 pm

Re: Setting up PPTP VPN to access both the private network and the internet

#4 Post by smilliken » Fri Dec 07, 2018 11:52 am

what is the make?
There is no "Ctrl+Z" in life!
Panasonic Toughpad FZ-G1 - MX-17
Acer 7551G MX-17 | Dell 1525, MX17 & Win 10
HP DV4-1118 Mx17 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
proskehy
Forum Novice
Forum  Novice
Posts: 8
Joined: Mon Nov 26, 2018 10:17 am

Re: Setting up PPTP VPN to access both the private network and the internet

#5 Post by proskehy » Fri Dec 07, 2018 11:56 am

I'm afraid I don't know much more besides that it uses PPTP and MS-CHAP v2. What kind of make do you have in mind?

derrotmax
Forum Novice
Forum  Novice
Posts: 12
Joined: Wed Jul 25, 2018 10:45 pm

Re: Setting up PPTP VPN to access both the private network and the internet

#6 Post by derrotmax » Fri Dec 07, 2018 2:13 pm

What you're referring to is called "split-tunneling". If you used the network manager to set up your PPTP VPN (on my machines I've had to install "network-manager-pptp-gnome" from the Package Manager to get PPTP working), then go back into your config, click on the IPV4 Settings tab, then click the Routes button, and then check the box labeled "Use this connection only for resources on its network", and see if that works for you. In my setups, I also have to make sure I have the Firewall application turned off as it loves to prevent PPTP from connecting.

User avatar
proskehy
Forum Novice
Forum  Novice
Posts: 8
Joined: Mon Nov 26, 2018 10:17 am

Re: Setting up PPTP VPN to access both the private network and the internet

#7 Post by proskehy » Fri Dec 07, 2018 2:46 pm

derrotmax wrote:
Fri Dec 07, 2018 2:13 pm
What you're referring to is called "split-tunneling". If you used the network manager to set up your PPTP VPN (on my machines I've had to install "network-manager-pptp-gnome" from the Package Manager to get PPTP working), then go back into your config, click on the IPV4 Settings tab, then click the Routes button, and then check the box labeled "Use this connection only for resources on its network", and see if that works for you. In my setups, I also have to make sure I have the Firewall application turned off as it loves to prevent PPTP from connecting.
Right, I also had to install the pptp-gnome package to even get into the config. I tried checking said box and if I do that, I can access the internet but can't access the resources on the VPN :/ I encountered issues where the firewall blocks PPTP on Fedora before, but when checking in MX Linux, firewall wasn't even on, so that shouldn't be the problem.

I feel like the checkbox you mentioned should work, but since it doesn't, I'm pretty lost on what to do...

User avatar
smilliken
Forum Guide
Forum Guide
Posts: 2132
Joined: Tue Feb 06, 2007 11:47 pm

Re: Setting up PPTP VPN to access both the private network and the internet

#8 Post by smilliken » Fri Dec 07, 2018 5:02 pm

Going to throw this out there, but would this have anything to do with the certificates?
There is no "Ctrl+Z" in life!
Panasonic Toughpad FZ-G1 - MX-17
Acer 7551G MX-17 | Dell 1525, MX17 & Win 10
HP DV4-1118 Mx17 & Win 10
HP CP1215/Brother DCP-7065DN
Linux User# 4523410

User avatar
proskehy
Forum Novice
Forum  Novice
Posts: 8
Joined: Mon Nov 26, 2018 10:17 am

Re: Setting up PPTP VPN to access both the private network and the internet

#9 Post by proskehy » Fri Dec 07, 2018 6:25 pm

smilliken wrote:
Fri Dec 07, 2018 5:02 pm
Going to throw this out there, but would this have anything to do with the certificates?
I'm not sure, but I don't think so (?)

I don't need any certificates to connect/make both VPN and the internet work on Windows, so I'm not sure why I'd need any on Linux.

derrotmax
Forum Novice
Forum  Novice
Posts: 12
Joined: Wed Jul 25, 2018 10:45 pm

Re: Setting up PPTP VPN to access both the private network and the internet

#10 Post by derrotmax » Fri Dec 07, 2018 7:16 pm

proskehy wrote:
Fri Dec 07, 2018 2:46 pm
derrotmax wrote:
Fri Dec 07, 2018 2:13 pm
What you're referring to is called "split-tunneling". If you used the network manager to set up your PPTP VPN (on my machines I've had to install "network-manager-pptp-gnome" from the Package Manager to get PPTP working), then go back into your config, click on the IPV4 Settings tab, then click the Routes button, and then check the box labeled "Use this connection only for resources on its network", and see if that works for you. In my setups, I also have to make sure I have the Firewall application turned off as it loves to prevent PPTP from connecting.
Right, I also had to install the pptp-gnome package to even get into the config. I tried checking said box and if I do that, I can access the internet but can't access the resources on the VPN :/ I encountered issues where the firewall blocks PPTP on Fedora before, but when checking in MX Linux, firewall wasn't even on, so that shouldn't be the problem.

I feel like the checkbox you mentioned should work, but since it doesn't, I'm pretty lost on what to do...
It really sounds like a possible routing issue on your machine -- in my case, I have no problem with my split tunnel, but that and $5 will get you a cup of coffee in your situation. I did some checking around to see if maybe that could be the case and I found the following post...maybe it'll point you in the right direction?

https://askubuntu.com/questions/664931/ ... lit-tunnel

Post Reply

Return to “MX Help”