Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Scanner Issues

Help for Current Versions of MX
Message
Author
MarkG
Forum Novice
Forum  Novice
Posts: 40
Joined: Sun May 06, 2018 3:54 pm

Re: Scanner Issues

#21 Post by MarkG » Tue Sep 04, 2018 3:03 am

I have a CanoScan LIDE n650 scanner that has worked under every linux distro that has had it thrown at it with the exception of one distro based around Fedora.

Working under MX Linux is sketchy at best.

Load the bundled scanner and it will sometimes read the device but not scan from it, it crashes and I have to point out that it was fine until about the 3rd update.

There is no question about my scanner being compatible, it is a questionable that programming is getting very unsupportable of legacy devices. This is where all distros can mop up disgruntled windows users over their actions.

Simple thing in life is that people do not like change, when they are familiar with something that is all they need and like my friends mother, she had a windows PC for her work at home. When I laid eyes on it, it was really old, I am talking about Green Screen, text based and DOS on an 8" floppy. At the time the PC was something like 15 years old and still working fine when 486DX's were blazing the trail of PC development and it was still working fine when the firs systems which were over 1GHz hit the scene...

I guess the moral of the story here is, just because it is old doesn't mean its not serviceable of useful. It was what set Linux apart from Microsoft, now, the lines are beginning to get blurred.

User avatar
Caesar2
Forum Regular
Forum Regular
Posts: 194
Joined: Wed Jul 27, 2011 2:57 pm

Re: Scanner Issues

#22 Post by Caesar2 » Wed Oct 10, 2018 3:49 pm

I got this Canoscan Lide 220 in the mail today. Plugged it into MX17 and it seemed to not work.
Plugged it into MX16 and it seemed to not work.
Edited several files as recommended in above posts and the link to the manual.
I installed sane also and gscan2pdf.
Rebooted and to my surprise, the thing works.
So much for plug and play, but at least it works.
I bought it because the ppl at PCLinuxOS said it was plug and play and I figured surely it would be on MX also.
Anyway, after an hour or so of following this threads' advice, I can rest easy.
Thanks to all the people who contributed suggestions here that got me up and running.
-Bill
MOTHERBOARD ASUS|F2A85-V PRO A85 FM2 R
PROCESSOR AMD A10-5800K APU with Radeon(tm) HD
3.8G 4M FM2 R
MEMORY 8 Gig
Segate 250 Gig

VIDEO CARD - ONBOARD AMD/ATI
TRINITY [RADEON 7660D]
vesa/fglrx BUS: PCI EXPRESS

Kulmbacher
Forum Novice
Forum  Novice
Posts: 79
Joined: Fri Apr 27, 2018 2:47 pm

Re: Scanner Issues

#23 Post by Kulmbacher » Thu Oct 11, 2018 5:17 am

Canoscan LIDE25 from fleamarket did not work, all suggestions above considered.

A different USB Cable brougth the solution, sometimes it can be so easy :-)

Post Reply

Return to “MX Help”