Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Laptops

Topics relating to MX Docs and MX Videos
Message
Author
User avatar
mmikeinsantarosa
Forum Guide
Forum Guide
Posts: 2253
Joined: Thu May 01, 2014 10:12 am

Re: Laptops

#21 Post by mmikeinsantarosa » Sun Jan 24, 2016 12:02 am

uncle mark wrote:So Mike, that looks like five old beater doorstops you've resurrected with Linux.
Watch it, them beaters are my friends :hell:
LT: Intel Core i7-6820HQ Kernel: 4.12.0-8.3-liquorix-amd64 x86_64 (64 bit)
DT: Intel(R) Core i5-3.1GHz Kernel~3.9-1-mepis64 x86_64

User avatar
uncle mark
Forum Veteran
Forum Veteran
Posts: 4936
Joined: Sat Nov 11, 2006 10:42 pm

Re: Laptops

#22 Post by uncle mark » Sun Jan 24, 2016 12:44 am

mmikeinsantarosa wrote:
uncle mark wrote:So Mike, that looks like five old beater doorstops you've resurrected with Linux.
Watch it, them beaters are my friends :hell:
I bet you're fun at parties.
Desktop: Custom build Asus/AMD/nVidia -- MEPIS 11
Laptop: Acer Aspire 5250 -- MX-15
Assorted junk: assorted Linuxes

User avatar
zeeone
Forum Regular
Forum Regular
Posts: 901
Joined: Fri Jul 14, 2006 12:50 am

Re: Laptops

#23 Post by zeeone » Sun Jan 24, 2016 1:08 am

Yahoo, a party! :cool:
Research, Research, Research, Before You Walk The Plank.
Registered Linux User # 398829

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 8484
Joined: Sun Dec 16, 2007 1:17 pm

Re: Laptops

#24 Post by dolphin_oracle » Mon Jan 25, 2016 9:27 pm

Acer c720 Chrombook

I'm running live. I have not installed to this laptop.

1) 32 or 64bit? 32 bit works out of the box. 64 bit works with a different kernel.
2) can you boot to the desktop? Yes
3) what works OOTB? - everything, although the chromebook keyboard special keys act as function keys. the search key is the Super Key.
4) what doesn't work OOTB? 64 bit iso will not get past boot loader screen. Just automatically reboots. I'm using a custom snapshot iso with the 4.2.3 liquorix kernel and a custom keyboard shortcut file to remap the "special" keys to more obvious functions. Touchpad is a little muddy. Using a custom 50-c720-touchpad.conf to make a few adjustments.
5) Comments (short) - Only running live on this system. Have not tried installing. Chromeos needs to be put into developer mode for usb boots to work.
6) inxi -F

Code: Select all

demo@mx1:~
$ inxi -F
System:    Host: mx1 Kernel: 4.2-3.dmz.3-liquorix-amd64 x86_64 (64 bit) Desktop: Xfce 4.12.2
           Distro: MX-15_x64 Fusion 24 December 2015
Machine:   System: Acer product: Peppy v: 1.0
           Mobo: N/A model: N/A Bios: coreboot v: N/A date: 01/16/2015
CPU:       Dual core Intel Celeron 2955U (-MCP-) cache: 2048 KB 
           clock speeds: max: 1400 MHz 1: 1399 MHz 2: 1286 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 10.3.2
Audio:     Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.2-3.dmz.3-liquorix-amd64
Network:   Card: Qualcomm Atheros AR9462 Wireless Network Adapter driver: ath9k
           IF: wlan0 state: up mac: 48:5a:b6:61:90:ef
Drives:    HDD Total Size: 24.0GB (4.6% used) ID-1: /dev/sda model: KINGSTON_SNS4151 size: 16.0GB
           ID-2: USB /dev/sdb model: Cruzer_Blade size: 8.0GB
Sensors:   System Temperatures: cpu: 39.8C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 153 Uptime: 26 min Memory: 422.2/1879.6MB Client: Shell (bash) inxi: 2.2.31 
demo@mx1:~
$ 
wiki entry here: http://www.mepiscommunity.org/wiki/mx-1 ... chromebook
http://www.youtube.com/runwiththedolphin
eeepc 904ha antix 17 32 bit (streaming media player)
lenovo ThinkPad T530 - MX-17
lenovo s21e - antiX-17, MX17(live-usb)

john_j
Forum Novice
Forum  Novice
Posts: 9
Joined: Wed Dec 02, 2015 11:50 am

Re: Laptops

#25 Post by john_j » Wed Jan 27, 2016 9:29 am

1) 32 or 64bit? 64 bit
2) can you boot to the desktop? yes
3) what works OOTB? Installed MX-15 quite a while ago and I think everything worked OOTB
4) what doesn't work OOTB? Did you find a fix? nothing I can recall
5) Comments (short) I use this laptop asmy daily home computer
6) inxi -F

System: Host: mx1 Kernel: 4.2-3.dmz.3-liquorix-amd64 x86_64 (64 bit)
Desktop: Xfce 4.12.2 Distro: MX-15-b2_x64 Fusion 24 November 2015
Machine: System: LENOVO product: 4236MBU v: ThinkPad T420
Mobo: LENOVO model: 4236MBU
Bios: LENOVO v: 83ET63WW (1.33 ) date: 07/29/2011
CPU: Dual core Intel Core i5-2540M (-HT-MCP-) cache: 3072 KB
clock speeds: max: 3300 MHz 1: 819 MHz 2: 806 MHz 3: 800 MHz
4: 978 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1600x900@60.00hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile
GLX Version: 3.0 Mesa 10.3.2
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel
Sound: ALSA v: k4.2-3.dmz.3-liquorix-amd64
Network: Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e
IF: eth0 state: down mac: 00:21:cc:6a:79:aa
Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
driver: iwlwifi
IF: wlan0 state: up mac: 08:11:96:25:87:10
Drives: HDD Total Size: 320.1GB (14.1% used)
ID-1: /dev/sda model: ST320LT007 size: 320.1GB
Partition: ID-1: / size: 292G used: 41G (15%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 2.17GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 41.0C mobo: N/A
Fan Speeds (in rpm): cpu: 1974
Info: Processes: 197 Uptime: 2:58 Memory: 1109.6/3903.9MB
Client: Shell (bash) inxi: 2.2.31

User avatar
Gaer Boy
Forum Guide
Forum Guide
Posts: 2108
Joined: Sat Jun 06, 2009 6:06 am

Re: Laptops

#26 Post by Gaer Boy » Wed Jan 27, 2016 11:13 am

HP x2 10-n054a Detachable laptop

1) 64-bit MX on 64-bit processor with 32-bit UEFI only.
2) Live boot to desktop fine. Installed boot a problem. Now OK with 'nomodeset' cheat.
3) Basically OK OOTB (see 4)
4) No audio, no network. Fix in prospect for network (kernel patch yet to be tested). Audio fix looks doubtful.
5) Decided to classify this as laptop rather than netbook. Nice machine to handle, OK as Win8 (if you like that) and runs MX-15 in VBox on Win8 OK. Definitely a struggle to install MX and still a work-in-progress.

Code: Select all

$ inxi -F
System:    Host: mx1 Kernel: 4.2.0-0.bpo.1-amd64 x86_64 (64 bit) Desktop: Xfce 4.12.2
           Distro: MX-15_x64 Fusion 24 December 2015
Machine:   System: Hewlett-Packard product: HP Pavilion x2 Detachable v: Type1 - ProductConfigId
           Mobo: Hewlett-Packard model: 815D v: 26.0B Bios: Insyde v: F.04 date: 05/31/2015
CPU:       Quad core Intel Atom Z3736F (-MCP-) cache: 1024 KB
           clock speeds: max: 2165 MHz 1: 532 MHz 2: 768 MHz 3: 499 MHz 4: 499 MHz
Graphics:  Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
           Display Server: X.Org 1.16.4 drivers: fbdev,intel (unloaded: vesa)
           Resolution: 1280x800@0.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.5, 128 bits) GLX Version: 3.0 Mesa 10.3.2
Audio:     Card Failed to Detect Sound Card! Sound: ALSA v: k4.2.0-0.bpo.1-amd64
Network:   Card: Failed to Detect Network Card!
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 31.3GB
Partition: ID-1: / size: 5.6G used: 3.3G (63%) fs: ext4 dev: /dev/mmcblk0p5
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 150 Uptime: 31 min Memory: 249.5/1935.8MB Client: Shell (bash) inxi: 2.2.31 

AsRock FM2A88X-ITX+, A8-6500, 8GB, 120GB Samsung SSD (GPT), 1TB HDD (MBR), MX-16
Lenovo Thinkpad X220, dual-core i5, 3MB, 320GB Hitachi HDD, Win7, MX-16.1

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 21638
Joined: Wed Jul 19, 2006 6:13 am

Re: Laptops

#27 Post by Jerry3904 » Wed Jan 27, 2016 11:20 am

Thanks for working so hard with BitJam on this--we will all benefit.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

NGIB
Forum Regular
Forum Regular
Posts: 461
Joined: Sat Apr 05, 2014 12:12 pm

Re: Laptops

#28 Post by NGIB » Thu Jan 28, 2016 8:25 pm

My latest used computer, a Thinkpad X230. Loaded 64 bit and all works OOTB...

Code: Select all

System:    Host: tpd Kernel: 4.1-7.dmz.1-amd64 x86_64 (64 bit gcc: 4.9.2)
           Desktop: Xfce 4.12.2 (Gtk 2.24.25) info: xfce4-panel dm: lightdm
           Distro: MX-15_x64 Fusion 24 December 2015
Machine:   System: LENOVO product: 23252QU v: ThinkPad X230 Chassis: type: 10
           Mobo: LENOVO model: 23252QU Bios: LENOVO v: G2ET94WW (2.54 ) date: 04/30/2013
CPU:       Dual core Intel Core i5-3320M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10376
           clock speeds: min/max: 1200/3300 MHz 1: 1537 MHz 2: 1201 MHz 3: 1201 MHz 4: 1199 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:0166
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.02hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 11.0.6 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1e20
           Sound: Advanced Linux Sound Architecture v: k4.1-7.dmz.1-amd64
Network:   Card-1: Intel 82579LM Gigabit Network Connection
           driver: e1000e v: 2.3.2-k port: 5080 bus-ID: 00:19.0 chip-ID: 8086:1502
           IF: eth0 state: down mac: 3c:97:0e:bc:81:4a
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
           driver: iwlwifi bus-ID: 03:00.0 chip-ID: 8086:0085
           IF: wlan0 state: up mac: a4:4e:31:38:32:90
Drives:    HDD Total Size: 320.1GB (1.2% used)
           ID-1: /dev/sda model: HITACHI_HTS72323 size: 320.1GB serial: E3834563DVZPWM
Partition: ID-1: / size: 136G used: 3.6G (3%) fs: ext4 dev: /dev/sda3
Sensors:   System Temperatures: cpu: 46.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 166 Uptime: 8 min Memory: 239.3/7688.3MB
           Init: SysVinit v: 2.88 runlevel: 5 default: 5 Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301 running in xfce4-terminal) inxi: 2.2.31 
Life's tough, it's tougher if you're stupid...

User avatar
j2mcgreg
Forum Regular
Forum Regular
Posts: 348
Joined: Tue Oct 23, 2007 12:04 pm

Re: Laptops

#29 Post by j2mcgreg » Thu Jan 28, 2016 9:25 pm

1) 64 bit
2) yes
3) everything works

inxi -F
System: Host: jimmiecarr Kernel: 4.2.0-0.bpo.1-amd64 x86_64 (64 bit)
Desktop: Xfce 4.12.2 Distro: MX-15_x64 Fusion 24 December 2015
Machine: Mobo: Acer model: Aspire 5742 v: V1.07
Bios: Acer v: V1.07 date: 09/27/2010
CPU: Dual core Intel Core i3 M 370 (-HT-MCP-) cache: 3072 KB
clock speeds: max: 2399 MHz 1: 1066 MHz 2: 1066 MHz 3: 1066 MHz
4: 1066 MHz
Graphics: Card: Intel Core Processor Integrated Graphics Controller
Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.04hz
GLX Renderer: Mesa DRI Intel Ironlake Mobile
GLX Version: 2.1 Mesa 11.0.6
Audio: Card Intel 5 Series/3400 Series High Definition Audio
driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.2.0-0.bpo.1-amd64
Network: Card-1: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe driver: tg3
IF: eth0 state: down mac: 1c:75:08:17:be:56
Card-2: Broadcom BCM43225 802.11b/g/n driver: wl
IF: wlan0 state: up mac: 4c:0f:6e:7c:12:b4
Drives: HDD Total Size: 516.1GB (2.4% used)
ID-1: /dev/sda model: WDC_WD5000BEVT size: 500.1GB
ID-2: USB /dev/sdb model: Multi size: 16.0GB
Partition: ID-1: / size: 457G used: 9.7G (3%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 2.17GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 33.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 182 Uptime: 1 min Memory: 288.3/3630.9MB
Client: Shell (bash) inxi: 2.2.31
Acer Aspire 5742: Intel i3 M370, Intel HD graphics, 4 GB ram, 500 GB hdd, Broadcom wireless n adapter

User avatar
dbvolvox
Forum Novice
Forum  Novice
Posts: 1
Joined: Fri Dec 18, 2015 4:50 am

Re: Laptops

#30 Post by dbvolvox » Fri Jan 29, 2016 5:30 am

Dual boot on HP255 G4 with bunsen labs with shared home partition and same conky.

inxi -F

Code: Select all

System:    Host: david-lap Kernel: 4.2-3.dmz.3-liquorix-amd64 x86_64 (64 bit) Desktop: Xfce 4.12.2
           Distro: MX-15-b2_x64 Fusion 24 November 2015
Machine:   System: Hewlett-Packard product: HP 255 G4 Notebook PC v: Type1ProductConfigId
           Mobo: Hewlett-Packard model: 80CB v: 99.09 Bios: Insyde v: F.0C date: 06/25/2015
CPU:       Quad core AMD A6-6310 APU with AMD Radeon R4 Graphics (-MCP-) cache: 8192 KB 
           clock speeds: max: 1800 MHz 1: 1400 MHz 2: 1200 MHz 3: 1800 MHz 4: 1000 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R4/R5 Graphics]
           Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: Gallium 0.4 on AMD MULLINS GLX Version: 3.0 Mesa 10.3.2
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.2-3.dmz.3-liquorix-amd64
Network:   Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be
           IF: wlan0 state: down mac: 18:4f:32:a1:9d:21
           Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169
           IF: eth0 state: up speed: 10 Mbps duplex: full mac: b0:5a:da:ca:82:1d
           Card-3: Realtek RTL8192CU 802.11n WLAN Adapter
           IF: null-if-id state: N/A mac: N/A
Drives:    HDD Total Size: 500.1GB (16.2% used) ID-1: /dev/sda model: ST500LT012 size: 500.1GB
Partition: ID-1: / size: 57G used: 4.1G (8%) fs: ext4 dev: /dev/sda8
           ID-2: /home size: 349G used: 65G (20%) fs: ext4 dev: /dev/sda6
           ID-3: swap-1 size: 7.43GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 37.1C mobo: 20.0C gpu: 38.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 198 Uptime: 1:13 Memory: 858.2/3414.4MB Client: Shell (bash) inxi: 2.2.31 

Post Reply

Return to “Documentation and videos”