Welcome!

Please read this important information about Spectre and Meltdown vulnerabilities.
Please read this important information about MX sources lists.

News
  • MX Linux on social media: here
  • Mepis support still here
Current releases
  • MX-17.1 Final release info here
  • antiX-17 release info here
New users
  • Please read this first, and don't forget to add system and hardware information to posts!
  • Read Forum Rules

Horizon Speaker Jack Issue SOLVED CF-54 MK2

For issues with MX that has been modified from the initial install. Example: adding packages that then cause issues.
Message
Author
tbuser48
Forum Novice
Forum  Novice
Posts: 11
Joined: Mon Aug 14, 2017 9:58 pm

Horizon Speaker Jack Issue SOLVED CF-54 MK2

#1 Postby tbuser48 » Wed Mar 14, 2018 3:24 pm

Here's my hearty recommendation for Linux for CF-54 MK2. :uhhuh:

Works out of the box. Touch calibration is spot on and multi-touch works.

UEFI disabled in bios at the present time.

Kernel is upgraded via MX-Package Installer to (see EDIT below) then cloned for LiveUSB or copied via Snapshot and saved as snapshot.iso.
EDIT

Code: Select all

  $ uname -a
Linux mx17 4.15.0-1-amd64 #1 SMP Debian 4.15.4-1~mx17+1 (2018-02-23) x86_64 GNU/Linux
END EDIT
-----------------------------------------------------------------------
Speaker Jack may not be functional with some Linux Distros.

This is my first tweak for MX17 Horizon on the CF-54.

This writes a PERMANENT file called sound.conf and enables a feature in snd-hda-intel. Call it a software switch. W10 does this automatically.

Code:

Code: Select all

$ su
Password:
root@mx54:/home/m17# echo "options snd-hda-intel model=headset-mode" > /etc/modprobe.d/sound.conf

Code: Select all

To remove the file:
sudo rm /etc/modprobe.d/sound.conf


Waiting on a mike for this headset...so mike untested. :popcorn:

Code: Select all

System:    Host: mx17 Kernel: 4.14.0-3-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
           Distro: MX-17_x64 Horizon December 15, 2017
Machine:   Device: laptop System: Panasonic product: CF-54-2 v: 002 serial: N/A
           Mobo: Panasonic model: CF54-2 v: 1 serial: N/A
           UEFI [Legacy]: American Megatrends v: V2.00L18 date: 05/11/2017
Battery    BAT1: charge: 8.3 Wh 18.3% condition: 45.3/45.3 Wh (100%)
CPU:       Dual core Intel Core i5-6300U (-MT-MCP-) cache: 3072 KB
           clock speeds: max: 3000 MHz 1: 500 MHz 2: 500 MHz 3: 500 MHz 4: 500 MHz
Graphics:  Card: Intel HD Graphics 520
           Display Server: x11 (X.Org 1.19.2 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1360x768@59.80hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) version: 4.5 Mesa 13.0.6
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.14.0-3-amd64
Network:   Card-1: Intel Ethernet Connection I219-LM driver: e1000e
           IF: eth0 state: down mac: bc:c3:42:8d:c3:e1
           Card-2: Intel Wireless 8260 driver: iwlwifi
           IF: wlan0 state: up mac: f8:63:3f:6d:26:44
Drives:    HDD Total Size: 384.1GB (2.9% used)
           ID-1: /dev/sda model: SAMSUNG_SSD_PM83 size: 128.0GB
           ID-2: /dev/sdb model: INTEL_SSDSCKKF25 size: 256.1GB
Partition: ID-1: / size: 232G used: 6.4G (3%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
           ID-3: swap-2 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sdb2
Sensors:   System Temperatures: cpu: 25.9C mobo: 24.5C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 193 Uptime: 14 min Memory: 592.2/3838.1MB Client: Shell (bash) inxi: 2.3.54
You do not have the required permissions to view the files attached to this post.

Return to “MX Modified”

Who is online

Users browsing this forum: No registered users and 2 guests