Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Failed to install budgie desktop in MX

For issues with MX that has been modified from the initial install. Example: adding packages that then cause issues.
Message
Author
User avatar
vamsi
Forum Regular
Forum Regular
Posts: 442
Joined: Thu Apr 13, 2017 2:50 am

Failed to install budgie desktop in MX

#1 Post by vamsi » Wed Feb 14, 2018 1:55 am

Code: Select all

sudo apt install budgie-desktop gnome-tweak-tool budgie-desktop-doc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 budgie-desktop : Depends: gnome-control-center but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
This is the error i got i first tried to install through package installer but when i click on install it just displays something and closes fast that i can't see anything so i used this command from information button in package installer i got this error is there any chance to fix this error

Thanks..

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 3438
Joined: Sun May 27, 2007 5:37 am

Re: Failed to install budgie desktop in MX

#2 Post by asqwerth » Wed Feb 14, 2018 2:48 am

Recent Versions of budgie no longer need gnome tweak tool as budgie now has its own budgie settings tool. I'm not sure if the budgie version compatible with Debian stretch has been updated to at least that version. Could you search for this in synaptic?

Or try installing with MXPI. [Oops. Ignore this line]
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22636
Joined: Wed Jul 19, 2006 6:13 am

Re: Failed to install budgie desktop in MX

#3 Post by Jerry3904 » Wed Feb 14, 2018 3:35 am

Huh. I have installed Budgie a number of times using MX Package Installer without any problem, including less than 24 hours ago.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 3438
Joined: Sun May 27, 2007 5:37 am

Re: Failed to install budgie desktop in MX

#4 Post by asqwerth » Wed Feb 14, 2018 4:38 am

@vamsi,

Based on Jerry's post, I suspect you have conflicting packages due to your mixing of repos and/or installing packages from various other sources.

Could you list your sources with

Code: Select all

inxi -r
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
vamsi
Forum Regular
Forum Regular
Posts: 442
Joined: Thu Apr 13, 2017 2:50 am

Re: Failed to install budgie desktop in MX

#5 Post by vamsi » Wed Feb 14, 2018 5:47 am

asqwerth wrote:@vamsi,

Based on Jerry's post, I suspect you have conflicting packages due to your mixing of repos and/or installing packages from various other sources.

Could you list your sources with

Code: Select all

inxi -r
Ok here is the output

Code: Select all

Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://ppa.launchpad.net/canonical-chromium-builds/stage/ubuntu/ xenial main
           deb http://ppa.launchpad.net/noobslab/icons/ubuntu/ xenial main
           deb http://ppa.launchpad.net/elementary-add-team/icons/ubuntu/ xenial main
           deb http://ppa.launchpad.net/oranchelo/oranchelo-icon-theme/ubuntu/ xenial main
           deb http://ppa.launchpad.net/whizzzkid/bingwallpaper/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/antix.list
           deb http://it.mxrepo.com/antix/stretch/ stretch main
           Active apt sources in file: /etc/apt/sources.list.d/debian-stable-updates.list
           deb http://kartolo.sby.datautama.net.id/debian/ stretch-updates non-free contrib main
           Active apt sources in file: /etc/apt/sources.list.d/debian.list
           deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
           deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt sources in file: /etc/apt/sources.list.d/mx.list
           deb http://it.mxrepo.com/mx/repo/ stretch non-free main
           deb http://it.mxrepo.com/mx/testrepo/ stretch test
           Active apt sources in file: /etc/apt/sources.list.d/various.list
           deb http://download.virtualbox.org/virtualbox/debian/ stretch contrib
I too installed it once a long back but now only i am getting this error

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5737
Joined: Sat Jul 15, 2006 10:40 am

Re: Failed to install budgie desktop in MX

#6 Post by anticapitalista » Wed Feb 14, 2018 6:28 am

vamsi wrote:
Ok here is the output

Code: Select all

Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://ppa.launchpad.net/canonical-chromium-builds/stage/ubuntu/ xenial main
           deb http://ppa.launchpad.net/noobslab/icons/ubuntu/ xenial main
           deb http://ppa.launchpad.net/elementary-add-team/icons/ubuntu/ xenial main
           deb http://ppa.launchpad.net/oranchelo/oranchelo-icon-theme/ubuntu/ xenial main
           deb http://ppa.launchpad.net/whizzzkid/bingwallpaper/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/antix.list
           deb http://it.mxrepo.com/antix/stretch/ stretch main
           Active apt sources in file: /etc/apt/sources.list.d/debian-stable-updates.list
           deb http://kartolo.sby.datautama.net.id/debian/ stretch-updates non-free contrib main
           Active apt sources in file: /etc/apt/sources.list.d/debian.list
           deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
           deb http://security.debian.org/ stretch/updates main contrib non-free
           Active apt sources in file: /etc/apt/sources.list.d/mx.list
           deb http://it.mxrepo.com/mx/repo/ stretch non-free main
           deb http://it.mxrepo.com/mx/testrepo/ stretch test
           Active apt sources in file: /etc/apt/sources.list.d/various.list
           deb http://download.virtualbox.org/virtualbox/debian/ stretch contrib
I too installed it once a long back but now only i am getting this error

Oh dear!
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
asqwerth
Forum Veteran
Forum Veteran
Posts: 3438
Joined: Sun May 27, 2007 5:37 am

Re: Failed to install budgie desktop in MX

#7 Post by asqwerth » Wed Feb 14, 2018 6:32 am

Oh boy. PPAs galore. Surely you know better by now. Ubuntu is not Debian.

I'm sure the conflict is due to the Ubuntu PPAs. The icon ones are not a concern, but the rest are.

Someone more experienced will have to help you revert your system to something sane, if possible.
Desktop: Intel i5-4460, 16GB RAM, Intel integrated graphics
Clevo N130WU-based Ultrabook: Intel i7-8550U (Kaby Lake R), 16GB RAM, Intel integrated graphics (UEFI)
ASUS X42D laptop: AMD Phenom II, 6GB RAM, Mobility Radeon HD 5400

User avatar
stsoh
Forum Regular
Forum Regular
Posts: 405
Joined: Sun Aug 20, 2017 10:11 am

Re: Failed to install budgie desktop in MX

#8 Post by stsoh » Wed Feb 14, 2018 6:40 am

oh dear!! oh dear!!
MX-17.1_x64 Horizon, G41M-P33 Combo(MS-7592), Pentium E5400 (min/max: 1203/2700 MHz), 8Gb RAM (800 MT/s),
Intel 4 Series Integrated Graphics, Realtek PCIe Fast RTL8101/2/6E, PCI Gigabit RTL8169 Ethernets.

User avatar
chrispop99
Forum Guide
Forum Guide
Posts: 2426
Joined: Tue Jan 27, 2009 3:07 pm

Re: Failed to install budgie desktop in MX

#9 Post by chrispop99 » Wed Feb 14, 2018 8:14 am

You should never, ever use PPA's with anything other than Ubuntu, or a system that is based on Ubuntu. Even then, there are some risks.

Also, in my experience, if you want to experiment with a desktop that is not the one the developers used, you need to do so from a fresh install, fulyl updated.

Chris
Test machines:
32-bit non-PAE - Thinkpad T41, 1.6GHz Pentium M, 1GB RAM.
32-bit PAE - DELL Latitude D610, 1.73GHz Pentium M, 2GB RAM.
64-bit - Lenovo T61, 2GHz Core 2 Duo, 2GB RAM
64-bit - Gigabyte Z77P-D3, Intel i3-3220, GeForce 8400 GS, 4GB PC3-12800.

User avatar
dolphin_oracle
Forum Veteran
Forum Veteran
Posts: 9548
Joined: Sun Dec 16, 2007 1:17 pm

Re: Failed to install budgie desktop in MX

#10 Post by dolphin_oracle » Wed Feb 14, 2018 9:08 am

when I get errors like that, I keep checking the failed depends manually until I find a likely culprit. The dependency chains can be long. Even a theme deb from the ubuntu ppa could conceivably have a dependency that would prevent installation of a package.

so you could try

Code: Select all

apt-get install -s gnome-control-center
and see what errors you get, and keep drilling down through those errors. maybe you will discover what package is the barrier and be able to remove it.


also, mx-pi creates a log in /var/log/mxpi.log that stores those errors, although in this case its likely the same as you've posted already.
http://www.youtube.com/runwiththedolphin
lenovo ThinkPad T530 - MX-17
lenovo s21e & 100s - antiX-17, MX17(live-usb)
FYI: mx "test" repo is not the same thing as debian testing repo.

Post Reply

Return to “MX Modified”