Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

[SOLVED] Random freezing

For issues with MX that has been modified from the initial install. Example: adding packages that then cause issues.
Post Reply
Message
Author
csaenemy
Forum Novice
Forum  Novice
Posts: 7
Joined: Sat Dec 23, 2017 4:46 pm

[SOLVED] Random freezing

#1 Post by csaenemy » Tue Dec 26, 2017 11:17 am

I installed MX-17 just before Christmas and like it very much. Unfortunately though, I have been experiencing regular freeze ups at random times. I have installed Alpine, Ranger, Cmus, Calcurse, Deadbeef, Gnuplot and Deluge. I have disabled screensaver and switched off power saving and desktop changer. I have enabled display compositing. Prior to this I was running Debian for a couple of years on the same PC with no issues. I have 4Gb of memory and Conky suggests only a fraction of that being used.
Freeze ups have occurred when using Firefox and when using GIMP. There are no clues in kern.log.
Any ideas?
Last edited by csaenemy on Fri Dec 29, 2017 4:07 pm, edited 1 time in total.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4421
Joined: Wed Jul 12, 2006 4:05 pm

Re: Random freezing

#2 Post by timkb4cq » Tue Dec 26, 2017 11:31 am

My desktop with integrated GeForce 8300 graphics will freeze on any Linux distro after a few hours use unless I install the proprietary nVidia driver. It's absolutely stable under MX with the driver.
If you have nVidia graphics, try that first.
If you don't, then please copy & paste your Quick System Info from MX Tools so we have an idea of what hardware you are running.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

csaenemy
Forum Novice
Forum  Novice
Posts: 7
Joined: Sat Dec 23, 2017 4:46 pm

Re: Random freezing

#3 Post by csaenemy » Tue Dec 26, 2017 11:35 am

Code: Select all

System:    Host: mx1 Kernel: 4.13.0-1-amd64 x86_64 bits: 64 Desktop: Xfce 4.12.3
           Distro: MX-17_x64 Horizon December 15, 2017
Machine:   Device: desktop System: LENOVO product: 90C20005UK v: Lenovo H30-00 serial: N/A
           Mobo: LENOVO model: Aptio CRB v: SDK0F82993 WIN serial: N/A
           UEFI [Legacy]: LENOVO v: O07KT43AUS date: 08/13/2014
CPU:       Quad core Intel Pentium J2900 (-MCP-) cache: 1024 KB
           clock speeds: max: 2665 MHz 1: 2415 MHz 2: 2415 MHz 3: 2415 MHz 4: 2415 MHz
Graphics:  Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
           Display Server: x11 (X.Org 1.19.2 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel Bay Trail version: 3.3 Mesa 13.0.6
Audio:     Card Intel Atom Processor Z36xxx/Z37xxx Series High Def. Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-1-amd64
Network:   Card: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller driver: r8169
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: c0:3f:d5:ea:f8:01
Drives:    HDD Total Size: 4500.9GB (6.9% used)
           ID-1: /dev/sda model: WDC_WD5000AAKX size: 500.1GB
           ID-2: USB /dev/sdc model: External_USB_3.0 size: 1000.2GB
           ID-3: USB /dev/sdd model: External_USB_3.0 size: 3000.6GB
Partition: ID-1: / size: 456G used: 7.6G (2%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 212 Uptime: 3:07 Memory: 888.3/3846.5MB Client: Shell (bash) inxi: 2.3.53

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4421
Joined: Wed Jul 12, 2006 4:05 pm

Re: Random freezing

#4 Post by timkb4cq » Tue Dec 26, 2017 11:52 am

That particular Intel graphics processor is known to have problems with the modesetting driver that it is currently running.

You can switch to the proper intel driver by creating a 20-intel.conf text file with this in it:

Code: Select all

Section "Device"
        Identifier  "Device0"
        Driver      "intel"
#       BusID       "PCI:0:2:0"
#       Option      "AccelMethod" "sna"
        Option      "DRI"    "true"
#       Option      "TearFree"  "true"
#       Option "DRI" "3"
EndSection
Some of the commented out options may improve performance if uncommented, but first let's get it stable. You can try uncommenting them later.

Copy this file to the correct location:

Code: Select all

sudo cp 20-intel.conf /etc/X11/xorg.conf.d/
then reboot.
Upon booting up, your Quick System Info should now show intel where it used to show modesetting and the lockups should cease.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

csaenemy
Forum Novice
Forum  Novice
Posts: 7
Joined: Sat Dec 23, 2017 4:46 pm

Re: Random freezing

#5 Post by csaenemy » Tue Dec 26, 2017 12:11 pm

Thank you for this. I have done as you suggest and will give it a day or two. All being well I will be marking as solved in due course.

csaenemy
Forum Novice
Forum  Novice
Posts: 7
Joined: Sat Dec 23, 2017 4:46 pm

Re: Random freezing

#6 Post by csaenemy » Tue Dec 26, 2017 1:10 pm

Unfortunately crashed after 22 minutes with no programs running.

User avatar
timkb4cq
Forum Veteran
Forum Veteran
Posts: 4421
Joined: Wed Jul 12, 2006 4:05 pm

Re: Random freezing

#7 Post by timkb4cq » Wed Dec 27, 2017 11:50 pm

Since your processor is a Bay Trail model, this may be the solution to your freezes.
Archwiki wrote:Baytrail complete freeze

If you are using kernel > 3.16 on Baytrail architecture and randomly encounter total system freezes, the following kernel option is a workaround until this bug is fixed in the linux kernel.

intel_idle.max_cstate=1

This is originally an Intel CPU bug that can be triggered by certain c-state transitions. It can also happen with Linux kernel 3.16 or Windows, though apparently much more rarely. The kernel option will prevent the freeze by avoiding c-state transitions but will also increase power consumption.
The kernel option is added to the GRUB_CMDLINE_LINUX_DEFAULT= line in /etc/default/grub file - separated from anything prior on the line by a space and inside the quotes. This will have to be done using right-click "Edit as root". Run

Code: Select all

sudo update-grub 
afterwards, then reboot.
MSI 970A-G43 MB, AMD FX-6300 (six core), 16GB RAM, GeForce 730, Samsung 850 EVO 250GB SSD, Seagate Barracuda XT 3TB

csaenemy
Forum Novice
Forum  Novice
Posts: 7
Joined: Sat Dec 23, 2017 4:46 pm

Re: Random freezing

#8 Post by csaenemy » Thu Dec 28, 2017 12:30 pm

I will bear this in mind.
I tried removing the # from before:

Code: Select all

Option      "AccelMethod" "sna"
in the 20-intel.conf file and so far no freezing for 22 hours. I don't know whether it's made a difference, or why it should have, but am keeping my fingers crossed.

Post Reply

Return to “MX Modified”