Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

stretched MX-16 problems

For issues with MX that has been modified from the initial install. Example: adding packages that then cause issues.
Message
Author
User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22209
Joined: Wed Jul 19, 2006 6:13 am

Re: stretched MX-16 problems

#11 Post by Jerry3904 » Sat Jul 01, 2017 4:22 pm

Thanks to Tim and Stevo. I wasn't very clear in my OP: my interest is not to set this up for my own use, but to try and document where problems might arise for MX-17 as we go forth.
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15949
Joined: Fri Dec 15, 2006 8:07 pm

Re: stretched MX-16 problems

#12 Post by Stevo » Sat Jul 01, 2017 7:20 pm

If you are using youtubedl-gui, that can download and use the latest youtube-dl within the application..as can QMPlay2.

I do have plain vanilla jessie and stretch builds of smtube in my OBS repo, though the Stretch version is still built against Qt 4--I think I'll fix that. http://forums.debian.net/viewtopic.php?f=6&t=127574

https://build.opensuse.org/package/show ... ert/SMTube

I think I can pull a trick with the build-depends to get it to use Qt 4 if Qt 5 is older than 5.6, so I don't have to split the Stretch version into a different package like I did for ffmpeg.

Here's the smtube 17.5.0 MX 17 packages built on Stretch: https://drive.google.com/open?id=0BxE7w ... Vo1NXRVekU

They work in the antiX 17 beta, too.

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15949
Joined: Fri Dec 15, 2006 8:07 pm

Re: stretched MX-16 problems

#13 Post by Stevo » Sat Jul 01, 2017 7:47 pm

The trick worked! Just these alternative build-depends make it use Qt 4 forJessie and Qt 5 for Stretch:

Code: Select all

 qt5-default (>= 5.6) | libqt4-dev (>= 4.6),
 libqt5webkit5-dev (>= 5.6) | libqtwebkit-dev,
 qttools5-dev-tools (>= 5.6) | libqt4-dev (>= 4.6),
 qtscript5-dev (>= 5.6) | libqt4-dev (>= 4.6)

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5669
Joined: Sat Jul 15, 2006 10:40 am

Re: stretched MX-16 problems

#14 Post by anticapitalista » Sun Jul 02, 2017 5:59 am

stevo - for smtube stretch you need to change gnome-mplayer with gnome-mpv since gnome-mplayer is not in stretch and is deprecated.

Here is a patch.
You do not have the required permissions to view the files attached to this post.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15949
Joined: Fri Dec 15, 2006 8:07 pm

Re: stretched MX-16 problems

#15 Post by Stevo » Sun Jul 02, 2017 4:54 pm

Thanks for finding that! But we don't need to patch anything in the debian folder, I can just edit the control file directly to add the gnome-mpv alternative dependency. I'll update the package.

Hmm, it also works with Dragon Player and QMPlay2, I can add those.

Edit: I also see that Stretch's xfce and Qt 5 doesn't suffer from the missing systray icon bug, like we had for qBittorrent when built on Qt 5, so that's good.
Last edited by Stevo on Sun Jul 02, 2017 5:42 pm, edited 1 time in total.

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5669
Joined: Sat Jul 15, 2006 10:40 am

Re: stretched MX-16 problems

#16 Post by anticapitalista » Sun Jul 02, 2017 5:18 pm

You're the packager, stevo and know best.

Sorry to OP jerry for dragging this thread off topic.
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
Jerry3904
Forum Veteran
Forum Veteran
Posts: 22209
Joined: Wed Jul 19, 2006 6:13 am

Re: stretched MX-16 problems

#17 Post by Jerry3904 » Sun Jul 02, 2017 5:32 pm

No, this is the topic actually: what problems do we have to consider with the move to Stretch? I know you're way ahead on this...
Production: 4.15.0-1-amd64, MX-17.1, AMD FX-4130 Quad-Core, GeForce GT 630/PCIe/SSE2, 8 GB, Kingston SSD 120 GB and WesternDigital 1TB
Testing: AAO 722: 4.15.0-1-386. MX-17.1, AMD C-60 APU, 4 GB

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5669
Joined: Sat Jul 15, 2006 10:40 am

Re: stretched MX-16 problems

#18 Post by anticapitalista » Mon Jul 03, 2017 4:54 pm

Stevo wrote:Thanks for finding that! But we don't need to patch anything in the debian folder, I can just edit the control file directly to add the gnome-mpv alternative dependency. I'll update the package.

Hmm, it also works with Dragon Player and QMPlay2, I can add those.

Edit: I also see that Stretch's xfce and Qt 5 doesn't suffer from the missing systray icon bug, like we had for qBittorrent when built on Qt 5, so that's good.
stevo - have you packaged the new/new version?
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

User avatar
Stevo
Forum Veteran
Forum Veteran
Posts: 15949
Joined: Fri Dec 15, 2006 8:07 pm

Re: stretched MX-16 problems

#19 Post by Stevo » Mon Jul 03, 2017 5:27 pm

Whoops--I only did it in the OBS: https://build.opensuse.org/package/show ... ert/SMTube

If you can't use those sources and packages, I can do them in a couple minutes in antiX virtual machines. If that, do you want some kind of branding in the version, like "17.5.0.-1antix1"?

I also got sidetracked by finding out that the "apt install" command in Stretch can now install standalone debs and their dependencies, though it seems to throw a nasty yet harmless warning at the end. Tested with conky-legacy-all, and it correctly removed conky-all first. If it can install more than one deb at once, that puts it ahead of gdebi.

User avatar
anticapitalista
Forum Veteran
Forum Veteran
Posts: 5669
Joined: Sat Jul 15, 2006 10:40 am

Re: stretched MX-16 problems

#20 Post by anticapitalista » Mon Jul 03, 2017 5:45 pm

I can't download the file package: No data for home:stevepassert / SMTube

17.5.0.-1antix1 seems good to me
anticapitalista
Reg. linux user #395339.

Philosophers have interpreted the world in many ways; the point is to change it.

antiX-17 "Heather Heyer" - lean and mean.
https://antixlinux.com

Post Reply

Return to “MX Modified”