Welcome!
Important information
-- Spectre and Meltdown vulnerabilities
-- Change in MX sources

News
-- MX Linux on social media: here
-- Mepis support still here

Current releases
-- MX-17.1 Final release info here
-- antiX-17 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Search found 2639 matches

by Adrian
Sat May 26, 2018 4:10 pm
Forum: Bugs and Non-Package Requests Forum
Topic: BUG: mx-installer 18.4.04 wrong group-ownership of user-account
Replies: 24
Views: 300

Re: BUG: mx-installer 18.4.04 wrong group-ownership of user-account

dolphin_oracle wrote:
Sat May 26, 2018 4:07 pm
Ok I've been working with gazelle-installer today anyway. I'll send up the change in a bit.
I edited directly in github, do a pull before you push, it should work fine I think.
by Adrian
Sat May 26, 2018 3:49 pm
Forum: Bugs and Non-Package Requests Forum
Topic: BUG: mx-installer 18.4.04 wrong group-ownership of user-account
Replies: 24
Views: 300

Re: BUG: mx-installer 18.4.04 wrong group-ownership of user-account

OK, let's replace everywhere with:

Code: Select all

cmd = QString("chown -R demo:demo %1").arg(dpath);
fehlix, you were right, thanks for the bug report! What is confusing is that some folders are handled by xdg and some are modified by installer.
by Adrian
Sat May 26, 2018 3:34 pm
Forum: Bugs and Non-Package Requests Forum
Topic: BUG: mx-installer 18.4.04 wrong group-ownership of user-account
Replies: 24
Views: 300

Re: BUG: mx-installer 18.4.04 wrong group-ownership of user-account

Should we change users to demo?
cmd = QString("chown -R demo.users %1").arg(dpath);
Also, see the explanation about . or : in chown: https://serverfault.com/questions/19429 ... p-in-chown
by Adrian
Sat May 26, 2018 3:26 pm
Forum: Bugs and Non-Package Requests Forum
Topic: BUG: mx-installer 18.4.04 wrong group-ownership of user-account
Replies: 24
Views: 300

Re: BUG: mx-installer 18.4.04 wrong group-ownership of user-account

dolphin_oracle wrote:
Sat May 26, 2018 3:16 pm
should that be something like demo.users:demo.users
No, demo.users is fine. But users id is indeed 100. Now the question is why I see that 1000 on my installed system?
by Adrian
Sat May 26, 2018 3:13 pm
Forum: Hardware /Configuration
Topic: [SOLVED] Usb mouses not detected after plug out and replug
Replies: 8
Views: 69

Re: [SOLVED] Usb mouses not detected after plug out and replug

Great! And by the way, welcome on the forum!
by Adrian
Sat May 26, 2018 2:38 pm
Forum: General
Topic: Dedoimedo back to MX Tools
Replies: 9
Views: 317

Re: Dedoimedo back to MX Tools

He has a good point about visual consistency of the tools, I worked hard to make the tools I'm working on a bit consistent but I'm not that good with GUIs and design... I think we have an issue with the icons of the tools they are not pretty consistent.
by Adrian
Sat May 26, 2018 2:37 pm
Forum: Hardware /Configuration
Topic: [SOLVED] Usb mouses not detected after plug out and replug
Replies: 8
Views: 69

Re: Usb mouses not detected after plug out and replug

What do you see in dmesg when you plug in the mouse?
by Adrian
Sat May 26, 2018 2:20 pm
Forum: Hardware /Configuration
Topic: [SOLVED] Usb mouses not detected after plug out and replug
Replies: 8
Views: 69

Re: Usb mouses not detected after plug out and replug

I wonder if it's a BIOS option, can you check your BIOS options and see if you see anything related to USB?
by Adrian
Sat May 26, 2018 2:00 pm
Forum: Bugs and Non-Package Requests Forum
Topic: BUG: mx-installer 18.4.04 wrong group-ownership of user-account
Replies: 24
Views: 300

Re: BUG: mx-installer 18.4.04 wrong group-ownership of user-account

On my box, it is an old install of antiX. I think something else must have changed the permissions xdg perhaps? There was a security upgrade of xdg-utils a few days ago. That's a good point, it might happen after the install, however, I don't see that happening with fully updated MX16 and MX17 (I d...
by Adrian
Sat May 26, 2018 1:50 pm
Forum: Bugs and Non-Package Requests Forum
Topic: BUG: mx-installer 18.4.04 wrong group-ownership of user-account
Replies: 24
Views: 300

Re: BUG: mx-installer 18.4.04 wrong group-ownership of user-account

Is this something related to persistency by any chance? Did any of you use persistency at any point?

Go to advanced search