Welcome!

The kernel problem with recent updates has been solved. Find the solution here

Important information
-- Required MX 15/16 Repository Changes
-- Information on torrent hosting changes
-- Information on MX15/16 GPG Keys
-- Spectre and Meltdown vulnerabilities

News
-- Introducing our new Website
-- MX Linux on social media: here

Current releases
-- MX-18.3 Point Release release info here
-- Migration Information to MX-18 here
-- antiX-17.4.1 release info here

New users
-- Please read this first, and don't forget to add system and hardware information to posts!
-- Here are the Forum Rules

Search found 429 matches

by Buck Fankers
Sun Sep 15, 2019 5:51 pm
Forum: MX Help
Topic: get ridding of beep on exit
Replies: 2
Views: 99

Re: get ridding of beep on exit

PhantomTramp wrote:
Sun Sep 15, 2019 4:00 pm
Edit:
"/etc/modprobe.d/pc-speaker.conf"
and add line:
"blacklist pcspkr"

viewtopic.php?t=49149
Will check it out, thanks.
Oh and thank you for that link. I was searching with duckduckgo but I didn't search MX forums, my bad, that link is full of info!
by Buck Fankers
Sun Sep 15, 2019 2:54 pm
Forum: MX Help
Topic: get ridding of beep on exit
Replies: 2
Views: 99

get ridding of beep on exit

For some reason I need kernel 4.9 and this one beeps on exit. I would like to get rid of this beeps. Beeps when I bring up exit menu and beeps on actual shutdown. (beeps on restart too I think) Kernel 4.19 doesn't beeps but unfortunately that computer needs to be on kernel 4.9 I'm traveling (differe...
by Buck Fankers
Sun Sep 15, 2019 4:51 am
Forum: MX Help
Topic: [SOLVED] Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9
Replies: 9
Views: 219

Re: Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9

What about doing it manually after installing 4.9 ? https://github.com/antoineco/broadcom-wl.git The following kernel modules are incompatible with this driver and should not be loaded: Huckleberry, thanks for the help! Never did any manual driver install, so it was interesting read. Now I got the ...
by Buck Fankers
Sun Sep 15, 2019 4:48 am
Forum: MX Help
Topic: [SOLVED] Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9
Replies: 9
Views: 219

Re: Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9

Boot to the 4.9 Debian kernel and run in the terminal: sudo dpkg-reconfigure broadcom-sta-dkms If you see where the error in the build occurs, copy and paste that section in a post here. If you don't, copy and paste the whole thing, in code tags. This worked, thank you very much for your help. Sinc...
by Buck Fankers
Sun Sep 15, 2019 4:40 am
Forum: MX Help
Topic: [SOLVED] Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9
Replies: 9
Views: 219

Re: Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9

sudo dpkg-reconfigure broadcom-sta-dkms and let's see the output from that. This did it, thank you and @Stevo I noticed something, maybe normal but just in case bellow is output, i ran your code in 4.9 but seems dksm was reinstalled also for 4.19 but not for third installed kernel 4.14. I would gue...
by Buck Fankers
Sat Sep 14, 2019 7:14 pm
Forum: MX Help
Topic: [SOLVED] Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9
Replies: 9
Views: 219

Re: Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9

Kernel entry for the debian kernel will install 4.9, the headers, and rebuild the broadcom wifi drivers. I uninstalled antiX 4.9 kernel, install Debian one, headers were installed, but situation is the same, there is no wi-fi, inxi -n shows: driver: N/A, and of course no info about bus ID, kernel p...
by Buck Fankers
Sat Sep 14, 2019 6:57 pm
Forum: MX Help
Topic: [SOLVED] Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9
Replies: 9
Views: 219

Re: Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9

did you also install the header files with the kernel? the mx-packageinstaller->PopularApps ->Kernel entry for the debian kernel will install 4.9, the headers, and rebuild the broadcom wifi drivers. the broadcom drivers are not in the kernel and have to be rebuilt when installed. Thanks. I used mxp...
by Buck Fankers
Sat Sep 14, 2019 6:36 pm
Forum: MX Help
Topic: [SOLVED] Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9
Replies: 9
Views: 219

[SOLVED] Wi-fi works on 4.19, but not on 4.14 or 4.9, need 4.9

I need to set 4.9 kernel or at least 4.14 since I will not be in this country for 2-3 years and setting this (former win 7) computer for some elderly person and I need (very) LTS. Unfortunately wi-fi is not working on 4.9 or 4.14. - there are no available networks, wi-fi device or driver is down Her...
by Buck Fankers
Thu Sep 12, 2019 3:41 am
Forum: Package Requests/Status - MX-19
Topic: Porting nanoVNA to MX?
Replies: 10
Views: 245

Re: Porting nanoVNA to MX?

I've been stalling to see when MX 19 will be released ... You don't have to wait on 19. There are few options. For me, easiest would be to install miniconda. You would have to check the site though, there are few commands to learn. But you can download inside miniconda any Python version and run pr...
by Buck Fankers
Tue Sep 10, 2019 3:46 pm
Forum: MX Help
Topic: Cannot boot into system after installing graphics drivers [SOLVED]
Replies: 21
Views: 453

Re: Cannot boot into system after installing graphics drivers

Via liveUSB I deleted the xorg text file. Booting up again did nothing. Sometimes reinstall is faster. You had another option, boot vie live USB, then CHROOT into installed system with sudo chroot-rescue-scan Then you can delete, reinstall, purge... whatever you do, it affects your installed system...

Go to advanced search